dev-php/sebastian-environment: Version bump for 4.2.3
authorBrian Evans <grknight@gentoo.org>
Thu, 19 Dec 2019 18:36:47 +0000 (13:36 -0500)
committerBrian Evans <grknight@gentoo.org>
Thu, 19 Dec 2019 19:46:56 +0000 (14:46 -0500)
Signed-off-by: Brian Evans <grknight@gentoo.org>
dev-php/sebastian-environment/Manifest
dev-php/sebastian-environment/files/autoload-4.2.3.php [new file with mode: 0644]
dev-php/sebastian-environment/sebastian-environment-4.2.3.ebuild [new file with mode: 0644]

index a274953f920d95072e4864e8536fae1b52b5c6c4..c7e3c89a8d1573b14253661753fd8120a682395b 100644 (file)
@@ -1 +1,2 @@
 DIST sebastian-environment-2.0.0.tar.gz 5607 BLAKE2B 3c34c6e61d9a0bdc5df8083331390935bd513d735a1509890a9af05be8b5a718bbb1d5826ab0cb80da2ee5c4cd436b22ef4ccb50c7b4e1c11d361a78b51621c3 SHA512 cf91f0a5f057007f318c5d6b11f8a1345b8df35d513c6291c5b725f0874ed301a64d1097c3fac1e6b32533caa96b3f78ac415d99b9b6ef63dc4a303b90d49c88
+DIST sebastian-environment-4.2.3.tar.gz 9622 BLAKE2B d90b181c3aae7c4ea8e172e5b7f897f8a93bf1edbeca19cc8a7a6f10963730ece1f267fed325a6734b1677b75cc8f5b84a5aa55be383a40b1ec2aa7a603bc668 SHA512 871a15297196b21364000d72afa73c2319e741a284c5446443ae3cacd8ce1a07b1ea3b1d8b6b1a88356fb261d093b889508cea63706341413b15f23348f77e80
diff --git a/dev-php/sebastian-environment/files/autoload-4.2.3.php b/dev-php/sebastian-environment/files/autoload-4.2.3.php
new file mode 100644 (file)
index 0000000..299c469
--- /dev/null
@@ -0,0 +1,15 @@
+<?php
+/* Autoloader for dev-php/sebastian-environment */
+
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+       require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+}
+
+\Fedora\Autoloader\Autoload::addClassMap(
+       [
+               'sebastianbergmann\environment\console' => '/Console.php',
+               'sebastianbergmann\environment\operatingsystem' => '/OperatingSystem.php',
+               'sebastianbergmann\environment\runtime' => '/Runtime.php',
+       ],
+       __DIR__
+);
diff --git a/dev-php/sebastian-environment/sebastian-environment-4.2.3.ebuild b/dev-php/sebastian-environment/sebastian-environment-4.2.3.ebuild
new file mode 100644 (file)
index 0000000..49b0a24
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/sebastian-//}"
+
+DESCRIPTION="Helps writing PHP code that has runtime-specific execution paths"
+HOMEPAGE="http://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+       >=dev-lang/php-7.1:*"
+
+src_install() {
+       insinto /usr/share/php/SebastianBergmann/Environment
+       doins -r src/*
+       newins "${FILESDIR}/autoload-4.2.3.php" autoload.php
+}