net-misc/openssh: stackprotector is broken on musl ppc
authorAnthony G. Basile <blueness@gentoo.org>
Sat, 4 May 2019 17:00:10 +0000 (13:00 -0400)
committerAnthony G. Basile <blueness@gentoo.org>
Sat, 4 May 2019 17:00:10 +0000 (13:00 -0400)
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11

net-misc/openssh/openssh-7.9_p1-r4.ebuild
net-misc/openssh/openssh-8.0_p1-r1.ebuild
net-misc/openssh/openssh-8.0_p1.ebuild

index 22614b8fc6516f955de9d432f8e05c3221a6e429..de21ccc51cbeb6d7db57ad4fea13d1c219beebae 100644 (file)
@@ -300,8 +300,8 @@ src_configure() {
                $(use_with !elibc_Cygwin hardening) #659210
        )
 
-       # stackprotect is broken on musl x86
-       use elibc_musl && use x86 && myconf+=( --without-stackprotect )
+       # stackprotect is broken on musl x86 and ppc
+       use elibc_musl && ( use x86 || use ppc ) && myconf+=( --without-stackprotect )
 
        # The seccomp sandbox is broken on x32, so use the older method for now. #553748
        use amd64 && [[ ${ABI} == "x32" ]] && myconf+=( --with-sandbox=rlimit )
index b0bcb15646df53ae359c0f56edb60c192d0c58b6..c541630005b9dd62dd204d42444d0a0d7d23d421 100644 (file)
@@ -293,8 +293,8 @@ src_configure() {
                $(use_with !elibc_Cygwin hardening) #659210
        )
 
-       # stackprotect is broken on musl x86
-       use elibc_musl && use x86 && myconf+=( --without-stackprotect )
+       # stackprotect is broken on musl x86 and ppc
+       use elibc_musl && ( use x86 || use ppc ) && myconf+=( --without-stackprotect )
 
        # The seccomp sandbox is broken on x32, so use the older method for now. #553748
        use amd64 && [[ ${ABI} == "x32" ]] && myconf+=( --with-sandbox=rlimit )
index 8c02120a21fc15cc8edc33d127b3ae63983af932..c468c3f26f80de23d107f44725dfa492db631c6a 100644 (file)
@@ -293,8 +293,8 @@ src_configure() {
                $(use_with !elibc_Cygwin hardening) #659210
        )
 
-       # stackprotect is broken on musl x86
-       use elibc_musl && use x86 && myconf+=( --without-stackprotect )
+       # stackprotect is broken on musl x86 and ppc
+       use elibc_musl && ( use x86 || use ppc ) && myconf+=( --without-stackprotect )
 
        # The seccomp sandbox is broken on x32, so use the older method for now. #553748
        use amd64 && [[ ${ABI} == "x32" ]] && myconf+=( --with-sandbox=rlimit )