dev-python/clang-python: Die on test failures
authorMichał Górny <mgorny@gentoo.org>
Mon, 24 Jul 2017 18:42:17 +0000 (20:42 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 24 Jul 2017 19:03:54 +0000 (21:03 +0200)
dev-python/clang-python/clang-python-4.0.0.ebuild
dev-python/clang-python/clang-python-4.0.1.ebuild
dev-python/clang-python/clang-python-5.0.9999.ebuild
dev-python/clang-python/clang-python-9999.ebuild

index dc7e4ee8aaab72ed94b36005442d059ad133d69f..c77ee951ec2feba14246e9db152dd11b9822eba5 100644 (file)
@@ -29,7 +29,7 @@ DEPEND="${RDEPEND}
 S=${WORKDIR}/cfe-${PV/_/}.src/bindings/python
 
 src_test() {
-       python_foreach_impl nosetests -v
+       python_foreach_impl nosetests -v || die
 }
 
 src_install() {
index dc7e4ee8aaab72ed94b36005442d059ad133d69f..c77ee951ec2feba14246e9db152dd11b9822eba5 100644 (file)
@@ -29,7 +29,7 @@ DEPEND="${RDEPEND}
 S=${WORKDIR}/cfe-${PV/_/}.src/bindings/python
 
 src_test() {
-       python_foreach_impl nosetests -v
+       python_foreach_impl nosetests -v || die
 }
 
 src_install() {
index 051a3308bd4dab83f5cc3391b642d80ae6fd185c..c892681f3410ca44550c90c2678ef7e0f8bc9d4b 100644 (file)
@@ -32,7 +32,7 @@ DEPEND="${RDEPEND}
 S=${WORKDIR}/${P}/bindings/python
 
 src_test() {
-       python_foreach_impl nosetests -v
+       python_foreach_impl nosetests -v || die
 }
 
 src_install() {
index be306e0a887a66a87ef6d5a76a4997c63b467c19..6019ef499996ec0be5dfd176de61269849b7fa78 100644 (file)
@@ -31,7 +31,7 @@ DEPEND="${RDEPEND}
 S=${WORKDIR}/${P}/bindings/python
 
 src_test() {
-       python_foreach_impl nosetests -v
+       python_foreach_impl nosetests -v || die
 }
 
 src_install() {