app-metrics/process-exporter: 0.4.0-r1 bump
authorWilliam Hubbs <william.hubbs@sony.com>
Thu, 17 Jan 2019 21:51:47 +0000 (15:51 -0600)
committerWilliam Hubbs <williamh@gentoo.org>
Thu, 17 Jan 2019 21:54:32 +0000 (15:54 -0600)
Add logging and make pidfile have the same name as the service.

Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.56, Repoman-2.3.12
Signed-off-by: William Hubbs <williamh@gentoo.org>
app-metrics/process-exporter/files/process-exporter.initd
app-metrics/process-exporter/process-exporter-0.4.0-r1.ebuild [new file with mode: 0644]

index d739825ecdfc3e7921e43bf6830a8519d0a156dd..f25eadc2a11faa54d6e35cd12d187f7075e21131 100644 (file)
@@ -1,8 +1,12 @@
 #!/sbin/openrc-run
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
 
 description="Process Exporter for Prometheus"
 command=/usr/bin/process-exporter
 command_args="--config.path /etc/process-exporter/all.yaml
-       --web.listen-address=:9256 ${COMMAND_ARGS}"
+       ${COMMAND_ARGS}"
 command_background=yes
-pidfile=/var/run/process-exporter.pid
+error_log=/var/log/process-exporter/${RC_SVCNAME}.log
+output_log=/var/log/process-exporter/${RC_SVCNAME}.log
+pidfile=/var/run/${RC_SVCNAME}.pid
diff --git a/app-metrics/process-exporter/process-exporter-0.4.0-r1.ebuild b/app-metrics/process-exporter/process-exporter-0.4.0-r1.ebuild
new file mode 100644 (file)
index 0000000..1ce1590
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN=github.com/ncabatoff/process-exporter
+
+inherit golang-build golang-vcs-snapshot systemd
+
+DESCRIPTION="Process exporter for prometheus"
+HOMEPAGE="https://github.com/ncabatoff/process-exporter"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="strip"
+
+src_compile() {
+       pushd "src/${EGO_PN}" || die
+       GOPATH="${S}" emake build
+}
+
+src_install() {
+       pushd "src/${EGO_PN}" || die
+       dobin ${PN}
+dodoc *.md
+       insinto /etc/${PN}
+       doins packaging/conf/all.yaml
+       systemd_dounit packaging/${PN}.service
+       newinitd "${FILESDIR}"/${PN}.initd ${PN}
+       keepdir /var/log/${PN}
+}