x11-libs/gdk-pixbuf: bump to 2.40.0
authorMart Raudsepp <leio@gentoo.org>
Sun, 13 Oct 2019 11:35:11 +0000 (14:35 +0300)
committerMart Raudsepp <leio@gentoo.org>
Sun, 13 Oct 2019 11:35:17 +0000 (14:35 +0300)
Package-Manager: Portage-2.3.69, Repoman-2.3.12
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
x11-libs/gdk-pixbuf/Manifest
x11-libs/gdk-pixbuf/gdk-pixbuf-2.40.0.ebuild [new file with mode: 0644]

index 91a8405286ffa6efd44f6b533a0f831fd45f592c..d15be355228a39f97ad2a52db414638cdab7c080 100644 (file)
@@ -2,3 +2,4 @@ DIST gdk-pixbuf-2.36.12-bug753605-atsize.jpg 80850 BLAKE2B 17e414ca097b7aaf51324
 DIST gdk-pixbuf-2.36.12.tar.xz 5675768 BLAKE2B da9e18b5dc55ad13a1bdab76d9c63a6233da1b45235ae5eb620e6e3f83888a0cc846f1ba17f72cb3b5af1ccd59a69631b3403bf09e262c53e0149e6f26896a33 SHA512 5d3bd620cf464bf92079b15c78f8400db48c427053c6eeedc4ea9652a4c290a09a26310100cc7eb487daf4b565df9f7e3a6edf14685f81ddbff6a0652fb6b41b
 DIST gdk-pixbuf-2.38.1.tar.xz 5509328 BLAKE2B 9180e833b264e4eb1bec1ec92e6ee7cb07a208459a7b58da9edd3f1872cdc1a98a6d7c27a147674d5dbded1b74098a4b1f197479c7addd1a6b307ced82a2e4dd SHA512 e50badaad2ccb3c816ba0849be386ecb75ea3c7df203d0b0144541c463ad1ace86c0d190b7550e3f59f0cba9639acc5cc048b7127484287894e4df6d62777920
 DIST gdk-pixbuf-2.38.2.tar.xz 5509752 BLAKE2B f78ba049edc7b1a6c909746ec68948764b3602988e110ee2ad752d26d8b3a37c3f2957a91d3c8a5fe3455cf11b477eaa43d097554048e8988c563b4074bfd751 SHA512 b0f83cca9bfbe45dab200b19a5ec6231b628c09633fd41348f433c226d523c2f9b805d41e4d955e9fd65c5b6d24df59c7c94193032379d6f09b0472ae988a0c1
+DIST gdk-pixbuf-2.40.0.tar.xz 5512160 BLAKE2B 26049a9ede60e7a50bdc5e9a731136e4bc6de031d01abd42667a0bf92617c36bcdc61d2dc18beb3c5223e32eab461ddb9fc9880a014ac1154763d3b7ee3e7200 SHA512 6512befd379494dbfd89a16fc4c92641842eb7b82fc820ec83a5b057526209947db646570db1124c073b0ef69c117bdf0f8d3fea807e302a4950db39187c35aa
diff --git a/x11-libs/gdk-pixbuf/gdk-pixbuf-2.40.0.ebuild b/x11-libs/gdk-pixbuf/gdk-pixbuf-2.40.0.ebuild
new file mode 100644 (file)
index 0000000..751e7ed
--- /dev/null
@@ -0,0 +1,139 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+# TODO: EAPI-7 needs gnome2-utils fixes - ${EROOT%/} and co usage for EAPI-7 in gdk_pixbuf_*
+# TODO: functions and eutils inherit for emktemp or some other solution
+
+inherit gnome.org gnome2-utils meson multilib multilib-minimal xdg
+
+DESCRIPTION="Image loading library for GTK+"
+HOMEPAGE="https://git.gnome.org/browse/gdk-pixbuf"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="X gtk-doc +introspection jpeg tiff"
+
+# TODO: For windows/darwin support: shared-mime-info conditional, native_windows_loaders option review
+DEPEND="
+       >=dev-libs/glib-2.48.0:2[${MULTILIB_USEDEP}]
+       x11-misc/shared-mime-info
+       >=media-libs/libpng-1.4:0=[${MULTILIB_USEDEP}]
+       jpeg? ( virtual/jpeg:0=[${MULTILIB_USEDEP}] )
+       tiff? ( >=media-libs/tiff-3.9.2:0=[${MULTILIB_USEDEP}] )
+       X? ( x11-libs/libX11[${MULTILIB_USEDEP}] )
+       introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+# librsvg blocker is for the new pixbuf loader API, you lose icons otherwise
+RDEPEND="${DEPEND}
+       !<gnome-base/gail-1000
+       !<gnome-base/librsvg-2.31.0
+       !<x11-libs/gtk+-2.21.3:2
+       !<x11-libs/gtk+-2.90.4:3
+"
+DEPEND="
+       app-text/docbook-xsl-stylesheets
+       dev-libs/libxslt
+       dev-util/glib-utils
+       gtk-doc? ( >=dev-util/gtk-doc-1.20
+               app-text/docbook-xml-dtd:4.3 )
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig
+"
+
+MULTILIB_CHOST_TOOLS=(
+       /usr/bin/gdk-pixbuf-query-loaders$(get_exeext)
+)
+
+PATCHES=(
+       # Do not run lowmem test on uclibc
+       # See https://bugzilla.gnome.org/show_bug.cgi?id=756590
+       "${FILESDIR}"/${PN}-2.32.3-fix-lowmem-uclibc.patch
+)
+
+src_prepare() {
+       xdg_src_prepare
+       # This will avoid polluting the pkg-config file with versioned libpng,
+       # which is causing problems with libpng14 -> libpng15 upgrade
+       # See upstream bug #667068
+       # First check that the pattern is present, to catch upstream changes on bumps,
+       # because sed doesn't return failure code if it doesn't do any replacements
+       grep -q "foreach png: \[ 'libpng16', 'libpng15', 'libpng14', 'libpng13', 'libpng12', 'libpng10' \]" meson.build || die "libpng check order has changed upstream"
+       sed -e "s/foreach png: \[ 'libpng16', 'libpng15', 'libpng14', 'libpng13', 'libpng12', 'libpng10' \]/foreach png: \[ 'libpng', 'libpng16', 'libpng15', 'libpng14', 'libpng13', 'libpng12', 'libpng10' \]/" -i meson.build || die
+}
+
+multilib_src_configure() {
+       local emesonargs=(
+               -Dpng=true
+               $(meson_use tiff)
+               $(meson_use jpeg)
+               -Djasper=false
+               $(meson_use X x11)
+               -Dbuiltin_loaders=png
+               -Drelocatable=false
+               #native_windows_loaders
+               -Dinstalled_tests=false
+               -Dgio_sniffing=true
+       )
+       if multilib_is_native_abi; then
+               emesonargs+=(
+                       $(meson_use gtk-doc docs)
+                       $(meson_use introspection gir)
+                       -Dman=true
+               )
+       else
+               emesonargs+=(
+                       -Ddocs=false
+                       -Dgir=false
+                       -Dman=false
+               )
+       fi
+       meson_src_configure
+}
+
+multilib_src_compile() {
+       meson_src_compile
+}
+
+multilib_src_test() {
+       meson_src_test
+}
+
+multilib_src_install() {
+       meson_src_install
+}
+
+pkg_preinst() {
+       xdg_pkg_preinst
+
+       multilib_pkg_preinst() {
+               # Make sure loaders.cache belongs to gdk-pixbuf alone
+               local cache="usr/$(get_libdir)/${PN}-2.0/2.10.0/loaders.cache"
+
+               if [[ -e ${EROOT%/}/${cache} ]]; then
+                       cp "${EROOT%/}"/${cache} "${ED}"/${cache} || die
+               else
+                       touch "${ED%/}"/${cache} || die
+               fi
+       }
+
+       multilib_foreach_abi multilib_pkg_preinst
+       gnome2_gdk_pixbuf_savelist
+}
+
+pkg_postinst() {
+       # causes segfault if set, see bug 375615
+       unset __GL_NO_DSO_FINALIZER
+
+       xdg_pkg_postinst
+       multilib_foreach_abi gnome2_gdk_pixbuf_update
+}
+
+pkg_postrm() {
+       xdg_pkg_postrm
+
+       if [[ -z ${REPLACED_BY_VERSION} ]]; then
+               rm -f "${EROOT%/}"/usr/lib*/${PN}-2.0/2.10.0/loaders.cache
+       fi
+}