dev-python/mako: Drop old
authorJustin Lecher <jlec@gentoo.org>
Fri, 11 Sep 2015 06:43:42 +0000 (08:43 +0200)
committerJustin Lecher <jlec@gentoo.org>
Fri, 11 Sep 2015 07:53:10 +0000 (09:53 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/mako/Manifest
dev-python/mako/mako-0.7.3-r1.ebuild [deleted file]
dev-python/mako/mako-0.7.3-r2.ebuild [deleted file]

index 5553b56b85ee96550138181ae8803200f261e3c1..1569cd974ef7e7f2421026117f6e21fa4062e280 100644 (file)
@@ -1,2 +1 @@
-DIST Mako-0.7.3.tar.gz 401787 SHA256 5e1d17fbd1aed57ebeea74ee3809015b121e142d73069066a113a125a4ec2ef5 SHA512 3134a05fcacb5d8e41ebab3bedb6c1a31eec94afb56f2c8319fee4b749930fcc7df5ed86e0de26cafbaea966b920921e29788f1c6ba5810eedb4d98f322085f9 WHIRLPOOL 8d3011b472a4bd04c4ef0ddad4767357bd1c570228702e900c956582c2e1e7e668765a34e4e450e18b8a1e0562d9b024ee1ae8b82efc891023154cf442f16d8a
 DIST Mako-1.0.0.tar.gz 470006 SHA256 a3cd72cfef507204b50f74ffcbfcfde7e856437891d3f6cfe780866986d006fe SHA512 81a6b7637e26d561350a591e3490e7140db218ae7f6b43fec8fca5b767fc6e57d0e8cc901d28fecb9863b2170c824a35c578a94579f991359fa0873f62ec578a WHIRLPOOL aa27b63e3832f03120312fbfec939b05606081e67a5cb4c9a056c27259631c2e159cf7506292d44e2c17c5950d7e4255d19f4beba78502bdbb52fbf11e1a872c
diff --git a/dev-python/mako/mako-0.7.3-r1.ebuild b/dev-python/mako/mako-0.7.3-r1.ebuild
deleted file mode 100644 (file)
index eca401e..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-MY_P="Mako-${PV}"
-
-DESCRIPTION="A Python templating language"
-HOMEPAGE="http://www.makotemplates.org/ https://pypi.python.org/pypi/Mako"
-SRC_URI="http://www.makotemplates.org/downloads/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~hppa ia64 ppc ~ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-RDEPEND=">=dev-python/beaker-1.1[${PYTHON_USEDEP}]
-       >=dev-python/markupsafe-0.9.2[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
-       "${FILESDIR}/test-fix.patch"
-)
-
-python_test() {
-       cp -r -l test "${BUILD_DIR}"/ || die
-
-       if [[ ${EPYTHON} == python3.* ]]; then
-               # Notes:
-               #   -W is not supported by python3.1
-               #   -n causes Python to write into hardlinked files
-               2to3 --no-diffs -w "${BUILD_DIR}"/test || die
-       fi
-
-       cd "${BUILD_DIR}"/test || die
-       nosetests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
-       rm -rf doc/build
-
-       use doc && local HTML_DOCS=( doc/. )
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/mako/mako-0.7.3-r2.ebuild b/dev-python/mako/mako-0.7.3-r2.ebuild
deleted file mode 100644 (file)
index b8abc6a..0000000
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-
-inherit readme.gentoo versionator distutils-r1
-
-MY_P="Mako-${PV}"
-
-DESCRIPTION="A Python templating language"
-HOMEPAGE="http://www.makotemplates.org/ https://pypi.python.org/pypi/Mako"
-SRC_URI="http://www.makotemplates.org/downloads/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~hppa ia64 ppc ~ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-RDEPEND="
-       >=dev-python/markupsafe-0.9.2[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/nose[${PYTHON_USEDEP}]
-               $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
-       "${FILESDIR}/test-fix.patch"
-)
-
-DOC_CONTENTS="
-${PN} can be enchanced with caching by dev-python/beaker"
-
-python_test() {
-       cp -r -l test "${BUILD_DIR}"/ || die
-
-       if [[ ${EPYTHON} == python3.* ]]; then
-               # Notes:
-               #   -W is not supported by python3.1
-               #   -n causes Python to write into hardlinked files
-               2to3 --no-diffs -w "${BUILD_DIR}"/test || die
-       fi
-
-       cd "${BUILD_DIR}"/test || die
-       nosetests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
-       rm -rf doc/build
-
-       use doc && local HTML_DOCS=( doc/. )
-       distutils-r1_python_install_all
-       readme.gentoo_create_doc
-}
-
-pkg_postinst() {
-       readme.gentoo_print_elog
-
-       for v in ${REPLACING_VERSIONS}; do
-               if ! version_is_at_least 0.7.3-r2 $v; then
-                       ewarn "dev-python/beaker is no longer hard dependency of ${P}"
-                       ewarn "If you rely on it, you should add beaker to your world"
-                       ewarn "file:"
-                       ewarn "# emerge --noreplace beaker"
-                       break
-               fi
-       done
-}