dev-python/qscintilla-python: add 2.11.4
authorDavide Pesavento <pesa@gentoo.org>
Fri, 27 Dec 2019 01:00:25 +0000 (02:00 +0100)
committerDavide Pesavento <pesa@gentoo.org>
Fri, 27 Dec 2019 01:01:10 +0000 (02:01 +0100)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Davide Pesavento <pesa@gentoo.org>
dev-python/qscintilla-python/Manifest
dev-python/qscintilla-python/qscintilla-python-2.11.4.ebuild [new file with mode: 0644]

index afe4c275980f1396054c9199e13b3198d0a3e55a..a1ce86f8e012217bee445d1181e4852fa1c50d10 100644 (file)
@@ -1,2 +1,3 @@
 DIST QScintilla-2.11.3.tar.gz 3006383 BLAKE2B 6238aaff44d6136a64e8c38e38c4886357eb72aa4067f54eda1e876040c41ebce8577e244b81a062e9020c4d142439f5612ca88055d0ba87172ff5b8893938d7 SHA512 83406ef2f425c6288fcac52b01417853186ba860e33e14b236801271e034c327cbb00817cb7247e98bafc1844aeff9f24ec4878ac8ec4bd52d0d2d9778f6b884
+DIST QScintilla-2.11.4.tar.gz 3007719 BLAKE2B b0f88a15a3636a0056d3bdac6e5d5bb05a065461c7de7fe0d5ad1740e87ca78a47bc1fd1af90a8751b553e8e326c830088a4cb38c9ebcad6be8bf9ebdb49bad0 SHA512 90fc2427121ca9ae55e34cf636460099bbdadd844318d9ef05f86790a36e25fb64528264bb7bb99e46b7add96378eff0cc69bb692940c6a1bddfadf86a9abdbd
 DIST QScintilla_gpl-2.10.8.tar.gz 2736054 BLAKE2B 4bc7a2bc1974f8e10a96b7716a8e35d4854e9eeb8040734f99b796bddd9679ee2539f6517743689f9d7deff9ce523cdbb2f77ccd65eaadfc947dcc7a1337d918 SHA512 c0a216737dbda6bc390225196b37a43e4884c9cd67e6e81fc1b1b952683fe88dbfe7caf3c66d94a378f37502e1f08cbdf788426248e73f5f66ec65982b7652b5
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.11.4.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.11.4.ebuild
new file mode 100644 (file)
index 0000000..a058f7a
--- /dev/null
@@ -0,0 +1,76 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} )
+inherit python-r1 qmake-utils
+
+DESCRIPTION="Python bindings for QScintilla"
+HOMEPAGE="https://www.riverbankcomputing.com/software/qscintilla/intro"
+
+MY_PN=QScintilla
+MY_P=${MY_PN}-${PV/_pre/.dev}
+if [[ ${PV} == *_pre* ]]; then
+       SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
+else
+       SRC_URI="https://www.riverbankcomputing.com/static/Downloads/${MY_PN}/${PV}/${MY_P}.tar.gz"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="debug"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+       ${PYTHON_DEPS}
+       >=dev-python/PyQt5-5.12[gui,printsupport,widgets,${PYTHON_USEDEP}]
+       >=dev-python/PyQt5-sip-4.19.14:=[${PYTHON_USEDEP}]
+       dev-qt/qtcore:5
+       dev-qt/qtgui:5
+       dev-qt/qtprintsupport:5
+       dev-qt/qtwidgets:5
+       ~x11-libs/qscintilla-${PV}:=
+"
+DEPEND="${RDEPEND}
+       >=dev-python/sip-4.19.14[${PYTHON_USEDEP}]
+"
+
+S=${WORKDIR}/${MY_P}/Python
+
+src_configure() {
+       configuration() {
+               local myconf=(
+                       "${PYTHON}"
+                       "${S}"/configure.py
+                       --pyqt=PyQt5
+                       --qmake="$(qt5_get_bindir)"/qmake
+                       $(usex debug '--debug --trace' '')
+                       --verbose
+               )
+               echo "${myconf[@]}"
+               "${myconf[@]}" || die
+
+               # Fix parallel install failure
+               sed -i -e '/INSTALLS += distinfo/i distinfo.depends = install_subtargets install_pep484_stubs install_api' \
+                       ${MY_PN}.pro || die
+
+               # Run eqmake to respect toolchain and build flags
+               eqmake5 -recursive ${MY_PN}.pro
+       }
+       python_foreach_impl run_in_build_dir configuration
+}
+
+src_compile() {
+       python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+       installation() {
+               emake INSTALL_ROOT="${D}" install
+               python_optimize
+       }
+       python_foreach_impl run_in_build_dir installation
+}