dev-python/oslo-utils: 3.41.3 stable amd64/x86 with cleanup
authorMatthew Thode <prometheanfire@gentoo.org>
Sun, 15 Dec 2019 17:57:23 +0000 (11:57 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Sun, 15 Dec 2019 17:57:40 +0000 (11:57 -0600)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/oslo-utils/Manifest
dev-python/oslo-utils/oslo-utils-3.40.4.ebuild [deleted file]
dev-python/oslo-utils/oslo-utils-3.41.3.ebuild

index b999bd0c6d1e258e6ed76537fc9aae7b7a0703cc..ffe9fc1c80dcc786cb3a0af2e3ac6f375ee9998d 100644 (file)
@@ -1,2 +1 @@
-DIST oslo-utils-3.40.4.tar.gz 90174 BLAKE2B 63c419c7925d58bdf73e3a1aaa683141f5e91d2b70a7e27db44a49ef5c662e7e1ff45016edc51eb73892ddebb45f6bcf4d8c1066d2eb6c6ebafa7f6a1be662b0 SHA512 d5df70052f0c4931fb5e9e89b6edf98ec2435a319157e04f53bf486f54e855ab178825772d405c2121cd2a2cfb894abfa35afe11edbe6b5b8030cbb915f841ab
 DIST oslo-utils-3.41.3.tar.gz 91174 BLAKE2B 9783360e5328083b5cfb2813f388ea29ca8876ce01cbcba5a25e0706766aab87d28f7683c4a9ef43ad9a0a4756403d2f35dc61ad170ada33e0dab67e5d5a6af4 SHA512 b8efc1ee5e22a0f224a48406208424d75ae1b9eb2b740bd2ac57e172f23f2d7e3f2ae712a006f89b4a64e0b6a619858908540b729705285d0aa99a8d5081495f
diff --git a/dev-python/oslo-utils/oslo-utils-3.40.4.ebuild b/dev-python/oslo-utils/oslo-utils-3.40.4.ebuild
deleted file mode 100644 (file)
index f51d620..0000000
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
-
-inherit distutils-r1
-
-MY_PN=${PN/-/.}
-
-DESCRIPTION="Oslo Utility library"
-HOMEPAGE="https://launchpad.net/oslo"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
-       !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       ${CDEPEND}
-       test? (
-               >=dev-python/eventlet-0.18.2[${PYTHON_USEDEP}]
-               !~dev-python/eventlet-0.18.3[${PYTHON_USEDEP}]
-               !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
-               !~dev-python/eventlet-0.21.0[${PYTHON_USEDEP}]
-               !~dev-python/eventlet-0.23.0[${PYTHON_USEDEP}]
-               >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
-               >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
-               >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
-               >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
-               >=dev-python/ddt-1.0.1[${PYTHON_USEDEP}]
-               >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
-               >=dev-python/coverage-4.0.0[${PYTHON_USEDEP}]
-               !~dev-python/coverage-4.4.0[${PYTHON_USEDEP}]
-               >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
-               >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
-               >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
-       )
-       doc? (
-               >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
-               !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
-               !~dev-python/sphinx-1.6.7[${PYTHON_USEDEP}]
-               >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
-               >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
-               >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
-       )
-"
-RDEPEND="
-       ${CDEPEND}
-       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
-       virtual/python-funcsigs[${PYTHON_USEDEP}]
-       >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
-       >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
-       >=dev-python/monotonic-0.6[${PYTHON_USEDEP}]
-       >=dev-python/pytz-2013.6[${PYTHON_USEDEP}]
-       >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
-       >=dev-python/netifaces-0.10.4[${PYTHON_USEDEP}]
-       >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
-       >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
-       sed -i '/^hacking/d' test-requirements.txt || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       use doc && esetup.py build_sphinx
-}
-
-# Note: Tests fail due to requiring installation
-#
-# Installation appears to fail due to the use of namespace packages but root
-# cause was never truly established.
-#
-# Tests fail with:
-# ImportError: No module named 'oslo.utils
-
-#RESTRICT="test"
-
-python_test() {
-       distutils_install_for_testing
-
-       cd "${TEST_DIR}"/lib || die
-
-       rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPTYHON}"
-
-       testr init || die "testr init failed under ${EPYTHON}"
-       testr run || die "testr run failed under ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( doc/build/html/. )
-
-       distutils-r1_python_install_all
-}
index 8d52d7df921e13f0fd068bd365e00adec2dbc164..767ed7d3941b8acbe3d81fbdaca86fd5241ecc50 100644 (file)
@@ -15,7 +15,7 @@ S="${WORKDIR}/${MY_PN}-${PV}"
 
 LICENSE="Apache-2.0"
 SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
+KEYWORDS="amd64 ~arm64 x86"
 IUSE="doc test"
 RESTRICT="!test? ( test )"