dev-java/oracle-jre-bin: Remove PostVMInitHook to stop usage tracker
authorJames Le Cuirot <chewi@gentoo.org>
Wed, 9 Sep 2015 09:04:21 +0000 (10:04 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Wed, 9 Sep 2015 09:04:52 +0000 (10:04 +0100)
Deleting the usage tracker resulted in exceptions being silently
raised in a thread and this caused havoc with debuggers. Deleting the
hook that calls it instead is a smaller change and avoids both
problems.

It is possible that Oracle may use this hook for something else
later. I have therefore added a JAVA_PKG_STRICT check to display its
contents on each merge so that we can keep an eye on it.

See bug #559936 for more details.

Package-Manager: portage-2.2.20.1

dev-java/oracle-jre-bin/oracle-jre-bin-1.8.0.60-r2.ebuild [moved from dev-java/oracle-jre-bin/oracle-jre-bin-1.8.0.60-r1.ebuild with 95% similarity]

similarity index 95%
rename from dev-java/oracle-jre-bin/oracle-jre-bin-1.8.0.60-r1.ebuild
rename to dev-java/oracle-jre-bin/oracle-jre-bin-1.8.0.60-r2.ebuild
index 970db2e470278bb3cbec417e6c8b4ca59364c4e6..89907ab5900e5636c84226dac60546093d173689 100644 (file)
@@ -123,10 +123,11 @@ src_prepare() {
                mv "${WORKDIR}"/${JCE_DIR} lib/security/ || die
        fi
 
-       # Delete Oracle's evil usage tracker. Not just because it's evil but
-       # because it breaks the sandbox during builds and we can't find any
-       # other feasible way to disable it or make it write somewhere else.
-       zip -d lib/rt.jar sun/usagetracker/\* || die
+       # Remove the hook that calls Oracle's evil usage tracker. Not just
+       # because it's evil but because it breaks the sandbox during builds
+       # and we can't find any other feasible way to disable it or make it
+       # write somewhere else. See bug #559936 for details.
+       zip -d lib/rt.jar sun/misc/PostVMInitHook.class || die
 }
 
 src_install() {