dev-python/sshtunnel: Bump EAPI, drop tests
authorAaron W. Swenson <titanofold@gentoo.org>
Thu, 6 Jun 2019 10:17:45 +0000 (06:17 -0400)
committerAaron W. Swenson <titanofold@gentoo.org>
Thu, 6 Jun 2019 10:18:05 +0000 (06:18 -0400)
Tests are now failing consuming all resources until OOM killed. Drop tests until
upstream figures it out.

Bug: https://bugs.gentoo.org/683774
Package-Manager: Portage-2.3.62, Repoman-2.3.11
Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
dev-python/sshtunnel/sshtunnel-0.1.4-r2.ebuild [new file with mode: 0644]

diff --git a/dev-python/sshtunnel/sshtunnel-0.1.4-r2.ebuild b/dev-python/sshtunnel/sshtunnel-0.1.4-r2.ebuild
new file mode 100644 (file)
index 0000000..a457551
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python SSH tunnels"
+HOMEPAGE="https://pypi.python.org/pypi/sshtunnel"
+SRC_URI="mirror://pypi/s/sshtunnel/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~x86"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="dev-python/paramiko[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# https://bugs.gentoo.org/683774
+RESTRICT="test"