gnome-extra/gnome-shell-extension-gsconnect: Bump to v23
authorPacho Ramos <pacho@gentoo.org>
Fri, 3 May 2019 08:56:41 +0000 (10:56 +0200)
committerPacho Ramos <pacho@gentoo.org>
Fri, 3 May 2019 08:56:41 +0000 (10:56 +0200)
Package-Manager: Portage-2.3.64, Repoman-2.3.12
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
gnome-extra/gnome-shell-extension-gsconnect/Manifest
gnome-extra/gnome-shell-extension-gsconnect/gnome-shell-extension-gsconnect-23.ebuild [new file with mode: 0644]

index ca534d6cdddbb8062cd42236a45af7d224f4ec90..4a8cd3be853e3f3db6f496a9a2b8aed4f20bc225 100644 (file)
@@ -1,2 +1,3 @@
 DIST gnome-shell-extension-gsconnect-12.tar.gz 1034122 BLAKE2B dc9e4003532bbb500c81d2bd0d2a715f60bb5c70b6bcf3286ebd8b2219d511f51e63c93ef30b0b71ced720531c811462f3b343d9a9eaa07ef4a56a498e5c497f SHA512 3b88aa7ff6e55556a6e438376c578a007d41d266dc91f6d56dfccde217bd0ede7ed40c10b05903582d9bde392f0a375f34b1fbdfd1aae0204f46b9d7e6c246ef
 DIST gnome-shell-extension-gsconnect-21.tar.gz 290699 BLAKE2B cfdaf5d3e02e7a73009ff6f355f9ba444a811fa0834f1d16ac191217a613b56ab39d0952fdd1119e2e6371ba3e5ac89473d1a10de922189c6b2a40e0518b97fc SHA512 3382b5043fcaa359cb12777098f4f89ccdca1a20c6e0b953a8f165563902e3b4d0d469f09a59d01bad708748969efd79651cdd5ab9129c29ff656c6a918e0821
+DIST gnome-shell-extension-gsconnect-23.tar.gz 295155 BLAKE2B 15779f9ceaaf0cae3326786eb78a12e7d669d95692c40f233a5c0d93ac44a4787738ce0826048019f27a0fead7de5b4bad1d64410d27646f05122547751f681e SHA512 8c480d1695b0e261a34277604c6fca5445987ae33cf07749b3d96649224f505f1ce2bee249325acbd8d89c23da1a04cea19d668fcc298ef777c55e9b53f85bba
diff --git a/gnome-extra/gnome-shell-extension-gsconnect/gnome-shell-extension-gsconnect-23.ebuild b/gnome-extra/gnome-shell-extension-gsconnect/gnome-shell-extension-gsconnect-23.ebuild
new file mode 100644 (file)
index 0000000..59ad286
--- /dev/null
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2-utils meson readme.gentoo-r1
+
+DESCRIPTION="KDE Connect implementation for Gnome Shell"
+HOMEPAGE="https://github.com/andyholmes/gnome-shell-extension-gsconnect"
+SRC_URI="https://github.com/andyholmes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="nautilus"
+
+COMMON_DEPEND="dev-libs/glib:2"
+
+RDEPEND="${COMMON_DEPEND}
+       app-eselect/eselect-gnome-shell-extensions
+       >=dev-libs/gjs-1.48
+       >=gnome-base/gnome-shell-3.28
+       gnome-base/gvfs
+       || ( ( net-libs/gnome-online-accounts dev-libs/libgdata ) dev-libs/folks )
+       || ( media-libs/libcanberra media-libs/gsound )
+       nautilus? (
+               dev-python/nautilus-python
+               gnome-base/nautilus[introspection] )
+"
+DEPEND="${COMMON_DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="For knowing more about how to do the setup, please visit:
+https://github.com/andyholmes/gnome-shell-extension-gsconnect/wiki/Installation"
+
+src_configure() {
+       meson_src_configure \
+               $(meson_use nautilus)
+}
+
+src_install() {
+       meson_src_install
+       readme.gentoo_create_doc
+}
+
+pkg_preinst() {
+       gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+       gnome2_schemas_update
+       ebegin "Updating list of installed extensions"
+       eselect gnome-shell-extensions update
+       eend $?
+       readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+       gnome2_schemas_update
+}