app-crypt/gpgme: drop old
authorAlon Bar-Lev <alonbl@gentoo.org>
Tue, 14 Aug 2018 15:58:44 +0000 (18:58 +0300)
committerAlon Bar-Lev <alonbl@gentoo.org>
Tue, 14 Aug 2018 16:02:24 +0000 (19:02 +0300)
Package-Manager: Portage-2.3.40, Repoman-2.3.9

app-crypt/gpgme/Manifest
app-crypt/gpgme/gpgme-1.10.0.ebuild [deleted file]

index 3ef61eb628f8978c278693d2ff46412ab8e7ffad..46a057841ae7b169449a1cfc004c4fb65b351c52 100644 (file)
@@ -1,2 +1 @@
-DIST gpgme-1.10.0.tar.bz2 1370162 BLAKE2B b421d91a4fcd2e8887dc1a5c276fe1cce66f379741d86dfca751f4863039c39ccaf492c7683d6f6a0de407d2a6056e3496e45e3d472eef36a879e8b903e58c57 SHA512 8ffa348ef4775ed3209486444d54411e28c9a0ff1d7a4315feb0b2856ccd5d110b219100ea41262ca0016af69a1936d79fee0eadf2599c7c5bbeed05d11f7ab5
 DIST gpgme-1.11.1.tar.bz2 1419232 BLAKE2B 93980c24e6d692f35105db23a02db891ef022addd583d5bda8e55ec3552dfebb87c9feebb74fdd59fa353a3b08571e51537f8dcaf63af018beff467a848e97e9 SHA512 42fa6f5d6217aaad9b44b969de9603167d179af9a1573342187718ff123cd88c686211c3dc5f2d9cacc20226ab5b8fef85cb66a19ada71d267c397d8ba52cf1a
diff --git a/app-crypt/gpgme/gpgme-1.10.0.ebuild b/app-crypt/gpgme/gpgme-1.10.0.ebuild
deleted file mode 100644 (file)
index c795924..0000000
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-DISTUTILS_OPTIONAL=1
-
-inherit distutils-r1 flag-o-matic libtool ltprune qmake-utils toolchain-funcs
-
-DESCRIPTION="GnuPG Made Easy is a library for making GnuPG easier to use"
-HOMEPAGE="http://www.gnupg.org/related_software/gpgme"
-SRC_URI="mirror://gnupg/gpgme/${P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="1/11" # subslot = soname major version
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="common-lisp static-libs cxx python qt5"
-
-COMMON_DEPEND=">=app-crypt/gnupg-2
-       >=dev-libs/libassuan-2.0.2:=
-       >=dev-libs/libgpg-error-1.17:=
-       python? ( ${PYTHON_DEPS} )
-       qt5? ( dev-qt/qtcore:5 )"
-       #doc? ( app-doc/doxygen[dot] )
-DEPEND="${COMMON_DEPEND}
-       python? ( dev-lang/swig )
-       qt5? ( dev-qt/qttest:5 )"
-RDEPEND="${COMMON_DEPEND}
-       cxx? (
-               !<kde-apps/gpgmepp-4.14.11_pre20160611:4
-               !kde-apps/gpgmepp:5
-               !<kde-apps/kdepimlibs-4.14.10_p20160611:4
-               !=kde-apps/kdepimlibs-4.14.11_pre20160211*:4
-       )"
-
-REQUIRED_USE="qt5? ( cxx ) python? ( ${PYTHON_REQUIRED_USE} )"
-
-do_python() {
-       if use python; then
-               pushd "lang/python" > /dev/null || die
-               top_builddir="../.." srcdir="." CPP=$(tc-getCPP) distutils-r1_src_${EBUILD_PHASE}
-               popd > /dev/null
-       fi
-}
-
-pkg_setup() {
-       addpredict /run/user/$(id -u)/gnupg
-
-       local MAX_WORKDIR=66
-       if [[ "${#WORKDIR}" -gt "${MAX_WORKDIR}" ]]; then
-               ewarn "Disabling tests as WORKDIR '${WORKDIR}' is longer than ${MAX_WORKDIR} which will fail tests"
-               SKIP_TESTS=1
-       fi
-}
-
-src_prepare() {
-       default
-       elibtoolize
-
-       # Make best effort to allow longer PORTAGE_TMPDIR
-       # as usock limitation fails build/tests
-       ln -s "${P}" "${WORKDIR}/b"
-       S="${WORKDIR}/b"
-}
-
-src_configure() {
-       local languages=()
-       use common-lisp && languages+=( "cl" )
-       use cxx && languages+=( "cpp" )
-       if use qt5; then
-               languages+=( "qt" )
-               #use doc ||
-               export DOXYGEN=true
-               export MOC="$(qt5_get_bindir)/moc"
-       fi
-
-       econf \
-               $([[ -n "${SKIP_TESTS}" ]] && echo "--disable-gpg-test --disable-gpgsm-test") \
-               --enable-languages="${languages[*]}" \
-               $(use_enable static-libs static)
-
-       use python && make -C lang/python prepare
-
-       do_python
-}
-
-src_compile() {
-       default
-       do_python
-}
-
-src_test() {
-       [[ -z "${SKIP_TESTS}" ]] || return
-
-       default
-       if use python; then
-               test_python() {
-                       emake -C lang/python/tests check \
-                               PYTHON=${EPYTHON} \
-                               PYTHONS=${EPYTHON} \
-                               TESTFLAGS="--python-libdir=${BUILD_DIR}/lib"
-               }
-               python_foreach_impl test_python
-       fi
-}
-
-src_install() {
-       default
-       do_python
-       prune_libtool_files
-
-       # backward compatibility for gentoo
-       # in the past we had slots
-       dodir /usr/include/gpgme
-       dosym ../gpgme.h /usr/include/gpgme/gpgme.h
-}