dev-cpp/sparsehash: Bump to EAPI 6
authorDavid Seifert <soap@gentoo.org>
Sun, 22 Jan 2017 17:13:56 +0000 (18:13 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 22 Jan 2017 17:15:06 +0000 (18:15 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-cpp/sparsehash/files/sparsehash-2.0.3-fix-docdir.patch [new file with mode: 0644]
dev-cpp/sparsehash/sparsehash-2.0.3.ebuild

diff --git a/dev-cpp/sparsehash/files/sparsehash-2.0.3-fix-docdir.patch b/dev-cpp/sparsehash/files/sparsehash-2.0.3-fix-docdir.patch
new file mode 100644 (file)
index 0000000..156a726
--- /dev/null
@@ -0,0 +1,21 @@
+* Do not override $(docdir) as part of the GNU conventions
+* Do not install 'COPYING' and 'INSTALL'
+* Install html files using html_ prefix and not doc_ prefix
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -11,12 +11,11 @@
+ AM_CXXFLAGS = -Wall -W -Wwrite-strings -Woverloaded-virtual -Wshadow
+ endif
+-docdir = $(prefix)/share/doc/$(PACKAGE)-$(VERSION)
+ ## This is for HTML and other documentation you want to install.
+ ## Add your documentation files (in doc/) in addition to these boilerplate
+ ## Also add a TODO file if you have one
+-dist_doc_DATA = AUTHORS COPYING ChangeLog INSTALL NEWS README README_windows.txt \
+-   TODO \
++dist_doc_DATA = AUTHORS ChangeLog NEWS README README_windows.txt TODO
++dist_html_DATA = \
+    doc/dense_hash_map.html                    \
+    doc/dense_hash_set.html                    \
+    doc/sparse_hash_map.html                   \
index 5fb17a073c6ddb10842eab7f38fb9fbd26f0360a..cc5f66461a190b02d179f6284ddc9bc2a89380be 100644 (file)
@@ -1,8 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
-EAPI="5"
+EAPI=6
+
+inherit autotools
 
 DESCRIPTION="An extremely memory-efficient hash_map implementation"
 HOMEPAGE="https://github.com/sparsehash/sparsehash"
@@ -15,10 +17,9 @@ IUSE=""
 
 S=${WORKDIR}/${PN}-${P}
 
-src_install() {
-       default
+PATCHES=( "${FILESDIR}"/${PN}-2.0.3-fix-docdir.patch )
 
-       # Installs just every piece
-       rm -rf "${ED}/usr/share/doc"
-       dohtml doc/*
+src_prepare() {
+       default
+       eautoreconf
 }