dev-python/pip: Bump to 20.1.1
authorMichał Górny <mgorny@gentoo.org>
Wed, 20 May 2020 05:27:58 +0000 (07:27 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 20 May 2020 07:17:58 +0000 (09:17 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pip/Manifest
dev-python/pip/pip-20.1.1.ebuild [new file with mode: 0644]

index f6e99d0a70879d4feab265feab2314b489ccbca6..aecac8b0b2dc466ea5e4afa277fc62d2bdbcf69c 100644 (file)
@@ -1,5 +1,6 @@
 DIST pip-19.3.1.tar.gz 6409819 BLAKE2B b3aacd0bee60400a1f30b4be57871002072e5cc7a86e76cca1848e977ebdc85b6e282fc521c19bf7a518d1aef3280133fcd65a431cb2a16e202dd7721c5b97ad SHA512 39446c0ab6e4495d98f22923a2a76901b024d9047b60d92580b21d447a718e5285cfd66f8ad0c20befcfe1abc7f06be29b6a5644d1b30265d3b67399fe76e033
 DIST pip-20.0.2.tar.gz 6445047 BLAKE2B 8f6e0a8908cf594c8d51818942b0839f59a495697a95dcc0347235e90cbe6d7f035f155761e7da9cfca1ba08b2c5a2c5def52c60c381f5428ef48efd1b6b5131 SHA512 f9965944ca0f319d01db1638ce97cf64772afff1778b3b1271155de73208cfcb3954d89a469c1143c0bf3288a53d4446165a49df994374b16ac6f7ffdae85857
+DIST pip-20.1.1.tar.gz 6503229 BLAKE2B 5b0409042c970ec47fa6f947b21a53aca43563a6bb442fd5f91788fa97caf7167a84b4f581de87453eb0e55657d2ccd11dca2d1815c3bfe9ef5923994306a6db SHA512 ee7b0345c08fbe0215811d07b4c57c1ceece826871842f6d1c174d82e8eee0ad810aa5413d6763ecd5a513e151792a53c36623ab99d2049555ef2542d32d1658
 DIST pip-20.1.tar.gz 6500955 BLAKE2B 81ab806fce4ae3d9aeab34fe8781c13507252ef0325abb35dd739f3eaf0e648866b052d2adb8b187974ae784f493dbb83f684c464da8f9079f66fe8c4fa2d61d SHA512 19cc1172540bec4b0c6facf55fa9c463bf8f4391dd1a643ac208c8e0b787950b2d72a6ec8f0772c7e6582c6b6a4a103f31ad58ffa2119fb574c174e5ec77b0c1
 DIST pip-9.0.1.tar.gz 1197370 BLAKE2B 3618161690d5e0a38d141f9b51baea4aaa3fdc225664ef180bbeecf6e2df95e9ea4f97c63fe3a68f84f4fb5ebcc74e316827253c7e07b03565e58113bbaa918a SHA512 ee59efb4b009ff6543b7afdea99b9cbbee1981ecc03af586acda76674024d3b66dab23049e68f3da9448734984619fc1eaba6e965c9dd3d731973376c8a42e25
 DIST setuptools-41.4.0-py2.py3-none-any.whl 580302 BLAKE2B 58dc2d48445406f7467bfb0934dc507e8a569e4759bfcc95287cfb21b5b1a7bcab061656a29a8b4976ee3ae12a3adca570035ae4a6d9df09ae7a799857775d36 SHA512 a27b38d596931dfef81d705d05689b7748ce0e02d21af4a37204fc74b0913fa7241b8135535eb7749f09af361cad90c475af98493fef11c4ad974780ee01243d
diff --git a/dev-python/pip/pip-20.1.1.ebuild b/dev-python/pip/pip-20.1.1.ebuild
new file mode 100644 (file)
index 0000000..b91120f
--- /dev/null
@@ -0,0 +1,140 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_REQ_USE="ssl(+),threads(+)"
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+SETUPTOOLS_PV="44.0.0"
+WHEEL_PV="0.34.2"
+
+DESCRIPTION="Installs python packages -- replacement for easy_install"
+HOMEPAGE="https://pip.pypa.io/ https://pypi.org/project/pip/ https://github.com/pypa/pip/"
+SRC_URI="
+       https://github.com/pypa/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+       test? (
+               https://files.pythonhosted.org/packages/py2.py3/s/setuptools/setuptools-${SETUPTOOLS_PV}-py2.py3-none-any.whl
+               https://files.pythonhosted.org/packages/py2.py3/w/wheel/wheel-${WHEEL_PV}-py2.py3-none-any.whl
+       )
+"
+# PyPI archive does not have tests, so we need to download from GitHub.
+# setuptools & wheel .whl files are required for testing, exact version is not very important.
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test -vanilla"
+
+# disable-system-install patch breaks tests
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=dev-python/setuptools-39.2.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+       ${RDEPEND}
+       test? (
+               dev-python/cryptography[${PYTHON_USEDEP}]
+               dev-python/csv23[${PYTHON_USEDEP}]
+               dev-python/freezegun[${PYTHON_USEDEP}]
+               dev-python/mock[${PYTHON_USEDEP}]
+               dev-python/pretend[${PYTHON_USEDEP}]
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/pyyaml[${PYTHON_USEDEP}]
+               dev-python/scripttest[${PYTHON_USEDEP}]
+               <dev-python/virtualenv-20[${PYTHON_USEDEP}]
+               dev-python/werkzeug[${PYTHON_USEDEP}]
+               dev-python/wheel[${PYTHON_USEDEP}]
+               $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' -2)
+       )
+"
+
+python_prepare_all() {
+       local PATCHES=(
+               "${FILESDIR}/${PN}-19.3-disable-version-check.patch"
+       )
+       if ! use vanilla; then
+               PATCHES+=( "${FILESDIR}/pip-20.0.2-disable-system-install.patch" )
+       fi
+       distutils-r1_python_prepare_all
+
+       if use test; then
+               mkdir tests/data/common_wheels/ || die
+               cp "${DISTDIR}"/setuptools-${SETUPTOOLS_PV}-py2.py3-none-any.whl \
+                       tests/data/common_wheels/ || die
+
+               cp "${DISTDIR}"/wheel-${WHEEL_PV}-py2.py3-none-any.whl \
+                       tests/data/common_wheels/ || die
+       fi
+}
+
+python_test() {
+       if [[ ${EPYTHON} == pypy* ]]; then
+               ewarn "Skipping tests on ${EPYTHON} since they are very broken"
+               return 0
+       fi
+
+       local -a exclude_tests
+
+       # these will be built in to an expression passed to pytest to exclude
+       exclude_tests=(
+               git
+               svn
+               bazaar
+               mercurial
+               version_check
+               uninstall_non_local_distutils
+               pep518_uses_build_env
+               install_package_with_root
+               install_editable_with_prefix
+               install_user_wheel
+               install_from_current_directory_into_usersite
+               uninstall_editable_from_usersite
+               uninstall_from_usersite_with_dist_in_global_site
+               build_env_isolation
+               user_config_accepted
+       )
+
+       distutils_install_for_testing
+
+       # generate the expression to exclude failing tests
+       local exclude_expr
+       printf -v exclude_expr "or %s " "${exclude_tests[@]}" || die
+       exclude_expr="not (${exclude_expr#or })" || die
+
+       local -x GENTOO_PIP_TESTING=1 \
+               PATH="${TEST_DIR}/scripts:${PATH}" \
+               PYTHONPATH="${TEST_DIR}/lib:${BUILD_DIR}/lib"
+
+       pytest -vv \
+               -k "${exclude_expr}" \
+               -m "not network" \
+               || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+       # Prevent dbus auto-launch
+       # https://bugs.gentoo.org/692178
+       export DBUS_SESSION_BUS_ADDRESS="disabled:"
+
+       local DOCS=( AUTHORS.txt docs/html/**/*.rst )
+       distutils-r1_python_install_all
+
+       COMPLETION="${T}"/completion.tmp
+
+       # 'pip completion' command embeds full $0 into completion script, which confuses
+       # 'complete' and causes QA warning when running as "${PYTHON} -m pip".
+       # This trick sets correct $0 while still calling just installed pip.
+       local pipcmd='import sys; sys.argv[0] = "pip"; import pip.__main__; sys.exit(pip.__main__._main())'
+
+       ${PYTHON} -c "${pipcmd}" completion --bash > "${COMPLETION}" || die
+       newbashcomp "${COMPLETION}" ${PN}
+
+       ${PYTHON} -c "${pipcmd}" completion --zsh > "${COMPLETION}" || die
+       insinto /usr/share/zsh/site-functions
+       newins "${COMPLETION}" _pip
+}