Version bump (bug 150735), and removed old version.
authorMarcus D. Hanwell <cryos@gentoo.org>
Wed, 1 Nov 2006 09:51:06 +0000 (09:51 +0000)
committerMarcus D. Hanwell <cryos@gentoo.org>
Wed, 1 Nov 2006 09:51:06 +0000 (09:51 +0000)
Package-Manager: portage-2.1.2_rc1-r1

sci-visualization/gwyddion/ChangeLog
sci-visualization/gwyddion/files/digest-gwyddion-2.0 [new file with mode: 0644]
sci-visualization/gwyddion/gwyddion-2.0.ebuild [new file with mode: 0644]

index eb08522dd4b3b3441095676389bf87097c215632..7f4b76d15cf5bf40b448ba2991b5b0da9d27cdcf 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for sci-visualization/gwyddion
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gwyddion/ChangeLog,v 1.4 2006/07/15 22:06:48 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gwyddion/ChangeLog,v 1.5 2006/11/01 09:51:06 cryos Exp $
+
+*gwyddion-2.0 (01 Nov 2006)
+
+  01 Nov 2006; Marcus D. Hanwell <cryos@gentoo.org> -gwyddion-1.15.ebuild,
+  +gwyddion-2.0.ebuild:
+  Version bump (bug 150735), and removed old version.
 
 *gwyddion-1.16 (15 Jul 2006)
 
diff --git a/sci-visualization/gwyddion/files/digest-gwyddion-2.0 b/sci-visualization/gwyddion/files/digest-gwyddion-2.0
new file mode 100644 (file)
index 0000000..d2f2736
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 eb944ddac1413c2eb4cef8e9a0f624a9 gwyddion-2.0.tar.bz2 2132755
+RMD160 eeb6e2d99956a10e198fdfc95f27681a5f2d8029 gwyddion-2.0.tar.bz2 2132755
+SHA256 5741156141ec27729f21b7a35b049e025c4219b6e5533a80dfbbc20069e1c0a9 gwyddion-2.0.tar.bz2 2132755
diff --git a/sci-visualization/gwyddion/gwyddion-2.0.ebuild b/sci-visualization/gwyddion/gwyddion-2.0.ebuild
new file mode 100644 (file)
index 0000000..dbc7bc1
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gwyddion/gwyddion-2.0.ebuild,v 1.1 2006/11/01 09:51:06 cryos Exp $
+
+DESCRIPTION="A software framework for SPM data analysis"
+HOMEPAGE="http://gwyddion.net/"
+SRC_URI="http://gwyddion.net/download/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python perl ruby nls"
+
+DEPEND="virtual/opengl
+       python? ( virtual/python )
+       perl? ( dev-lang/perl )
+       ruby? ( virtual/ruby )
+       >=x11-libs/gtk+-2.6
+       x11-libs/gtkglext"
+
+src_compile() {
+       econf \
+               $(use_enable python) \
+               $(use_enable perl) \
+               $(use_enable ruby) \
+               $(use_enable nls) \
+               --disable-desktop-file-update \
+               || die "econf failed."
+       emake || die "emake failed."
+}
+
+src_install() {
+       make DESTDIR=${D} install || die "make install failed."
+       dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}