gnome-base/gvfs: bump to 1.42.2
authorMart Raudsepp <leio@gentoo.org>
Mon, 16 Mar 2020 08:58:46 +0000 (10:58 +0200)
committerMart Raudsepp <leio@gentoo.org>
Mon, 16 Mar 2020 22:08:05 +0000 (00:08 +0200)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
gnome-base/gvfs/Manifest
gnome-base/gvfs/gvfs-1.42.2.ebuild [new file with mode: 0644]

index d861872e052f35c0411c5fdde39876b7d2bc7c61..42f74b2acca5147609d8177de8fbbc02dc3622b9 100644 (file)
@@ -1 +1,3 @@
 DIST gvfs-1.40.2.tar.xz 1204824 BLAKE2B beaf9ba603d035a81ab21dc3fe438dfe77cc0cb1d38d0457d079be80b7ec93ab6adbe9992dd0030510fb816ce14da5ef03c3f865e32bdd69956bc0181da09af2 SHA512 aec525091553e793e10ad9747e29080c92401b9d2a0b8dff98994c071d67057796628dc2a53c0ede46c53f2b149abb55e57c3ddd75e11a93c2f168713e5fb61c
+DIST gvfs-1.42.2-patchset.tar.xz 23932 BLAKE2B 6957c5a8a200ecff9c3294a7fb7304ae1be147e45dae1838121690a3a20b1d2557681b4efe5f722811d5302b8270d0058eedac7f8a95029cd872df3db14cc541 SHA512 0494fb36e093d06bb278a75ecbf3bc17460d5d20302a9c1d2c5b74a0b65c2a259141b515b3e80c57c3e1125df74b3cf6d2a91ae70c8e2e0af3bbca285417b9f0
+DIST gvfs-1.42.2.tar.xz 1204972 BLAKE2B ebc1c4a4ae69a809ee7c556e65f87f968806ef057cfb7f7a7d2f18614443197c1feaad79099fd5b04640035e7ab306683018676ce109a7d718e3c8d35676be7c SHA512 b786ae2e493099a0a1ab2756efba3690f0e241a53995013e2632b2d7e01628d52d72b47298c7a2b913c8d50f135c191b2963a7ffc0e768fc5c96a89f93401e3c
diff --git a/gnome-base/gvfs/gvfs-1.42.2.ebuild b/gnome-base/gvfs/gvfs-1.42.2.ebuild
new file mode 100644 (file)
index 0000000..42155c7
--- /dev/null
@@ -0,0 +1,140 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson systemd xdg
+
+DESCRIPTION="Virtual filesystem implementation for GIO"
+HOMEPAGE="https://wiki.gnome.org/Projects/gvfs"
+SRC_URI+=" https://dev.gentoo.org/~leio/distfiles/${PF}-patchset.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+
+IUSE="afp archive bluray cdda elogind fuse google gnome-keyring gnome-online-accounts gphoto2 +http ios mtp nfs policykit samba systemd test +udev udisks zeroconf"
+RESTRICT="!test? ( test )"
+# elogind/systemd only relevant to udisks (in v1.38.1)
+REQUIRED_USE="
+       ?? ( elogind systemd )
+       cdda? ( udev )
+       google? ( gnome-online-accounts )
+       gphoto2? ( udev )
+       mtp? ( udev )
+       udisks? ( udev )
+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+
+RDEPEND="
+       >=dev-libs/glib-2.57.2:2
+       >=gnome-base/gsettings-desktop-schemas-3.33.0
+       afp? ( >=dev-libs/libgcrypt-1.2.2:0= )
+       sys-apps/dbus
+       app-crypt/gcr:=
+       policykit? (
+               >=sys-auth/polkit-0.114
+               sys-libs/libcap )
+       http? (
+               dev-libs/libxml2:2
+               >=net-libs/libsoup-2.58.0:2.4 )
+       zeroconf? ( >=net-dns/avahi-0.6[dbus] )
+       udev? ( >=dev-libs/libgudev-147:= )
+       fuse? ( >=sys-fs/fuse-3.0.0:3 )
+       udisks? ( >=sys-fs/udisks-1.97:2 )
+       systemd? ( >=sys-apps/systemd-206:0= )
+       elogind? ( >=sys-auth/elogind-229:0= )
+       ios? (
+               >=app-pda/libimobiledevice-1.2:=
+               >=app-pda/libplist-1:= )
+       gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.17.1:= )
+       gnome-keyring? ( app-crypt/libsecret )
+       bluray? ( media-libs/libbluray:= )
+       mtp? (
+               >=dev-libs/libusb-1.0.21
+               >=media-libs/libmtp-1.1.15 )
+       samba? ( >=net-fs/samba-4[client] )
+       archive? ( app-arch/libarchive:= )
+       cdda? (
+               dev-libs/libcdio:0=
+               >=dev-libs/libcdio-paranoia-0.78.2 )
+       google? ( >=dev-libs/libgdata-0.17.9:=[crypt,gnome-online-accounts] )
+       gphoto2? ( >=media-libs/libgphoto2-2.5.0:= )
+       nfs? ( >=net-fs/libnfs-1.9.8 )
+       net-misc/openssh
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+       >=dev-util/meson-0.49
+       dev-util/glib-utils
+       app-text/docbook-xsl-stylesheets
+       app-text/docbook-xml-dtd:4.2
+       dev-libs/libxslt
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig
+       dev-util/gdbus-codegen
+"
+
+PATCHES=(
+       "${WORKDIR}"/patches
+)
+
+src_configure() {
+       local enable_logind="false"
+       if use systemd || use elogind; then
+               enable_logind="true"
+       fi
+
+       local enable_gcrypt="false"
+       if use afp; then # currently HAVE_GCRYPT and linkage only used with afp; check it on big bumps (grep for HAVE_GCRYPT and enable_gcrypt); adjust depends if changes
+               enable_gcrypt="true"
+       fi
+
+       local enable_libusb="false"
+       if use mtp; then # currently HAVE_LIBUSB and linkage only used with mtp; check it on big bumps (grep for HAVE_LIBUSB and enable_libusb); adjust depends if changes
+               enable_libusb="true"
+       fi
+
+       local emesonargs=(
+               -Dsystemduserunitdir="$(systemd_get_userunitdir)"
+               -Dtmpfilesdir="${EPREFIX}"/usr/lib/tmpfiles.d
+               $(meson_use policykit admin)
+               $(meson_use ios afc)
+               $(meson_use afp)
+               $(meson_use archive)
+               $(meson_use cdda)
+               $(meson_use zeroconf dnssd)
+               $(meson_use gnome-online-accounts goa)
+               $(meson_use google)
+               $(meson_use gphoto2)
+               $(meson_use http)
+               $(meson_use mtp)
+               $(meson_use nfs)
+               -Dsftp=true
+               $(meson_use samba smb)
+               $(meson_use udisks udisks2)
+               $(meson_use bluray)
+               $(meson_use fuse)
+               -Dgcr=true
+               -Dgcrypt=${enable_gcrypt}
+               $(meson_use udev gudev)
+               $(meson_use gnome-keyring keyring)
+               -Dlogind=${enable_logind}
+               -Dlibusb=${enable_libusb}
+               -Ddevel_utils=false # wouldn't install any of it as of 1.38.1; some tests need it, but they aren't automated tests in v1.38.1
+               -Dinstalled_tests=false
+               -Dman=true
+       )
+       meson_src_configure
+}
+
+pkg_postinst() {
+       xdg_pkg_postinst
+       gnome2_schemas_update
+       gnome2_giomodule_cache_update
+}
+
+pkg_postrm() {
+       xdg_pkg_postrm
+       gnome2_schemas_update
+       gnome2_giomodule_cache_update
+}