projects
/
gentoo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
daf9ccb
)
dev-ruby/httparty: fix gemspec generation
author
Hans de Graaff
<graaff@gentoo.org>
Thu, 19 Sep 2019 05:55:14 +0000
(07:55 +0200)
committer
Hans de Graaff
<graaff@gentoo.org>
Thu, 19 Sep 2019 06:03:56 +0000
(08:03 +0200)
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
dev-ruby/httparty/httparty-0.17.1.ebuild
patch
|
blob
|
history
diff --git
a/dev-ruby/httparty/httparty-0.17.1.ebuild
b/dev-ruby/httparty/httparty-0.17.1.ebuild
index 91c3eb58c40deb8a2cb598ebc2a44a9be5229c4a..418e319afe65d3ad1c515a2189c78271bea7bce4 100644
(file)
--- a/
dev-ruby/httparty/httparty-0.17.1.ebuild
+++ b/
dev-ruby/httparty/httparty-0.17.1.ebuild
@@
-28,6
+28,8
@@
ruby_add_rdepend 'dev-ruby/mime-types:3 >=dev-ruby/multi_xml-0.5.2'
ruby_add_bdepend 'test? ( dev-ruby/webmock )'
all_ruby_prepare() {
+ sed -i -e 's/git ls-files \?-\?-\?/find/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
# Remove bundler
rm Gemfile || die
sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die