dev-libs/wayland-protocols: Version bump to 1.20
authorMatt Turner <mattst88@gentoo.org>
Sat, 7 Mar 2020 03:06:48 +0000 (19:06 -0800)
committerMatt Turner <mattst88@gentoo.org>
Sat, 7 Mar 2020 03:10:26 +0000 (19:10 -0800)
Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-libs/wayland-protocols/Manifest
dev-libs/wayland-protocols/wayland-protocols-1.20.ebuild [new file with mode: 0644]
dev-libs/wayland-protocols/wayland-protocols-9999.ebuild

index 96c5ba05c4b50a5b7c4714e548c7d2b4f46a5cfe..e66308acbbefa9ee06b729724d320d3be01b4845 100644 (file)
@@ -1,2 +1,3 @@
 DIST wayland-protocols-1.18.tar.xz 108344 BLAKE2B 7e770bafa364ff96441354246801d1c6cbe561eefe864673610dc2d47e3aa5ac7cd22a2fc2925aa1060a261ed6df8b6b5ef81c33adbeb374170821feeecd651f SHA512 166be44f370a99281da442e7e2c2fc2f3169b61eeaa69263611b4e33847e93d1071f3cc89537597e1252d48d03993ce39c7d65f43b66a23c9b1551f47959e483
 DIST wayland-protocols-1.19.tar.xz 107612 BLAKE2B ff91a7eeca0e43a3e93c927f440253c01751872ace142d874431a347ad652c04d02f36fa08b7e48787d569db9787415eafbd24495a442568b6476332c8935243 SHA512 f09b700a785da0002ca215d2e695461368534c5c961e064ca19b73fe0c72754b3c9d4076cf495d8c907053dbabb2381f6a2bbcef41564071a4c589a8c44ff0fb
+DIST wayland-protocols-1.20.tar.xz 111684 BLAKE2B 2ddd3d0b0dde94fda4788a1fd6631b6fcf22fb134e74a55f2c310ab4b72802d3b069d294e3d7b68ea6ddfdb0f944ac9011b73a9678e65eec924135822f697087 SHA512 d13f65d03add2c39cc32bf6bda0e981e9f52504bf8505fceea045c8baeb73bea64fa4edb99cb837677fbab1b5b3023054adff36fac127e819690f366b81c4977
diff --git a/dev-libs/wayland-protocols/wayland-protocols-1.20.ebuild b/dev-libs/wayland-protocols/wayland-protocols-1.20.ebuild
new file mode 100644 (file)
index 0000000..85d20d4
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ ${PV} = 9999* ]]; then
+       EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/${PN}.git/"
+       inherit git-r3 autotools
+else
+       SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/wayland"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+       default
+
+       [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_test() {
+       export XDG_RUNTIME_DIR="${T}/runtime-dir"
+       mkdir "${XDG_RUNTIME_DIR}" || die
+       chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+       default
+}
index 837f825ff1b888eb1d3f7cba51bb03295d0f283f..85d20d4e9e318a55935a212f83b66a5bb7527dca 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7