dev-python/fixtures: Add pypy3 support
authorJustin Lecher <jlec@gentoo.org>
Mon, 24 Aug 2015 06:00:06 +0000 (08:00 +0200)
committerJustin Lecher <jlec@gentoo.org>
Mon, 24 Aug 2015 10:12:07 +0000 (12:12 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/fixtures/fixtures-1.3.1-r1.ebuild

index 56e3e7490ed568431995227492dc09d66e2d8199..ac95e29b2a5b4b13c623caddb90b783de8e4885c 100644 (file)
@@ -3,7 +3,8 @@
 # $Id$
 
 EAPI=5
-PYTHON_COMPAT=( python2_7 python3_3 python3_4 pypy )
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
 
 inherit distutils-r1
 
@@ -23,7 +24,7 @@ RDEPEND="
        dev-python/six[${PYTHON_USEDEP}]
        >=dev-python/testtools-0.9.22[${PYTHON_USEDEP}]"
 DEPEND="${RDEPEND}
-       test? ( dev-python/mock[$(python_gen_usedep python2_7 pypy)] )"
+       test? ( dev-python/mock[${PYTHON_USEDEP}] )"
 #DISTUTILS_IN_SOURCE_BUILD=1
 
 python_test() {