dev-python/awscli: bump to v1.18.62
authorThomas Deutschmann <whissi@gentoo.org>
Tue, 19 May 2020 09:40:53 +0000 (11:40 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Tue, 19 May 2020 09:49:01 +0000 (11:49 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-python/awscli/Manifest
dev-python/awscli/awscli-1.18.62.ebuild [new file with mode: 0644]

index 6dc29205c31ac5ef864760fe730adb4f5d31d411..465d50b4b95e8286ae8a0afd47f614cc6e1f7eba 100644 (file)
@@ -1,2 +1,3 @@
 DIST awscli-1.18.48.tar.gz 1737744 BLAKE2B 818709e924cac51fb8490383d91d9d935f812bb019a71051a2a062676b2720eecd2a59b6c398c599cba6caaf7da35179864eb80fd91cc5ec7547cd56d89de01b SHA512 1501a4d588e2ce2f4ed668a8e827403ed4e4d4588fabef26aecbc6521931ccc760918ce9ddd14af92a94d17cc980a84a3e95f5f21e84b955d2923a0daf62fa7a
 DIST awscli-1.18.56.tar.gz 1738900 BLAKE2B 520ca08c2b9d52c666247af375fc4da5f4da9e5eb779001ee70c5c77c9c9faba7fae045baeab6bf74c5727cccd6499accfa3b554b0c2082930c855a06be8cc45 SHA512 4c5f126bf485815a9bf48c2ead1353e5b1cbc6ac34201303c3e245a88c4b321bfcdec96cbbee6419e7128285c03b938fa0138c2f6204699c3fc8f045a6a7ad09
+DIST awscli-1.18.62.tar.gz 1739551 BLAKE2B 029119e6c4d9078f46507c1837c2122f86ab3bc83e8e34bdf6ddb969426769845ea6ae49d8f1cff3e4c9d2951ce562e6bf395b67082efd3eeade0e2c36638ab4 SHA512 08e996d4cdcb941553969310b998a033a4a4dfeec1de44167e8cd3c4a46e751858285a8d33ddc348c1133c90d25bb73da6ee33f6e2c94c3dd8dd79f56b85014b
diff --git a/dev-python/awscli/awscli-1.18.62.ebuild b/dev-python/awscli/awscli-1.18.62.ebuild
new file mode 100644 (file)
index 0000000..e1bc7ef
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+
+# requires network access
+RESTRICT="test"
+
+RDEPEND="
+       >=dev-python/botocore-1.16.12[${PYTHON_USEDEP}]
+       <dev-python/colorama-0.4.4[${PYTHON_USEDEP}]
+       dev-python/docutils[${PYTHON_USEDEP}]
+       <dev-python/rsa-3.5.0.0[${PYTHON_USEDEP}]
+       >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+       <dev-python/pyyaml-5.4.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/mock[${PYTHON_USEDEP}]
+               dev-python/nose[${PYTHON_USEDEP}]
+       )
+"
+
+S="${WORKDIR}/aws-cli-${PV}"
+
+python_test() {
+       nosetests -vv || die
+}
+
+python_install_all() {
+       newbashcomp bin/aws_bash_completer aws
+
+       insinto /usr/share/zsh/site-functions
+       newins bin/aws_zsh_completer.sh _aws
+
+       distutils-r1_python_install_all
+
+       rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}