www-servers/automx2: Bump to version 2020.1
authorRalph Seichter <github@seichter.de>
Sun, 8 Mar 2020 21:40:07 +0000 (22:40 +0100)
committerMarc Schiffbauer <mschiff@gentoo.org>
Mon, 9 Mar 2020 05:07:49 +0000 (00:07 -0500)
Upstream release to support "Werkzeug" 1.0.0. This ebuild
also adds support for Python 3.8.

Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Ralph Seichter <gentoo@seichter.de>
Closes: https://github.com/gentoo/gentoo/pull/14881
Signed-off-by: Marc Schiffbauer <mschiff@gentoo.org>
www-servers/automx2/Manifest
www-servers/automx2/automx2-2020.1.ebuild [new file with mode: 0644]

index ac9e496c8d57e65afc1a62cc9b6847cd8b9a5b41..a8ac298f32c72c6bec05a73018d87e60543f140c 100644 (file)
@@ -1 +1,2 @@
 DIST automx2-2019.0.tar.bz2 46670 BLAKE2B 6f62b4429be8046fce18ccba6827879a99627d8fbe9cf7973d8059e87b4968a280b62d5d005aaed3b0e1074053f4a6355c34f2cdce2f06a9afb14c52b4504fb7 SHA512 e494a48ffd3e6d133a89db5afd1dc75116a8efcc41f0571a24271bcbe6074c86d62184ce00bae9ced888a70be7d20f2a3614f28007d4481537d42c680dca4daa
+DIST automx2-2020.1.tar.bz2 49405 BLAKE2B 2c9b26300e32e613f622e0b3a39b7f408d22e22638d61da3c93f5d448fe3ebb325e9a0004e3351abed2c9e427373c42637e3539831c04cda8e65a4d1bba1773e SHA512 823e569eacedcf49d53f8ed623a75455e715e3d49186179927a0e10d3efe9823c336912789bbf3d7d2f9aba3053b601352c99bda4ffcc9a7b78e412c938cd91f
diff --git a/www-servers/automx2/automx2-2020.1.ebuild b/www-servers/automx2/automx2-2020.1.ebuild
new file mode 100644 (file)
index 0000000..1553bc9
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Email client autoconfiguration service"
+HOMEPAGE="https://automx.org/"
+SRC_URI="https://gitlab.com/automx/automx2/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+BDEPEND="acct-user/automx2
+       $(python_gen_cond_dep \
+               '>=dev-python/flask-migrate-2.5.2[${PYTHON_MULTI_USEDEP}]' python-3
+       )"
+RDEPEND="${BDEPEND}"
+
+python_prepare_all() {
+       sed -i -e "/('scripts'/d" setup.py || die
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       export AUTOMX2_CONF="tests/unittest.conf"
+       ${EPYTHON} -m unittest discover tests/ || die
+}
+
+python_install_all() {
+       if use doc; then
+               DOCS="*.adoc doc/*.adoc contrib/*sample.conf"
+               HTML_DOCS="doc/*.html doc/*.svg"
+       fi
+       sed -e "s/@EPYTHON@/${EPYTHON}/" "${FILESDIR}/init" | newinitd - "${PN}"
+       newconfd "${FILESDIR}/confd" "${PN}"
+       insinto /etc
+       newins "${FILESDIR}/conf" "${PN}.conf"
+       distutils-r1_python_install_all
+}