app-editors/nedit: Fix for format-security
authorJustin Lecher <jlec@gentoo.org>
Mon, 21 Sep 2015 08:27:01 +0000 (10:27 +0200)
committerJustin Lecher <jlec@gentoo.org>
Mon, 21 Sep 2015 08:27:09 +0000 (10:27 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
app-editors/nedit/files/nedit-5.6-format.patch [new file with mode: 0644]
app-editors/nedit/metadata.xml
app-editors/nedit/nedit-5.6.ebuild

diff --git a/app-editors/nedit/files/nedit-5.6-format.patch b/app-editors/nedit/files/nedit-5.6-format.patch
new file mode 100644 (file)
index 0000000..e2d6e17
--- /dev/null
@@ -0,0 +1,12 @@
+diff -up nedit-5.6/source/nc.c.format nedit-5.6/source/nc.c
+--- nedit-5.6/source/nc.c.format       2014-12-28 13:56:20.000000000 +0000
++++ nedit-5.6/source/nc.c      2015-06-17 07:30:25.617032345 +0100
+@@ -503,7 +503,7 @@ static int startServer(const char *messa
+     
+     /* prompt user whether to start server */
+     if (!Preferences.autoStart) {
+-      printf(message);
++      printf("%s", message);
+       do {
+           c = getc(stdin);
+       } while (c == ' ' || c == '\t');
index b71a05ca27aaa346a203bc6b1a1e6ea330d836a9..843f88b58fab114d63e4542809fc04e67559f3ca 100644 (file)
@@ -1,7 +1,7 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-<maintainer>
-<email>amynka@gentoo.org</email>
-</maintainer>
+       <maintainer>
+               <email>amynka@gentoo.org</email>
+       </maintainer>
 </pkgmetadata>
index 3c2f414752d6f2ef885725090653479bd647df4d..ac944828872314f45ad316c294522e900861057d 100644 (file)
@@ -28,6 +28,7 @@ S="${WORKDIR}/${PN}-5.6"
 src_prepare() {
        #respecting LDFLAGS, bug #208189
        epatch \
+               "${FILESDIR}"/${P}-format.patch \
                "${FILESDIR}"/${P}-ldflags.patch \
                "${FILESDIR}"/${P}-40_Pointer_to_Integer.patch
        sed \