net-dns/knot: bump to 2.8.2
authorPierre-Olivier Mercier <nemunaire@nemunai.re>
Thu, 6 Jun 2019 13:56:31 +0000 (15:56 +0200)
committerMichał Górny <mgorny@gentoo.org>
Thu, 6 Jun 2019 17:11:45 +0000 (19:11 +0200)
Package-Manager: Portage-2.3.62, Repoman-2.3.11
Signed-off-by: Pierre-Olivier Mercier <nemunaire@nemunai.re>
Signed-off-by: Michał Górny <mgorny@gentoo.org>
net-dns/knot/Manifest
net-dns/knot/knot-2.8.2.ebuild [new file with mode: 0644]

index 74e5344ff0c8f06c28a59e395a385f353a13226f..e396059417a9bcb0e2f5d468aa483b73cc8323b7 100644 (file)
@@ -2,3 +2,4 @@ DIST knot-2.7.6.tar.xz 1151068 BLAKE2B aba7b9f89d98ddabe5596198b0767b6d88cab2278
 DIST knot-2.7.7.tar.xz 1156996 BLAKE2B aa31233cf9af9f8060a40788529593d35912992472d5b9d892e632ba4cbf08a0f0adec6ed00d1152bf6cd443e3a659fa88050355e65a71cc2a3aac3c453bdc44 SHA512 95c341ce7c8cc2e65429d6e3bf009844fbd82ca5a0e36019f0e019ce35fc3ba8b68c159d34637380f6a3ad3dc2291ed5adc37e91515b2b6ecf61f7078ddad841
 DIST knot-2.8.0.tar.xz 1168900 BLAKE2B e6d54709ce0bbc5411918de337fd2eb1cb939bbaf1b0dec149b169c2a93c6c0f4719028e35ff9a07d940d5e30470a4661e847a83c73ba0baaf89a520d8ee4fc3 SHA512 0cf2840d908bbab3197bff82d37e4a754204a3b79efa7e982719bc19028519d3ff0b2177780dada54e1b070f5f7aa28dab7bbfcc2d2ea086817f3a29b746228e
 DIST knot-2.8.1.tar.xz 1169260 BLAKE2B 0a02394d5dfdce98d5f909f04a8902778f152d366d76f449ee57dfe99ad6168d7848454fbf21e01ce47dde1721af5293445f450f45949c21c3715f3f32fd5af9 SHA512 b1f97171efae85b5d6f845e57d933170e8f81b30e8b5a1a6157bb0f6bf5e1e545e7b3d2d51eedf0061166e9842ab01eb6c5e84b1ef9e98e20eda9a806e3e5d4b
+DIST knot-2.8.2.tar.xz 1193760 BLAKE2B 0afd70740be103d596856dfcfea629b5216aa41e8e0044f050a993967c7bf53a129fd824d1d1ec6fef4d41072f25225f06a6113bf86266d755d6f944c8b5799f SHA512 d7a045cc7b1a1f43b9536283d4202d7f8f36ac2160e0b985b40f318cc0041f3c3e977ff2db6f518dd37ea62d93d0d3f617bca1ac0dff81185bf5dcb9c1eac97b
diff --git a/net-dns/knot/knot-2.8.2.ebuild b/net-dns/knot/knot-2.8.2.ebuild
new file mode 100644 (file)
index 0000000..5ccc7dc
--- /dev/null
@@ -0,0 +1,107 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd user
+
+DESCRIPTION="High-performance authoritative-only DNS server"
+HOMEPAGE="https://www.knot-dns.cz/"
+SRC_URI="https://secure.nic.cz/files/knot-dns/${P/_/-}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+KNOT_MODULES=(
+       "+cookies"
+       "+dnsproxy"
+       "dnstap"
+       "geoip"
+       "+noudp"
+       "+onlinesign"
+       "+queryacl"
+       "+rrl"
+       "+stats"
+       "+synthrecord"
+       "+whoami"
+)
+IUSE="doc caps +fastparser idn +libidn2 systemd +utils ${KNOT_MODULES[@]}"
+
+RDEPEND="
+       dev-db/lmdb
+       dev-libs/libedit
+       dev-libs/userspace-rcu:=
+       dev-python/lmdb
+       net-libs/gnutls:=
+       caps? ( sys-libs/libcap-ng )
+       dnstap? (
+               dev-libs/fstrm
+               dev-libs/protobuf-c:=
+       )
+       geoip? ( dev-libs/libmaxminddb:= )
+       idn? (
+               !libidn2? ( net-dns/libidn:0= !net-dns/libidn2 )
+               libidn2? ( net-dns/libidn2:= )
+       )
+       systemd? ( sys-apps/systemd:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+       virtual/pkgconfig
+       doc? ( dev-python/sphinx )
+"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_configure() {
+       local u
+       local my_conf=(
+               --with-storage="${EPREFIX}/var/lib/${PN}"
+               --with-rundir="${EPREFIX}/var/run/${PN}"
+               $(use_enable fastparser)
+               $(use_enable dnstap)
+               $(use_enable doc documentation)
+               $(use_enable utils utilities)
+               --enable-systemd=$(usex systemd)
+               $(use_with idn libidn)
+       )
+
+       for u in "${KNOT_MODULES[@]#+}"; do
+               my_conf+=("$(use_with ${u} module-${u})")
+       done
+
+       econf "${my_conf[@]}"
+}
+
+src_compile() {
+       default
+
+       if use doc; then
+               emake -C doc html
+               HTML_DOCS=( doc/_build/html/{*.html,*.js,_sources,_static} )
+       fi
+}
+
+src_test() {
+       emake check
+}
+
+src_install() {
+       default
+
+       rmdir "${D}/var/run/${PN}" "${D}/var/run/" || die
+       keepdir /var/lib/${PN}
+
+       newinitd "${FILESDIR}/knot.init" knot
+       if use systemd; then
+               systemd_newunit "${FILESDIR}/knot-1.service" knot.service
+       fi
+
+       find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+       enewgroup knot 53
+       enewuser knot 53 -1 /var/lib/knot knot
+}