dev-libs/npth: version bump to 1.6
authorTim Harder <radhermit@gentoo.org>
Thu, 27 Sep 2018 03:20:16 +0000 (23:20 -0400)
committerTim Harder <radhermit@gentoo.org>
Fri, 28 Sep 2018 17:31:33 +0000 (13:31 -0400)
dev-libs/npth/Manifest
dev-libs/npth/npth-1.6.ebuild [new file with mode: 0644]

index 061c4ac54ba2626654cac2074b9480a42055273e..1ef1314ed2a6c59dab2cb25cee2fd22f82242ad5 100644 (file)
@@ -1,3 +1,4 @@
 DIST npth-1.3.tar.bz2 295998 BLAKE2B 25c0176439a5be3766df15526b06dd07f318dca8b729eb5ec461a40b912132ebbf7bf6ddb2b57a064bfba73f3fe0ab59c00daf6138324f53f5e9e6df91941bf8 SHA512 97b0278cc9448adb42c4a83b8e7bafeed939acaf3dd3a201a1b103df4e48f24224d4bdaeb97903ad1884914ce363cbceffe948a7c1db4f19abf87ca5964f5699
 DIST npth-1.4.tar.bz2 299106 BLAKE2B ba5186de1371d08137e86ef1f6ad12a610a26b7ae3ca50d6fc49f685083380803b245acf01110a28ab25427208bab82de73f16d6f21011b1a0590d16c7c85cf7 SHA512 649009b4fbd2bbbb8fce2911c2f9070a758d037be0d147a63754e3c1f5a9ffb73b907cd09c79314fe60c25084ca7a7b3b387139dd83cc0e11a7e7ba64630ae1f
 DIST npth-1.5.tar.bz2 299308 BLAKE2B 1a3cef4475ad5440487151026889ef321626b372d1c6970c7482df92a702d02860589f7f1f541b1fccf0e8f39b194476ef91507e33a35e05ba3713465f9f11d1 SHA512 20f0ec59d304c68081e42535870af8e76c18e30aa7b04ccdafe60fe5261ad7275c2c0e3ea3a767d6145258a3a39fa641032cd97205318266dd727a5fe7ee331a
+DIST npth-1.6.tar.bz2 300486 BLAKE2B 665fdb2f4cbe59750b6b4b7c2701ee80a23a122df10c9f8be47c4af5f3bf5968f709637ab3f4878bb68609752fbb6ce1364e109fdfeba64e4db258733a33f3fc SHA512 2ed1012e14a9d10665420b9a23628be7e206fd9348111ec751349b93557ee69f1176bcf7e6b195b35b1c44a5e0e81ee33b713f03d79a33d1ecd9037035afeda2
diff --git a/dev-libs/npth/npth-1.6.ebuild b/dev-libs/npth/npth-1.6.ebuild
new file mode 100644 (file)
index 0000000..f8b047f
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit libtool
+
+DESCRIPTION="New GNU Portable Threads Library"
+HOMEPAGE="https://git.gnupg.org/cgi-bin/gitweb.cgi?p=npth.git"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~amd64-fbsd"
+IUSE="static-libs"
+
+src_prepare() {
+       default
+       elibtoolize  # for Solaris shared library
+}
+
+src_configure() {
+       econf $(use_enable static-libs static)
+}
+
+src_install() {
+       default
+       find "${D}" -name '*.la' -delete || die
+}