dev-python/nose: Clean py27-requiring docs up
authorMichał Górny <mgorny@gentoo.org>
Mon, 25 May 2020 12:38:20 +0000 (14:38 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 25 May 2020 12:44:33 +0000 (14:44 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/nose/nose-1.3.7-r5.ebuild [new file with mode: 0644]

diff --git a/dev-python/nose/nose-1.3.7-r5.ebuild b/dev-python/nose/nose-1.3.7-r5.ebuild
new file mode 100644 (file)
index 0000000..8ce50a0
--- /dev/null
@@ -0,0 +1,81 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Unittest extension with automatic test suite discovery and easy test authoring"
+HOMEPAGE="
+       https://pypi.org/project/nose/
+       https://nose.readthedocs.io/en/latest/
+       https://github.com/nose-devs/nose"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="coverage examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       coverage? ( dev-python/coverage[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+       test? (
+               dev-python/coverage[${PYTHON_USEDEP}]
+               $(python_gen_cond_dep '
+                       dev-python/twisted[${PYTHON_USEDEP}]
+               ' python2_7 python3_{6,7,8})
+       )"
+
+PATCHES=(
+       "${FILESDIR}"/${P}-python-3.5-backport.patch
+
+       # Patch against master found in an upstream PR, backported:
+       # https://github.com/nose-devs/nose/pull/1004
+       "${FILESDIR}"/${P}-coverage-4.1-support.patch
+
+       "${FILESDIR}"/${P}-python-3.6-test.patch
+)
+
+python_prepare_all() {
+       # Tests need to be converted, and they don't respect BUILD_DIR.
+       use test && DISTUTILS_IN_SOURCE_BUILD=1
+
+       # Disable tests requiring network connection.
+       sed \
+               -e "s/test_resolve/_&/g" \
+               -e "s/test_raises_bad_return/_&/g" \
+               -e "s/test_raises_twisted_error/_&/g" \
+               -i unit_tests/test_twisted.py || die "sed failed"
+       # Disable versioning of nosetests script to avoid collision with
+       # versioning performed by the eclass.
+       sed -e "/'nosetests%s = nose:run_exit' % py_vers_tag,/d" \
+               -i setup.py || die "sed2 failed"
+
+       distutils-r1_python_prepare_all
+}
+
+python_compile() {
+       local add_targets=()
+
+       if use test; then
+               add_targets+=( egg_info )
+               python_is_python3 && add_targets+=( build_tests )
+       fi
+
+       distutils-r1_python_compile "${add_targets[@]}"
+}
+
+python_test() {
+       "${EPYTHON}" selftest.py -v || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+       use examples && dodoc -r examples
+       distutils-r1_python_install_all
+}