media-libs/elgato-streamdeck: initial ebuild
authorRick Farina <zerochaos@gentoo.org>
Tue, 19 May 2020 19:51:42 +0000 (15:51 -0400)
committerRick Farina <zerochaos@gentoo.org>
Thu, 21 May 2020 16:27:31 +0000 (12:27 -0400)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Rick Farina <zerochaos@gentoo.org>
media-libs/elgato-streamdeck/Manifest [new file with mode: 0644]
media-libs/elgato-streamdeck/elgato-streamdeck-0.8.1.ebuild [new file with mode: 0644]
media-libs/elgato-streamdeck/elgato-streamdeck-9999.ebuild [new file with mode: 0644]
media-libs/elgato-streamdeck/metadata.xml [new file with mode: 0644]

diff --git a/media-libs/elgato-streamdeck/Manifest b/media-libs/elgato-streamdeck/Manifest
new file mode 100644 (file)
index 0000000..84233cc
--- /dev/null
@@ -0,0 +1 @@
+DIST elgato-streamdeck-0.8.1.tar.gz 2552919 BLAKE2B 505a7ad71b04473b3eb2c719304c224829ebf5abc366bea0d38daf882099d92308b1099815435ac03f65542bdb908a2cafbdc96f10168351fd06644050b69f06 SHA512 c65b90ab0ee5c6e17a6f7af670c54a12c96b705ef4bec359a51ba6671a3908626a9658f5a5829266102fa249628b82ee04c525db995f4984f26f802620598e6c
diff --git a/media-libs/elgato-streamdeck/elgato-streamdeck-0.8.1.ebuild b/media-libs/elgato-streamdeck/elgato-streamdeck-0.8.1.ebuild
new file mode 100644 (file)
index 0000000..07a7469
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Python library to control the Elgato Stream Deck"
+HOMEPAGE="https://github.com/abcminiuser/python-elgato-streamdeck"
+if [ "${PV}" = "9999" ]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/abcminiuser/python-elgato-streamdeck.git"
+else
+       SRC_URI="https://github.com/abcminiuser/python-elgato-streamdeck/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+       S="${WORKDIR}/python-${P}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/pillow[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
diff --git a/media-libs/elgato-streamdeck/elgato-streamdeck-9999.ebuild b/media-libs/elgato-streamdeck/elgato-streamdeck-9999.ebuild
new file mode 100644 (file)
index 0000000..07a7469
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Python library to control the Elgato Stream Deck"
+HOMEPAGE="https://github.com/abcminiuser/python-elgato-streamdeck"
+if [ "${PV}" = "9999" ]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/abcminiuser/python-elgato-streamdeck.git"
+else
+       SRC_URI="https://github.com/abcminiuser/python-elgato-streamdeck/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+       S="${WORKDIR}/python-${P}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/pillow[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
diff --git a/media-libs/elgato-streamdeck/metadata.xml b/media-libs/elgato-streamdeck/metadata.xml
new file mode 100644 (file)
index 0000000..cb9246c
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>sidhayn@gmail.com</email>
+               <name>Rick Farina</name>
+       </maintainer>
+  <upstream>
+    <remote-id type="github">abcminiuser/python-elgato-streamdeck</remote-id>
+  </upstream>
+</pkgmetadata>