dev-util/gn: bump to 0.1726
authorStephan Hartmann <stha09@googlemail.com>
Sat, 14 Mar 2020 19:51:18 +0000 (20:51 +0100)
committerMike Gilbert <floppym@gentoo.org>
Sun, 15 Mar 2020 01:21:27 +0000 (21:21 -0400)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Stephan Hartmann <stha09@googlemail.com>
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
dev-util/gn/Manifest
dev-util/gn/files/gn-gen-r4.patch [new file with mode: 0644]
dev-util/gn/gn-0.1726.ebuild [new file with mode: 0644]

index f681f83b9e40d86aec2d112ee0e98ad17bd56b3a..69f8b57f5866ab0a614ee47bc3ac255c1290be59 100644 (file)
@@ -1,3 +1,4 @@
 DIST gn-0.1463.tar.gz 905571 BLAKE2B e048e642704533d478fb751748a97f60283f63868ab1ab6fa5b8e7bc0322745cf21464eaa16194f684869b50f306668d3c7d3b4f72c3985b865d8492d1ff0901 SHA512 f32861a8fa44034b932e6aae4787fd7da6e4c6c19c5b6919de7b0d0f1ba20f415c1c55db95a08958a338b7b9de740ff49a29ab894a9c4e9049a89450d8c88281
 DIST gn-0.1544.tar.gz 911124 BLAKE2B b8bac7783c373e8101cf727c254c2ee50af49c3e679a8df2cb337a0637e305f1f9094517e6af6a76a19300f533a41d9433624a7963ba0151a88a636bc7e6b4f8 SHA512 5cb3a25b66d44cd26063453ddf96563d62b24e8a961ca7fa29a48ee7bde4a423bd0dace36c432b46b677e042fcac9a4fb23afa5dc27e994fca54030b972dad29
 DIST gn-0.1616.tar.xz 660332 BLAKE2B dab581d9f05cbe7ed91758d0ec68c61bd4e9fd0357b9cfa04f5276185ed6e810b37d9e2177cf3daec29e25633af2d32c6f733507a77cee7e37681bb977a59818 SHA512 42f68b40eebc423b785b1ba735548b3e5d2b64abd0dc1bb22940b9336c491308f062f547f81b5366c1dfe1f0e3bb41390ed3e3712637765cac1a50499a5e04d2
+DIST gn-0.1726.tar.xz 663480 BLAKE2B 26920a1594e9cc664293efaeaa8725568b78ecc1f2ac8c9a3cd27333e5fe89f1fa5bdee9e42c408f3c4a7cfb630e79220926c5694e31131d3e7627be49b5d6b2 SHA512 3e93ba02f251386c4aa320a45b8a045c2a1fa686a8f170455f3c06bb25b1a628c44530ae2e56bcbb2ff4b2a84dd065d54dde90955a55a325a8d219acce69ec2f
diff --git a/dev-util/gn/files/gn-gen-r4.patch b/dev-util/gn/files/gn-gen-r4.patch
new file mode 100644 (file)
index 0000000..717c908
--- /dev/null
@@ -0,0 +1,46 @@
+From ad008cd029c995226fef36554e2e3cc657ef1380 Mon Sep 17 00:00:00 2001
+From: Mike Gilbert <floppym@gentoo.org>
+Date: Sat, 14 Mar 2020 18:02:51 +0000
+Subject: [PATCH] Remove unwanted cflags/ldflags parameters
+
+---
+ build/gen.py | 9 ---------
+ 1 file changed, 9 deletions(-)
+
+diff --git a/build/gen.py b/build/gen.py
+index bcd9f15d..b48e844c 100755
+--- a/build/gen.py
++++ b/build/gen.py
+@@ -288,11 +288,6 @@ def WriteGNNinja(path, platform, host, options):
+     if options.debug:
+       cflags.extend(['-O0', '-g'])
+     else:
+-      cflags.append('-DNDEBUG')
+-      cflags.append('-O3')
+-      if options.no_strip:
+-        cflags.append('-g')
+-      ldflags.append('-O3')
+       # Use -fdata-sections and -ffunction-sections to place each function
+       # or data item into its own section so --gc-sections can eliminate any
+       # unused functions and data items.
+@@ -325,7 +320,6 @@ def WriteGNNinja(path, platform, host, options):
+         '-D_FILE_OFFSET_BITS=64',
+         '-D__STDC_CONSTANT_MACROS', '-D__STDC_FORMAT_MACROS',
+         '-pthread',
+-        '-pipe',
+         '-fno-exceptions',
+         '-fno-rtti',
+         '-fdiagnostics-color',
+@@ -341,9 +335,6 @@ def WriteGNNinja(path, platform, host, options):
+       if not options.no_static_libstdcpp:
+         ldflags.append('-static-libstdc++')
+-      # This is needed by libc++.
+-      if not platform.is_mingw():
+-        libs.append('-ldl')
+     elif platform.is_darwin():
+       min_mac_version_flag = '-mmacosx-version-min=10.9'
+       cflags.append(min_mac_version_flag)
+-- 
+2.24.1
+
diff --git a/dev-util/gn/gn-0.1726.ebuild b/dev-util/gn/gn-0.1726.ebuild
new file mode 100644 (file)
index 0000000..0c11eb3
--- /dev/null
@@ -0,0 +1,64 @@
+# Copyright 2018-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit ninja-utils python-any-r1 toolchain-funcs
+
+DESCRIPTION="GN is a meta-build system that generates build files for Ninja"
+HOMEPAGE="https://gn.googlesource.com/"
+SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="vim-syntax"
+
+BDEPEND="
+       ${PYTHON_DEPS}
+       dev-util/ninja
+"
+
+PATCHES=(
+       "${FILESDIR}"/gn-gen-r4.patch
+)
+
+pkg_setup() {
+       :
+}
+
+src_configure() {
+       python_setup
+       tc-export AR CC CXX
+       unset CFLAGS
+       set -- ${EPYTHON} build/gen.py --no-last-commit-position --no-strip --no-static-libstdc++
+       echo "$@" >&2
+       "$@" || die
+       cat >out/last_commit_position.h <<-EOF || die
+       #ifndef OUT_LAST_COMMIT_POSITION_H_
+       #define OUT_LAST_COMMIT_POSITION_H_
+       #define LAST_COMMIT_POSITION_NUM ${PV##0.}
+       #define LAST_COMMIT_POSITION "${PV}"
+       #endif  // OUT_LAST_COMMIT_POSITION_H_
+       EOF
+}
+
+src_compile() {
+       eninja -C out gn
+}
+
+src_test() {
+       eninja -C out gn_unittests
+       out/gn_unittests || die
+}
+
+src_install() {
+       dobin out/gn
+       einstalldocs
+
+       if use vim-syntax; then
+               insinto /usr/share/vim/vimfiles
+               doins -r tools/gn/misc/vim/{autoload,ftdetect,ftplugin,syntax}
+       fi
+}