dev-python/pynput: initial ebuild
authorRick Farina <zerochaos@gentoo.org>
Fri, 22 May 2020 16:40:12 +0000 (12:40 -0400)
committerRick Farina <zerochaos@gentoo.org>
Fri, 22 May 2020 17:22:10 +0000 (13:22 -0400)
imported from multiple sources and edited a lot

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Rick Farina <zerochaos@gentoo.org>
dev-python/pynput/Manifest [new file with mode: 0644]
dev-python/pynput/metadata.xml [new file with mode: 0644]
dev-python/pynput/pynput-1.6.8.ebuild [new file with mode: 0644]
dev-python/pynput/pynput-9999.ebuild [new file with mode: 0644]

diff --git a/dev-python/pynput/Manifest b/dev-python/pynput/Manifest
new file mode 100644 (file)
index 0000000..62ccc8a
--- /dev/null
@@ -0,0 +1 @@
+DIST pynput-1.6.8.tar.gz 94483 BLAKE2B c04714fb9cdda9527ed6d3c0e7c25214a7678ee908f1a638023b95c2f63242fa7dc28f193b2055338a9cce10c26399eb4f4af0ec69a6ffaa1be0b7e85481ecc4 SHA512 23cf2e47e0a284aeb2e294529a1f47a01a42bccae146500eee2ff74704cb5ef7ff33327cca5d6ebec338369b1341c489431891d9f034801cc6be9aac2af90442
diff --git a/dev-python/pynput/metadata.xml b/dev-python/pynput/metadata.xml
new file mode 100644 (file)
index 0000000..2b9b426
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>zerochaos@gentoo.org</email>
+               <name>Rick Farina</name>
+       </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pynput/pynput-1.6.8.ebuild b/dev-python/pynput/pynput-1.6.8.ebuild
new file mode 100644 (file)
index 0000000..a9c4160
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Sends virtual input commands"
+HOMEPAGE="https://github.com/moses-palmer/pynput"
+LICENSE="GPL-3"
+SLOT="0"
+if [ "${PV}" = "9999" ]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/moses-palmer/pynput.git"
+else
+       SRC_URI="https://github.com/moses-palmer/pynput/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+IUSE=""
+
+RDEPEND="
+       dev-python/six[${PYTHON_USEDEP}]
+       dev-python/python-xlib[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+src_prepare(){
+       sed -i "s/ + SETUP_PACKAGES,/,/g" setup.py
+       distutils-r1_src_prepare
+}
diff --git a/dev-python/pynput/pynput-9999.ebuild b/dev-python/pynput/pynput-9999.ebuild
new file mode 100644 (file)
index 0000000..a9c4160
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Sends virtual input commands"
+HOMEPAGE="https://github.com/moses-palmer/pynput"
+LICENSE="GPL-3"
+SLOT="0"
+if [ "${PV}" = "9999" ]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/moses-palmer/pynput.git"
+else
+       SRC_URI="https://github.com/moses-palmer/pynput/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+IUSE=""
+
+RDEPEND="
+       dev-python/six[${PYTHON_USEDEP}]
+       dev-python/python-xlib[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+src_prepare(){
+       sed -i "s/ + SETUP_PACKAGES,/,/g" setup.py
+       distutils-r1_src_prepare
+}