sys-freebsd/freebsd-lib: Remove support for non-existent deps
authorMichał Górny <mgorny@gentoo.org>
Sun, 26 Aug 2018 20:14:46 +0000 (22:14 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 26 Aug 2018 20:34:34 +0000 (22:34 +0200)
profiles/base/package.use.mask
sys-freebsd/freebsd-lib/freebsd-lib-11.1-r1.ebuild
sys-freebsd/freebsd-lib/freebsd-lib-9.1-r11.ebuild
sys-freebsd/freebsd-lib/metadata.xml

index d9d758931445734c616928043563bd25834ea139..4ca9fdf3fee668126ca424e3ff1deb2255eb42d8 100644 (file)
@@ -68,10 +68,6 @@ dev-lang/rust extended
 # dev-python/visual will be removed (#630252)
 net-analyzer/scapy visual
 
-# Pacho Ramos <pacho@gentoo.org> (18 Mar 2018)
-# net-dns/hesiod will be removed (#606652)
-sys-freebsd/freebsd-lib hesiod
-
 # Lars Wendler <polynomial-c@gentoo.org> (14 Mar 2018)
 # Broken on all 32bit arches. Globally masked because of sys-apps/dmapi having
 # no active upstream anymore.
index 6e8b27343dc968bc5381b7847d9074ade70ca260..cd66d1e6bd9168f98e915508451b1797379fedae 100644 (file)
@@ -36,7 +36,6 @@ EXTRACTONLY="
 
 if [ "${CATEGORY#*cross-}" = "${CATEGORY}" ]; then
        RDEPEND="ssl? ( dev-libs/openssl:0= )
-               hesiod? ( net-dns/hesiod )
                kerberos? ( app-crypt/heimdal )
                pam? ( virtual/pam )
                usb? ( !dev-libs/libusb )
@@ -71,7 +70,7 @@ if [ "${CTARGET}" = "${CHOST}" -a "${CATEGORY#*cross-}" != "${CATEGORY}" ]; then
        export CTARGET=${CATEGORY/cross-}
 fi
 
-IUSE="atm bluetooth ssl hesiod ipv6 kerberos usb netware
+IUSE="atm bluetooth ssl ipv6 kerberos usb netware
        build headers-only zfs pam xinetd
        userland_GNU userland_BSD"
 
@@ -91,7 +90,7 @@ pkg_setup() {
 
        use atm || mymakeopts="${mymakeopts} WITHOUT_ATM= "
        use bluetooth || mymakeopts="${mymakeopts} WITHOUT_BLUETOOTH= "
-       use hesiod || mymakeopts="${mymakeopts} WITHOUT_HESIOD= "
+       mymakeopts="${mymakeopts} WITHOUT_HESIOD= "
        use ipv6 || mymakeopts="${mymakeopts} WITHOUT_INET6_SUPPORT= "
        use kerberos || mymakeopts="${mymakeopts} WITHOUT_KERBEROS_SUPPORT= WITHOUT_GSSAPI= "
        use netware || mymakeopts="${mymakeopts} WITHOUT_IPX= WITHOUT_IPX_SUPPORT= WITHOUT_NCP= "
index 59b3798a45f05455fcbcb37d308672e2d67d0469..500ae3dcf0ab77b25777a8502cf17bd80dbe5002 100644 (file)
@@ -27,7 +27,6 @@ SRC_URI="mirror://gentoo/${LIB}.tar.bz2
 
 if [ "${CATEGORY#*cross-}" = "${CATEGORY}" ]; then
        RDEPEND="ssl? ( dev-libs/openssl )
-               hesiod? ( net-dns/hesiod )
                kerberos? ( app-crypt/heimdal )
                usb? ( !dev-libs/libusb )
                zfs? ( =sys-freebsd/freebsd-cddl-${RV}* )
@@ -53,7 +52,7 @@ if [ "${CTARGET}" = "${CHOST}" -a "${CATEGORY#*cross-}" != "${CATEGORY}" ]; then
        export CTARGET=${CATEGORY/cross-}
 fi
 
-IUSE="atm bluetooth ssl hesiod ipv6 kerberos usb netware
+IUSE="atm bluetooth ssl ipv6 kerberos usb netware
        build headers-only zfs
        userland_GNU userland_BSD"
 
@@ -69,7 +68,7 @@ pkg_setup() {
 
        use atm || mymakeopts="${mymakeopts} WITHOUT_ATM= "
        use bluetooth || mymakeopts="${mymakeopts} WITHOUT_BLUETOOTH= "
-       use hesiod || mymakeopts="${mymakeopts} WITHOUT_HESIOD= "
+       mymakeopts="${mymakeopts} WITHOUT_HESIOD= "
        use ipv6 || mymakeopts="${mymakeopts} WITHOUT_INET6_SUPPORT= "
        use kerberos || mymakeopts="${mymakeopts} WITHOUT_KERBEROS_SUPPORT= WITHOUT_GSSAPI= "
        use netware || mymakeopts="${mymakeopts} WITHOUT_IPX= WITHOUT_IPX_SUPPORT= WITHOUT_NCP= "
index 24ca54034a3f35d7f922491156a8132ea6c7c22c..4fa69d853494faf7b7c4c69d0865dace4ec33a3a 100644 (file)
@@ -6,7 +6,6 @@
     <name>BSD Project</name>
   </maintainer>
   <use>
-    <flag name="hesiod">Enable support for net-dns/hesiod</flag>
     <flag name="netware">
       Build libraries and tools to work with NetWare protocols (IPX
       and NCP).