dev-python/pyopencl: bump to 2019.1.2
authort0b3 <thomas.bettler@gmail.com>
Sun, 22 Mar 2020 08:06:45 +0000 (09:06 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 30 Mar 2020 17:43:59 +0000 (19:43 +0200)
Bug: https://bugs.gentoo.org/712672
Bug: https://bugs.gentoo.org/711808
Closes: https://bugs.gentoo.org/712680
Signed-off-by: t0b3 <thomas.bettler@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/15040
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pyopencl/Manifest
dev-python/pyopencl/pyopencl-2019.1.2.ebuild [new file with mode: 0644]
profiles/package.mask

index d76f6492151f4d1721c8661a16f6407b71b128eb..7595d5001778ff7758955f2633b93491bcb83e04 100644 (file)
@@ -1 +1,2 @@
 DIST pyopencl-2017.2.tar.gz 350145 BLAKE2B 12c481893158f97dec612256b36e710ab52356c8b5f644f3710b5e34d4d10df3b27137ad76f29543fe16b3da725471e206aa5f69c646a79a65246d6091c686a9 SHA512 49f2ff619d8c214a3962b8444e68ba415dda032abaf9eeab259fcd1b21fbaab10bd057035161baef7f0182995834082218a6667464c01645231a94c88aa5c18b
+DIST pyopencl-2019.1.2.tar.gz 343805 BLAKE2B 027b231231532403a5e18249bd438e1a5a67805a685e46fd9506f7286957b14068540f93a3733149aeba2a720f6c71e91db74351916ca974739374a05f2d2c74 SHA512 b2850622253f480cafacadbb9d13afea801af9d4dd52679f132fc0e5f1d4c2f4d3bdf83c9ed64c14c19ead75e6d36afa8b57ff52bbea135fc02291b1fe7b8636
diff --git a/dev-python/pyopencl/pyopencl-2019.1.2.ebuild b/dev-python/pyopencl/pyopencl-2019.1.2.ebuild
new file mode 100644 (file)
index 0000000..436d47d
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for OpenCL"
+HOMEPAGE="https://mathema.tician.de/software/pyopencl
+       https://pypi.org/project/pyopencl/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples opengl"
+
+RDEPEND="
+       >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
+       >=dev-python/decorator-3.2.0[${PYTHON_USEDEP}]
+       dev-python/mako[${PYTHON_USEDEP}]
+       dev-python/numpy[${PYTHON_USEDEP}]
+       >=dev-python/pytools-2017.5[${PYTHON_USEDEP}]
+       dev-python/pybind11[${PYTHON_USEDEP}]
+       >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+       >=virtual/opencl-2"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+python_configure_all() {
+       local myconf=()
+       if use opengl; then
+               myconf+=(--cl-enable-gl)
+       fi
+
+       "${EPYTHON}" configure.py \
+               --cl-pretend-version=1.2 \
+               "${myconf[@]}"
+}
+
+python_test() {
+       cd "${S}/test" || die
+       pytest -vv || die "Testsuite failed under ${EPYTHON}"
+}
+
+python_install_all() {
+       if use examples; then
+               dodoc -r examples
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
+
+       distutils-r1_python_install_all
+}
index 2fe3031f73dcc398b78ad846b10451387a2a7c83..4046d8f97837d32167ce86665febe240aa6b0950 100644 (file)
@@ -505,7 +505,6 @@ dev-python/pygeocoder
 dev-python/pyhcl
 dev-python/pymtp
 dev-python/pynzb
-dev-python/pyopencl
 dev-python/pyshark
 dev-python/pysolr
 dev-python/pystache