app-emacs/with-editor: add 2.5.10
authorHans de Graaff <graaff@gentoo.org>
Wed, 15 Feb 2017 06:18:01 +0000 (07:18 +0100)
committerHans de Graaff <graaff@gentoo.org>
Wed, 15 Feb 2017 06:18:01 +0000 (07:18 +0100)
Package-Manager: portage-2.3.3

app-emacs/with-editor/Manifest
app-emacs/with-editor/with-editor-2.5.10.ebuild [new file with mode: 0644]

index 5559e1b2add84a427b9a7c50bf20cef9cfe30179..9d2ee2aa571ea5e3428af164a600dfc5fd5f97f8 100644 (file)
@@ -1,2 +1,3 @@
+DIST with-editor-2.5.10.tar.gz 28081 SHA256 c7a849ed827e830f0092695d6b99dce9fad5e1a87e6f0cf1fe7379f860505d53 SHA512 797c7d905eeb4d7398dfba10e4a9b7e7729098a87e48dd75c14fd80f1dd9c5a9693033367a0a9788c4b6c6cc3aa8d2a6ef66ac8bddd24457a61c830887e66a59 WHIRLPOOL bc57ec45d64f4c587fbba2bd847b27ad41ec79dca5745ddd1034005d5c4d48546692bc9dabe723e453ab807a7bc070598701761d7d65fde6d4f2357364376fe5
 DIST with-editor-2.5.8.tar.gz 27978 SHA256 56b2216fb316af5c7673589405a0a7e545a2414a9991374ad95ef15f2a68f0b5 SHA512 abd42a096e3318cc25576b240df1ed670de327afabe675d3df12780c392779f33b88e7a76d125f31cf37e3b22eda88391329c73d21ccc834e611893e759ea3e0 WHIRLPOOL 3b6c47ab250a892d31a7108d668ab14729ab8b37662f20c89450193613d3f5824df54720d3a23cd4b3c1afdf9b02ab462feb29528335d602b999daec161554d5
 DIST with-editor-2.5.9.tar.gz 28072 SHA256 f0772410e280cf7926d145bcc8c43643141afefa3aa97fa2cfc08c8cbdfdce7e SHA512 2a4c06aea89a52f706c80d3a6cb2ddc628daec13ef8a491ab6bc983d6eed66cde4ef7406d4374959a74c66940bffb28d476ad18e914f958ce0f3fcae828b1f90 WHIRLPOOL 2a596ecae7b1a259547fb8037b216bb9033f4b42defc00793b996b2951c3e74e3dc2b8e2198f71bb1ffd9082d802f6b691b8921c1c564e047319d0a099926f45
diff --git a/app-emacs/with-editor/with-editor-2.5.10.ebuild b/app-emacs/with-editor/with-editor-2.5.10.ebuild
new file mode 100644 (file)
index 0000000..deb0733
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Use the Emacsclient as the \$EDITOR of child processes"
+HOMEPAGE="https://magit.vc/manual/with-editor"
+SRC_URI="https://github.com/magit/with-editor/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+SITEFILE="50${PN}-gentoo.el"
+ELISP_TEXINFO="*.texi"
+DOCS="README.md with-editor.org"
+
+DEPEND=">=app-emacs/dash-2.13.0"
+# Versions of magit before 2.5.0 bundled with-editor
+RDEPEND="!!<app-emacs/magit-2.5.0 ${DEPEND}"