moved from USE flag tcltk to tcl, see bug 17808
authorChristian Faulhammer <fauli@gentoo.org>
Sat, 10 Feb 2007 23:30:01 +0000 (23:30 +0000)
committerChristian Faulhammer <fauli@gentoo.org>
Sat, 10 Feb 2007 23:30:01 +0000 (23:30 +0000)
Package-Manager: portage-2.1.2-r9

net-misc/suite3270/ChangeLog
net-misc/suite3270/suite3270-3.2.20.ebuild
net-misc/suite3270/suite3270-3.3.2_p1.ebuild
net-misc/suite3270/suite3270-3.3.4_p6.ebuild

index 35c33a834e26e7fbfc13f11fd1402ae857c62e57..f2f6d095235a34ea674e4a8a9f617d78f8e479ea 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for net-misc/suite3270
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/suite3270/ChangeLog,v 1.11 2006/05/26 22:54:58 robbat2 Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/suite3270/ChangeLog,v 1.12 2007/02/10 23:30:01 opfer Exp $
+
+  10 Feb 2007; Christian Faulhammer <opfer@gentoo.org>
+  suite3270-3.2.20.ebuild, suite3270-3.3.2_p1.ebuild,
+  suite3270-3.3.4_p6.ebuild:
+  moved from USE flag tcltk to tcl, see bug 17808
 
   26 May 2006; Robin H. Johnson <robbat2@gentoo.org>
   suite3270-3.2.20.ebuild:
index 71116e4c99699afaf571fe57421f65895dcfcc16..c99589aa6caf84abc3f3f43120ad9bd95a52723c 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/suite3270/suite3270-3.2.20.ebuild,v 1.8 2006/05/26 22:54:58 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/suite3270/suite3270-3.2.20.ebuild,v 1.9 2007/02/10 23:30:01 opfer Exp $
 
-IUSE="tcltk X"
+IUSE="tcl X"
 
 S="${WORKDIR}"
 DESCRIPTION="Complete 3270 access package"
@@ -14,7 +14,7 @@ LICENSE="GPL-2"
 KEYWORDS="x86 sparc"
 
 RDEPEND="X? ( || ( x11-libs/libXaw virtual/x11 ) )
-               tcltk? ( dev-lang/tcl !>=dev-lang/tcl-8.3 )
+               tcl? ( dev-lang/tcl !>=dev-lang/tcl-8.3 )
                sys-libs/ncurses
                sys-libs/readline"
 DEPEND="${RDEPEND}
@@ -55,7 +55,7 @@ suite3270_src_install() {
 suite3270_makelist() {
        MY_PLIST="c3270 pr3287 s3270"
        use X && MY_PLIST="${MY_PLIST} x3270"
-       use tcltk && MY_PLIST="${MY_PLIST} tcl3270"
+       use tcl && MY_PLIST="${MY_PLIST} tcl3270"
 }
 
 src_compile() {
@@ -63,7 +63,7 @@ src_compile() {
        local myconf_common
        myconf_common="--without-pr3287 --cache-file=${S}/config.cache"
        use X && myconf_common="${myconf_common} --with-x"
-       if use tcltk; then
+       if use tcl; then
                for j in `seq 9 1`; do
                has_version "=dev-lang/tcl-8.${j}*"
                if [ "$?" -eq "0" ]; then
@@ -74,7 +74,7 @@ src_compile() {
                done
        fi
        for i in ${MY_PLIST}; do
-               suite3270_src_compile ${i}  "${myconf_common}"
+               suite3270_src_compile ${i}      "${myconf_common}"
        done
 }
 
index c7171599edf17a3d94d1223abfcbde979e6c09fa..b94ffad323489054040140908aba753cafebe5d9 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/suite3270/suite3270-3.3.2_p1.ebuild,v 1.7 2006/01/27 00:45:19 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/suite3270/suite3270-3.3.2_p1.ebuild,v 1.8 2007/02/10 23:30:01 opfer Exp $
 
-IUSE="tcltk X cjk ssl debug"
+IUSE="tcl X cjk ssl debug"
 
 S="${WORKDIR}"
 DESCRIPTION="Complete 3270 access package"
@@ -16,7 +16,7 @@ LICENSE="GPL-2"
 KEYWORDS="~x86 ~sparc ~amd64 s390"
 
 RDEPEND="X? ( || ( x11-libs/libXaw virtual/x11 ) )
-               tcltk? ( dev-lang/tcl )
+               tcl? ( dev-lang/tcl )
                sys-libs/ncurses
                sys-libs/readline
                ssl? ( dev-libs/openssl )
@@ -65,7 +65,7 @@ suite3270_src_install() {
 
 suite3270_makelist() {
        MY_PLIST="c3270 pr3287 s3270"
-       use tcltk && MY_PLIST="${MY_PLIST} tcl3270"
+       use tcl && MY_PLIST="${MY_PLIST} tcl3270"
        use X && MY_PLIST="${MY_PLIST} x3270"
 }
 
@@ -82,7 +82,7 @@ src_compile() {
        else
                myconf_common="${myconf_common} --without-icu --disable-dbcs"
        fi
-       if use tcltk; then
+       if use tcl; then
                local tclinc
                for j in `seq 1 5`; do
                        if has_version "=dev-lang/tcl-8.${j}*"; then
@@ -91,14 +91,14 @@ src_compile() {
                        fi
                done
                if [ -z "${tclinc}" ]; then
-                       die "USE=tcltk, but cannot find dev-lang/tcl!"
+                       die "USE=tcl, but cannot find dev-lang/tcl!"
                fi
                myconf_common="${myconf_common} ${tclinc}"
        else
                myconf_common="${myconf_common} --without-tcl"
        fi
        for i in ${MY_PLIST}; do
-               suite3270_src_compile ${i}  "${myconf_common}"
+               suite3270_src_compile ${i}      "${myconf_common}"
        done
 }
 
index c3e7c07ebed635a94e03ac77b7dc52ccb7cbfbd4..4754c6511b0be35a3b7c82e3116d377fa0e738d1 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/suite3270/suite3270-3.3.4_p6.ebuild,v 1.1 2006/05/13 07:26:07 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/suite3270/suite3270-3.3.4_p6.ebuild,v 1.2 2007/02/10 23:30:01 opfer Exp $
 
-IUSE="tcltk X cjk ssl debug"
+IUSE="tcl X cjk ssl debug"
 
 S="${WORKDIR}"
 DESCRIPTION="Complete 3270 access package"
@@ -16,7 +16,7 @@ LICENSE="GPL-2"
 KEYWORDS="~x86 ~sparc ~amd64 ~ppc ~s390"
 
 RDEPEND="X? ( || ( x11-libs/libXaw virtual/x11 ) )
-               tcltk? ( dev-lang/tcl )
+               tcl? ( dev-lang/tcl )
                sys-libs/ncurses
                sys-libs/readline
                ssl? ( dev-libs/openssl )
@@ -65,7 +65,7 @@ suite3270_src_install() {
 
 suite3270_makelist() {
        MY_PLIST="c3270 pr3287 s3270"
-       use tcltk && MY_PLIST="${MY_PLIST} tcl3270"
+       use tcl && MY_PLIST="${MY_PLIST} tcl3270"
        use X && MY_PLIST="${MY_PLIST} x3270"
 }
 
@@ -82,7 +82,7 @@ src_compile() {
        else
                myconf_common="${myconf_common} --without-icu --disable-dbcs"
        fi
-       if use tcltk; then
+       if use tcl; then
                local tclinc
                for j in `seq 1 5`; do
                        if has_version "=dev-lang/tcl-8.${j}*"; then
@@ -91,14 +91,14 @@ src_compile() {
                        fi
                done
                if [ -z "${tclinc}" ]; then
-                       die "USE=tcltk, but cannot find dev-lang/tcl!"
+                       die "USE=tcl, but cannot find dev-lang/tcl!"
                fi
                myconf_common="${myconf_common} ${tclinc}"
        else
                myconf_common="${myconf_common} --without-tcl"
        fi
        for i in ${MY_PLIST}; do
-               suite3270_src_compile ${i}  "${myconf_common}"
+               suite3270_src_compile ${i}      "${myconf_common}"
        done
 }