app-office/calligra-l10n: Migrate to L10N
authorMichał Górny <mgorny@gentoo.org>
Sat, 2 Jul 2016 12:55:56 +0000 (14:55 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 3 Jul 2016 16:08:35 +0000 (18:08 +0200)
app-office/calligra-l10n/calligra-l10n-2.9.11.ebuild

index 7c3cb845aa86a7bd46da12f125095d6d3a45cf54..582a141997ee6fe328d1701e0a65cf4503f9524a 100644 (file)
@@ -34,8 +34,8 @@ SRC_URI=""
 SLOT="4"
 
 for MY_LANG in ${MY_LANGS} ; do
-       IUSE="${IUSE} linguas_${MY_LANG}"
-       SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE}/${PN}-${MY_LANG}-${PV}.tar.xz )"
+       IUSE="${IUSE} l10n_${MY_LANG/[@_]/-}"
+       SRC_URI="${SRC_URI} l10n_${MY_LANG/[@_]/-}? ( ${URI_BASE}/${PN}-${MY_LANG}-${PV}.tar.xz )"
 done
 unset MY_LANG
 
@@ -45,19 +45,17 @@ src_unpack() {
        local lng dir
        if [[ -z ${A} ]]; then
                elog
-               elog "You either have the LINGUAS variable unset, or it only"
-               elog "contains languages not supported by ${P}."
-               elog "You won't have any additional language support."
+               elog "None of the requested L10N are supported by ${P}."
                elog
                elog "${P} supports these language codes:"
-               elog "${MY_LANGS}"
+               elog "${MY_LANGS//[@_]/-}"
                elog
        fi
 
        [[ -n ${A} ]] && unpack ${A}
        cd "${S}"
 
-       # add all linguas to cmake
+       # add all L10N to cmake
        if [[ -n ${A} ]]; then
                for lng in ${MY_LANGS}; do
                        dir="${PN}-${lng}-${PV}"