sci-visualization/kst: Fix build with sci-libs/gsl-2
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 26 Aug 2018 18:07:50 +0000 (20:07 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 26 Aug 2018 18:23:49 +0000 (20:23 +0200)
Closes: https://bugs.gentoo.org/574746
Package-Manager: Portage-2.3.48, Repoman-2.3.10

sci-visualization/kst/files/kst-2.0.8-gsl-2.0.patch [new file with mode: 0644]
sci-visualization/kst/kst-2.0.8.ebuild

diff --git a/sci-visualization/kst/files/kst-2.0.8-gsl-2.0.patch b/sci-visualization/kst/files/kst-2.0.8-gsl-2.0.patch
new file mode 100644 (file)
index 0000000..c49ba2e
--- /dev/null
@@ -0,0 +1,30 @@
+Patch kindly borrowed from Debian.
+Gentoo-bug: https://bugs.gentoo.org/574746
+KDE-bug: https://bugs.kde.org/show_bug.cgi?id=355324
+
+--- a/src/plugins/fits/non_linear.h
++++ b/src/plugins/fits/non_linear.h
+@@ -177,7 +177,9 @@ bool kstfit_nonlinear(
+             }
+             iIterations++;
+           } while( iStatus == GSL_CONTINUE && iIterations < MAX_NUM_ITERATIONS );
+-          gsl_multifit_covar( pSolver->J, 0.0, pMatrixCovariance );
++          gsl_matrix *J = gsl_matrix_alloc (pSolver->fdf->n, pSolver->fdf->p);
++          gsl_multifit_fdfsolver_jac (pSolver, J);
++          gsl_multifit_covar (J, 0.0, pMatrixCovariance);
+           //
+           // determine the fitted values...
+--- a/src/plugins/fits/non_linear_weighted.h
++++ b/src/plugins/fits/non_linear_weighted.h
+@@ -193,7 +193,9 @@ bool kstfit_nonlinear_weighted(
+           }
+           while( iStatus == GSL_CONTINUE && iIterations < MAX_NUM_ITERATIONS );
+-          gsl_multifit_covar( pSolver->J, 0.0, pMatrixCovariance );
++          gsl_matrix *J = gsl_matrix_alloc (pSolver->fdf->n, pSolver->fdf->p);
++          gsl_multifit_fdfsolver_jac (pSolver, J);
++          gsl_multifit_covar (J, 0.0, pMatrixCovariance);
+           //
+           // determine the fitted values...
index d8c58992ca3b87e918080bde25de9dd3d2a009d3..6b0ac253117bff94ca0cdf89747d69cbf53b6321 100644 (file)
@@ -44,6 +44,7 @@ DOCS=( AUTHORS README.kstScript )
 PATCHES=(
        "${FILESDIR}/${P}-includes.patch"
        "${FILESDIR}/${P}-qt-5.11.patch"
+       "${FILESDIR}/${P}-gsl-2.0.patch"
 )
 
 src_configure() {