games-board/eboard: remove deprecated games eclass
authorAustin English <wizardedit@gentoo.org>
Wed, 7 Sep 2016 22:45:39 +0000 (17:45 -0500)
committerAustin English <wizardedit@gentoo.org>
Wed, 7 Sep 2016 23:28:55 +0000 (18:28 -0500)
Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: portage-2.3.0

games-board/eboard/eboard-1.1.1-r2.ebuild [new file with mode: 0644]
games-board/eboard/files/eboard-1.1.1-as-needed.patch
games-board/eboard/files/eboard-1.1.1-gcc44.patch
games-board/eboard/files/eboard-1.1.1-libpng15.patch
games-board/eboard/files/eboard-1.1.1-ovflfix.patch

diff --git a/games-board/eboard/eboard-1.1.1-r2.ebuild b/games-board/eboard/eboard-1.1.1-r2.ebuild
new file mode 100644 (file)
index 0000000..2b32096
--- /dev/null
@@ -0,0 +1,75 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DEB_V=${PV}-4.1
+EXTRAS1="eboard-extras-1pl2"
+EXTRAS2="eboard-extras-2"
+DESCRIPTION="chess interface for POSIX systems"
+HOMEPAGE="http://www.bergo.eng.br/eboard/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
+       mirror://sourceforge/${PN}/${EXTRAS1}.tar.gz
+       mirror://sourceforge/${PN}/${EXTRAS2}.tar.gz
+       mirror://debian/pool/main/e/eboard/${PN}_${DEB_V}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+RDEPEND="
+       media-libs/libpng:0=
+       x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+       dev-lang/perl
+       virtual/pkgconfig"
+
+PATCHES=(
+       "${WORKDIR}"/${PN}_${DEB_V}.diff
+       "${FILESDIR}"/${P}-as-needed.patch
+       "${FILESDIR}"/${P}-gcc44.patch
+       "${FILESDIR}"/${P}-ovflfix.patch
+       "${FILESDIR}"/${P}-libpng15.patch
+)
+
+src_prepare() {
+       default
+
+       sed -i \
+               -e "s:(\"-O6\"):split(' ', \"${CXXFLAGS}\"):" \
+               configure || die
+}
+
+src_configure() {
+       ./configure \
+               --compiler="$(tc-getCXX)" \
+               --prefix="/usr" \
+               --data-prefix="/usr/share" \
+               --man-prefix="/usr/share/man" \
+               --extra-libs="dl" \
+               $(use_enable nls) || die # not an autoconf script
+}
+
+src_install() {
+       default
+       dodoc Documentation/*.txt
+
+       newicon icon-eboard.xpm ${PN}.xpm
+       make_desktop_entry ${PN} ${PN} ${PN}
+
+       cd "${WORKDIR}"/${EXTRAS1}
+       insinto /usr/share/${PN}
+       doins *.png *.wav
+       newins extras1.conf themeconf.extras1
+       newdoc ChangeLog Changelog.extras
+       newdoc README README.extras
+       dodoc CREDITS
+
+       cd "${WORKDIR}"/${EXTRAS2}
+       doins *.png *.wav
+       newins extras2.conf themeconf.extras2
+}
index b4ec397ba9674e654fd2d716d10eb3c726b874ad..199dd0e70a2de006225bd1711db8a557082b76e4 100644 (file)
@@ -1,5 +1,5 @@
---- configure.old      2009-02-03 14:46:21.000000000 +0100
-+++ configure  2009-02-03 14:48:13.000000000 +0100
+--- a/configure        2009-02-03 14:46:21.000000000 +0100
++++ b/configure        2009-02-03 14:48:13.000000000 +0100
 @@ -638,7 +638,7 @@
  
  print CONFIGMAKE "CXX       = $cxx\n";
@@ -9,8 +9,8 @@
  
  print CONFIGMAKE "prefix    = \${DESTDIR}$prefix\n";
  print CONFIGMAKE "bindir    = \${DESTDIR}$prefix/bin\n";
---- elifekam.old       2009-02-03 14:48:43.000000000 +0100
-+++ elifekam   2009-02-03 14:48:58.000000000 +0100
+--- a/elifekam 2009-02-03 14:48:43.000000000 +0100
++++ b/elifekam 2009-02-03 14:48:58.000000000 +0100
 @@ -24,7 +24,7 @@
  all: eboard nls-dicts
  
index 43a26393d4f42276685a99d1302f244a53093e0e..60e7d81fcdb2c1708a68e30d5f6015859a23ffb4 100644 (file)
@@ -1,5 +1,5 @@
---- ntext.cc
-+++ ntext.cc
+--- a/ntext.cc
++++ b/ntext.cc
 @@ -244,7 +244,7 @@
      return;
    }
index 8ab283259f79988ad9cd3d6d8e058d6e0fb27ed3..cd0ccf8b4f20b096a15f3f09e6ac024a65c55e93 100644 (file)
@@ -1,5 +1,5 @@
---- cimg.cc
-+++ cimg.cc
+--- a/cimg.cc
++++ b/cimg.cc
 @@ -94,11 +95,11 @@
        ct == PNG_COLOR_TYPE_GRAY_ALPHA)
      png_set_gray_to_rgb(pngp);
index 4a586b2b70a3456040adfa728f43790ab8c4be2a..b09c4dba880f893d8da5f524fe3a39d51b0af61a 100644 (file)
@@ -1,5 +1,5 @@
---- proto_xboard.cc.old        2010-11-03 16:42:15.000000000 +0100
-+++ proto_xboard.cc    2010-11-03 16:43:14.000000000 +0100
+--- a/proto_xboard.cc  2010-11-03 16:42:15.000000000 +0100
++++ b/proto_xboard.cc  2010-11-03 16:43:14.000000000 +0100
 @@ -1084,7 +1084,7 @@
    snprintf(EngineCommandLine,512,"crafty bookpath=%s logpath=%s tbpath=%s",
           BookPath,LogPath,LogPath);
@@ -9,8 +9,8 @@
    else
      strcpy(EngineRunDir,"/tmp");
  
---- util.cc.old        2010-11-03 16:42:24.000000000 +0100
-+++ util.cc    2010-11-03 16:43:42.000000000 +0100
+--- a/util.cc  2010-11-03 16:42:24.000000000 +0100
++++ b/util.cc  2010-11-03 16:43:42.000000000 +0100
 @@ -783,7 +783,7 @@
    int i,n;
    char cmd[1024];