net-nds/led: Bump to EAPI 7
authorMichał Górny <mgorny@gentoo.org>
Sat, 9 Nov 2019 13:41:07 +0000 (14:41 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 9 Nov 2019 13:56:38 +0000 (14:56 +0100)
Closes: https://bugs.gentoo.org/697234
Signed-off-by: Michał Górny <mgorny@gentoo.org>
net-nds/led/led-1.111.ebuild

index dbd214b97ef85f6262f40d8eadebce5164e3180c..441a72ed409ce28f70908c5c0f8bdff9f5e02d19 100644 (file)
@@ -1,26 +1,30 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
-inherit eutils
-DESCRIPTION="led is a general purpose LDAP editor"
+DESCRIPTION="A general purpose LDAP editor"
 HOMEPAGE="http://led.sourceforge.net/"
 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="~amd64 ~ppc ~x86"
 IUSE=""
 
-DEPEND=">=dev-lang/perl-5.6.1
+RDEPEND=">=dev-lang/perl-5.6.1
        dev-perl/perl-ldap
        dev-perl/URI
        virtual/perl-Digest-MD5
        dev-perl/Authen-SASL"
+DEPEND=${RDEPEND}
 
-src_compile() {
+src_configure() {
        # non-standard configure system!
-       perl Configure --prefix=/usr --generic --rfc2307 --shadow --iplanet
+       perl Configure --prefix=/usr --generic --rfc2307 --shadow --iplanet || die
+}
+
+src_compile() {
        # parallel make bad
        emake -j1
 }