dev-python/nnpy: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 09:10:58 +0000 (10:10 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 09:10:58 +0000 (10:10 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/nnpy/Manifest
dev-python/nnpy/files/py3.patch [deleted file]
dev-python/nnpy/nnpy-1.4.1.ebuild [deleted file]

index 26c6d13e2103d16cd897e4451569640c27c107e7..8d130691ad3316fedb599d5fecb47e739a87512b 100644 (file)
@@ -1,2 +1 @@
-DIST nnpy-1.4.1.tar.gz 4826 BLAKE2B 28e976fdde6580e5f0e828f4e68858ca74459899092b448f0f54f89d88cb1dc7e9df9583de76d2e9ee824909c834404cfca92d0a477bfa58573c57e9ddac0cda SHA512 26e1393fdca77cc9385eff0622f9a5b4987eeca533c57478ba873a1ea96f312a2d535fd3eaa883c47746157a9d692b4b0f6c52d51ea5b4fea5fb885cfdadc2a2
 DIST nnpy-1.4.2.tar.gz 4830 BLAKE2B 7e1e3d3ade400e96e43504e490f22e5595850d54e80d4591fa0a519a47a492aaf569d9937c4ee05fc9504c4beb5cb2ef8496a65874e64b6162087eade6762906 SHA512 b0908e3b53ac62d8a41ecadd412b2c4bff69773d5eeecc2eb72cad2667c3a14405dc1dfa6f2cdf4f81cf76b9eadbcdca5bdfa1499a2f0c3beddbacbd3e21b7d7
diff --git a/dev-python/nnpy/files/py3.patch b/dev-python/nnpy/files/py3.patch
deleted file mode 100644 (file)
index 8a39044..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-commit 98ee46a4034ca94d6123b854e79f1dc3f35fff4a
-Author: Alexis Ballier <aballier@gentoo.org>
-Date:   Sat Jun 3 19:55:10 2017 +0200
-
-    Fix tests under python3.
-
-diff --git a/nnpy/tests.py b/nnpy/tests.py
-index ba2a3fe..7f9f6e0 100644
---- a/nnpy/tests.py
-+++ b/nnpy/tests.py
-@@ -17,7 +17,7 @@ class Tests(unittest.TestCase):
-         poller = nnpy.PollSet((sub, nnpy.POLLIN))
-         self.assertEqual(len(poller.poll()), 1)
-         self.assertEqual(poller.poll()[0], 1)
--        self.assertEqual(sub.recv(), 'FLUB')
-+        self.assertEqual(sub.recv().decode(), 'FLUB')
-         self.assertEqual(pub.get_statistic(nnpy.STAT_MESSAGES_SENT), 1)
-         pub.close()
-         sub.shutdown(sub_conn)
diff --git a/dev-python/nnpy/nnpy-1.4.1.ebuild b/dev-python/nnpy/nnpy-1.4.1.ebuild
deleted file mode 100644 (file)
index b359e5c..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="cffi-based Python bindings for nanomsg"
-HOMEPAGE="https://github.com/nanomsg/nnpy"
-SRC_URI="https://github.com/nanomsg/nnpy/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm"
-IUSE=""
-
-DEPEND="
-       dev-python/cffi:=[${PYTHON_USEDEP}]
-       dev-libs/nanomsg:=
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}/py3.patch" )
-
-python_test() {
-       PYTHONPATH="${S}:${PYTHONPATH}" "${PYTHON}" "${S}/nnpy/tests.py" || die
-}