kde-apps/dolphin: Version bump 15.08.0
authorMichael Palimaka <kensington@gentoo.org>
Thu, 27 Aug 2015 11:09:28 +0000 (21:09 +1000)
committerMichael Palimaka <kensington@gentoo.org>
Thu, 27 Aug 2015 11:09:28 +0000 (21:09 +1000)
Package-Manager: portage-2.2.20.1

kde-apps/dolphin/Manifest
kde-apps/dolphin/dolphin-15.08.0.ebuild [new file with mode: 0644]
kde-apps/dolphin/files/dolphin-15.08.0-deps.patch [new file with mode: 0644]

index f17829a584ad679cdd75b14193018fbedf55d35e..08f6847e5e1ce103153a6fe3dd1f652367ef008f 100644 (file)
@@ -1 +1,2 @@
+DIST dolphin-15.08.0.tar.xz 656524 SHA256 7ac16d7150b7c5e1d6350cf679981d675c995303a7f68eab1290763d3fd35ad9 SHA512 485f5a888ef5f68014c9c33b8a0f63a0d9b20a65098b026714b1b7cf831751bf382430296ef43861d4259bb73f84251353855c60ca096acdb384d1947e8fed57 WHIRLPOOL 3a207189700c11287b2286b5dc017beea4040279849079b5d86a9ce7464023d19d6ba55818ce0a11f609242f01f19a2936ec626a211352944f848dd8646a224c
 DIST kde-baseapps-4.14.3.tar.xz 2548152 SHA256 125baf42a7ab8c255b5829d12837f54c1791498f79593a9b09a9e55344ade6db SHA512 d422c1ee5cd2e1dc15b5baa2199bb85441196bc3048b9bfa443f898c3a1cfbc7f66087edf016fb594b9e48340517beef54b4429b4fde664374e75486c7cb0f9e WHIRLPOOL b22a98d140bb66ea47aeb5607e606c7a531c82787e27204f5eabb7d29d763b2bfe1456d85242d3e05e7ab4d2366fc622ef1cc624dd1954e276fb36c49840998a
diff --git a/kde-apps/dolphin/dolphin-15.08.0.ebuild b/kde-apps/dolphin/dolphin-15.08.0.ebuild
new file mode 100644 (file)
index 0000000..2c5f46b
--- /dev/null
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="true"
+KDE_PUNT_BOGUS_DEPS="true"
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Plasma filemanager focusing on usability"
+HOMEPAGE="https://dolphin.kde.org https://www.kde.org/applications/system/dolphin"
+KEYWORDS="~amd64 ~x86"
+IUSE="semantic-desktop thumbnail"
+
+DEPEND="
+       $(add_frameworks_dep kbookmarks)
+       $(add_frameworks_dep kcmutils)
+       $(add_frameworks_dep kcodecs)
+       $(add_frameworks_dep kcompletion)
+       $(add_frameworks_dep kconfig)
+       $(add_frameworks_dep kconfigwidgets)
+       $(add_frameworks_dep kcoreaddons)
+       $(add_frameworks_dep kdbusaddons)
+       $(add_frameworks_dep ki18n)
+       $(add_frameworks_dep kiconthemes)
+       $(add_frameworks_dep kinit)
+       $(add_frameworks_dep kio)
+       $(add_frameworks_dep kitemviews)
+       $(add_frameworks_dep kjobwidgets)
+       $(add_frameworks_dep knewstuff)
+       $(add_frameworks_dep knotifications)
+       $(add_frameworks_dep kparts)
+       $(add_frameworks_dep kservice)
+       $(add_frameworks_dep ktextwidgets)
+       $(add_frameworks_dep kwidgetsaddons)
+       $(add_frameworks_dep kwindowsystem)
+       $(add_frameworks_dep kxmlgui)
+       $(add_frameworks_dep solid)
+       dev-qt/qtconcurrent:5
+       dev-qt/qtdbus:5
+       dev-qt/qtgui:5
+       dev-qt/qtwidgets:5
+       dev-qt/qtxml:5
+       media-libs/phonon[qt5]
+       semantic-desktop? (
+               $(add_frameworks_dep baloo)
+               $(add_frameworks_dep kfilemetadata)
+               $(add_kdeapps_dep baloo-widgets)
+       )
+       !semantic-desktop? (
+               $(add_frameworks_dep kdelibs4support)
+       )
+"
+RDEPEND="${DEPEND}
+       $(add_kdeapps_dep kio-extras)
+       thumbnail? (
+               $(add_kdeapps_dep ffmpegthumbs '' 5.9999)
+               $(add_kdeapps_dep thumbnailers '' 5.9999)
+       )
+"
+
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/${PN}-15.08.0-deps.patch" )
+
+src_configure() {
+       local mycmakeargs=(
+               $(cmake-utils_use_with semantic-desktop KF5Baloo)
+               $(cmake-utils_use_with semantic-desktop KF5BalooWidgets)
+               $(cmake-utils_use_with semantic-desktop KF5FileMetaData)
+       )
+
+       kde5_src_configure
+}
+
+pkg_postinst() {
+       kde5_pkg_postinst
+
+       if ( ! has_version kde-apps/ark:${SLOT} || ! has_version kde-apps/libkonq:${SLOT} ); then
+               echo
+               elog "For compress/extract actions, please install kde-apps/ark:${SLOT} and kde-apps/libkonq:${SLOT}"
+               echo
+       fi
+}
diff --git a/kde-apps/dolphin/files/dolphin-15.08.0-deps.patch b/kde-apps/dolphin/files/dolphin-15.08.0-deps.patch
new file mode 100644 (file)
index 0000000..43ae391
--- /dev/null
@@ -0,0 +1,48 @@
+From 4c0d110b2d36153a564602223b4dd3e04b1f4158 Mon Sep 17 00:00:00 2001
+From: Michael Palimaka <kensington@gentoo.org>
+Date: Wed, 26 Aug 2015 22:53:44 +1000
+Subject: [PATCH] Update dependencies.
+
+It appears that KF5TextEditor was added for KTextEdit, but that is actually
+provided by KF5TextWidgets. It's then necessary to explicitly link to KF5Parts
+(it was previously brought in implicitly by KF5TextEditor).
+
+REVIEW: 124932
+---
+ CMakeLists.txt     | 2 +-
+ src/CMakeLists.txt | 3 ++-
+ 2 files changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index b56fd7a..a5580e9 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -62,7 +62,7 @@ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
+     Solid
+     IconThemes
+     Completion
+-    TextEditor
++    TextWidgets
+     WindowSystem
+     Notifications
+ )
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 2a5e5a6..9689923 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -143,10 +143,11 @@ target_link_libraries(
+     KF5::KIOWidgets
+     KF5::KIOFileWidgets
+     KF5::Completion
+-    KF5::TextEditor
++    KF5::TextWidgets
+     KF5::WindowSystem
+     KF5::ConfigCore
+     KF5::NewStuff
++    KF5::Parts
+ )
+ if(HAVE_BALOO)
+-- 
+2.4.6
+