sys-libs/glibc: drop prepallstrip, bug #587296
authorSergei Trofimovich <slyfox@gentoo.org>
Wed, 25 Sep 2019 07:27:26 +0000 (08:27 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Wed, 25 Sep 2019 08:04:44 +0000 (09:04 +0100)
Stop using internal portage's 'prepallstrip' helper.
This effectively reverts https://bugs.gentoo.org/46186.
Modern gdb can inspect threads without debugging symbols
in libpthread/libthread_db.

Reported-by: Michał Górny
Closes: https://bugs.gentoo.org/587296
Bug: https://bugs.gentoo.org/46186
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
12 files changed:
sys-libs/glibc/glibc-2.19-r2.ebuild
sys-libs/glibc/glibc-2.24-r4.ebuild
sys-libs/glibc/glibc-2.25-r11.ebuild
sys-libs/glibc/glibc-2.26-r7.ebuild
sys-libs/glibc/glibc-2.27-r6.ebuild
sys-libs/glibc/glibc-2.28-r6.ebuild
sys-libs/glibc/glibc-2.29-r2.ebuild
sys-libs/glibc/glibc-2.29-r4.ebuild
sys-libs/glibc/glibc-2.29-r5.ebuild
sys-libs/glibc/glibc-2.30-r1.ebuild
sys-libs/glibc/glibc-2.30.ebuild
sys-libs/glibc/glibc-9999.ebuild

index 42ed9d4e04de876eb7b029c0068c97367718158b..75f849f69dc267ed07ad462c6a77029251e3ed62 100644 (file)
@@ -9,7 +9,6 @@ inherit prefix eutils toolchain-funcs flag-o-matic gnuconfig usr-ldscript \
 DESCRIPTION="GNU libc C library"
 HOMEPAGE="https://www.gnu.org/software/libc/"
 LICENSE="LGPL-2.1+ BSD HPND ISC inner-net rc PCRE"
-RESTRICT="strip" # Strip ourself #46186
 SLOT="2.2"
 
 EMULTILIB_PKG="true"
@@ -1197,23 +1196,6 @@ glibc_headers_install() {
        dosym usr/include $(alt_prefix)/sys-include
 }
 
-src_strip() {
-       # gdb is lame and requires some debugging information to remain in
-       # libpthread, so we need to strip it by hand.  libthread_db makes no
-       # sense stripped as it is only used when debugging.
-       local pthread=$(has splitdebug ${FEATURES} && echo "libthread_db" || echo "lib{pthread,thread_db}")
-       env \
-               -uRESTRICT \
-               CHOST=${CTARGET} \
-               STRIP_MASK="/*/{,tls/}${pthread}*" \
-               prepallstrip
-       # if user has stripping enabled and does not have split debug turned on,
-       # then leave the debugging sections in libpthread.
-       if ! has nostrip ${FEATURES} && ! has splitdebug ${FEATURES} ; then
-               ${STRIP:-${CTARGET}-strip} --strip-debug "${ED}"/*/libpthread-*.so
-       fi
-}
-
 src_install() {
        if just_headers ; then
                export ABI=default
@@ -1222,7 +1204,6 @@ src_install() {
        fi
 
        foreach_abi glibc_do_src_install
-       src_strip
 }
 
 # Simple test to make sure our new glibc isn't completely broken.
index 40f30a0b8ebef8bef0bd0f39b36a3c88684b2723..b808611bd319f1c3faeca0a47a8a1d9da3e3c614 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="5"
@@ -10,7 +10,6 @@ HOMEPAGE="https://www.gnu.org/software/libc/libc.html"
 
 LICENSE="LGPL-2.1+ BSD HPND ISC inner-net rc PCRE"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-RESTRICT="strip" # strip ourself #46186
 EMULTILIB_PKG="true"
 
 # Configuration variables
index 67c8f98ebb74660b47235d51a3a111e578b115ab..e2a0f9131bbc9d4b7fa268c2e832584b48fd8dab 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="5"
@@ -10,7 +10,6 @@ HOMEPAGE="https://www.gnu.org/software/libc/libc.html"
 
 LICENSE="LGPL-2.1+ BSD HPND ISC inner-net rc PCRE"
 KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
-RESTRICT="strip" # strip ourself #46186
 EMULTILIB_PKG="true"
 
 # Configuration variables
index 7caf7ba188cb3ad1f7426b852a4899fce874aac4..bfbe9b01b0334b7d72e63a8e41ec8ed1ec2e2b60 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -9,7 +9,6 @@ DESCRIPTION="GNU libc C library"
 HOMEPAGE="https://www.gnu.org/software/libc/"
 
 LICENSE="LGPL-2.1+ BSD HPND ISC inner-net rc PCRE"
-RESTRICT="strip" # Strip ourself #46186
 EMULTILIB_PKG="true"
 
 # Configuration variables
@@ -784,7 +783,6 @@ src_install() {
        fi
 
        foreach_abi glibc_do_src_install
-       src_strip
 }
 
 pkg_preinst() {
index fc6931ffb7cbfb4551d9ff7dfdfe30c495f209df..42be8144de45f1025ac27f40d46226d24dc444e2 100644 (file)
@@ -9,7 +9,6 @@ inherit prefix eutils versionator toolchain-funcs flag-o-matic gnuconfig usr-lds
 DESCRIPTION="GNU libc C library"
 HOMEPAGE="https://www.gnu.org/software/libc/"
 LICENSE="LGPL-2.1+ BSD HPND ISC inner-net rc PCRE"
-RESTRICT="strip" # Strip ourself #46186
 SLOT="2.2"
 
 EMULTILIB_PKG="true"
@@ -1303,23 +1302,6 @@ glibc_headers_install() {
        dosym usr/include $(alt_prefix)/sys-include
 }
 
-src_strip() {
-       # gdb is lame and requires some debugging information to remain in
-       # libpthread, so we need to strip it by hand.  libthread_db makes no
-       # sense stripped as it is only used when debugging.
-       local pthread=$(has splitdebug ${FEATURES} && echo "libthread_db" || echo "lib{pthread,thread_db}")
-       env \
-               -uRESTRICT \
-               CHOST=${CTARGET} \
-               STRIP_MASK="/*/{,tls/}${pthread}*" \
-               prepallstrip
-       # if user has stripping enabled and does not have split debug turned on,
-       # then leave the debugging sections in libpthread.
-       if ! has nostrip ${FEATURES} && ! has splitdebug ${FEATURES} ; then
-               ${STRIP:-${CTARGET}-strip} --strip-debug "${ED}"$(alt_prefix)/*/libpthread-*.so
-       fi
-}
-
 src_install() {
        if just_headers ; then
                export ABI=default
@@ -1328,7 +1310,6 @@ src_install() {
        fi
 
        foreach_abi glibc_do_src_install
-       src_strip
 }
 
 # Simple test to make sure our new glibc isn't completely broken.
index 761c007900b2a44d5d1a03261c5fd4406bae8338..d40991f16ab9a675e5fc264755626b956234067a 100644 (file)
@@ -9,7 +9,6 @@ inherit prefix eutils eapi7-ver toolchain-funcs flag-o-matic gnuconfig usr-ldscr
 DESCRIPTION="GNU libc C library"
 HOMEPAGE="https://www.gnu.org/software/libc/"
 LICENSE="LGPL-2.1+ BSD HPND ISC inner-net rc PCRE"
-RESTRICT="strip" # Strip ourself #46186
 SLOT="2.2"
 
 EMULTILIB_PKG="true"
@@ -1301,23 +1300,6 @@ glibc_headers_install() {
        dosym usr/include $(alt_prefix)/sys-include
 }
 
-src_strip() {
-       # gdb is lame and requires some debugging information to remain in
-       # libpthread, so we need to strip it by hand.  libthread_db makes no
-       # sense stripped as it is only used when debugging.
-       local pthread=$(has splitdebug ${FEATURES} && echo "libthread_db" || echo "lib{pthread,thread_db}")
-       env \
-               -uRESTRICT \
-               CHOST=${CTARGET} \
-               STRIP_MASK="/*/{,tls/}${pthread}*" \
-               prepallstrip
-       # if user has stripping enabled and does not have split debug turned on,
-       # then leave the debugging sections in libpthread.
-       if ! has nostrip ${FEATURES} && ! has splitdebug ${FEATURES} ; then
-               ${STRIP:-${CTARGET}-strip} --strip-debug "${ED}"$(alt_prefix)/*/libpthread-*.so
-       fi
-}
-
 src_install() {
        if just_headers ; then
                export ABI=default
@@ -1326,7 +1308,6 @@ src_install() {
        fi
 
        foreach_abi glibc_do_src_install
-       src_strip
 }
 
 # Simple test to make sure our new glibc isn't completely broken.
index 5352ae1f92b39fc339146959d80df5908ccbef06..b80ddd00814478355b9407f444f28d7f4bf181bc 100644 (file)
@@ -11,7 +11,6 @@ inherit python-any-r1 prefix eutils eapi7-ver toolchain-funcs flag-o-matic gnuco
 DESCRIPTION="GNU libc C library"
 HOMEPAGE="https://www.gnu.org/software/libc/"
 LICENSE="LGPL-2.1+ BSD HPND ISC inner-net rc PCRE"
-RESTRICT="strip" # Strip ourself #46186
 SLOT="2.2"
 
 EMULTILIB_PKG="true"
@@ -1343,23 +1342,6 @@ glibc_headers_install() {
        dosym usr/include $(alt_prefix)/sys-include
 }
 
-src_strip() {
-       # gdb is lame and requires some debugging information to remain in
-       # libpthread, so we need to strip it by hand.  libthread_db makes no
-       # sense stripped as it is only used when debugging.
-       local pthread=$(has splitdebug ${FEATURES} && echo "libthread_db" || echo "lib{pthread,thread_db}")
-       env \
-               -uRESTRICT \
-               CHOST=${CTARGET} \
-               STRIP_MASK="/*/{,tls/}${pthread}*" \
-               prepallstrip
-       # if user has stripping enabled and does not have split debug turned on,
-       # then leave the debugging sections in libpthread.
-       if ! has nostrip ${FEATURES} && ! has splitdebug ${FEATURES} ; then
-               ${STRIP:-${CTARGET}-strip} --strip-debug "${ED}"$(alt_prefix)/*/libpthread-*.so
-       fi
-}
-
 src_install() {
        if just_headers ; then
                export ABI=default
@@ -1368,7 +1350,6 @@ src_install() {
        fi
 
        foreach_abi glibc_do_src_install
-       src_strip
 }
 
 # Simple test to make sure our new glibc isn't completely broken.
index c49d826372670bdc41e8402f64388d05d39da484..7282d89d8eee7bf7b7975723c5fa9b32b5f615af 100644 (file)
@@ -11,7 +11,6 @@ inherit python-any-r1 prefix eutils eapi7-ver toolchain-funcs flag-o-matic gnuco
 DESCRIPTION="GNU libc C library"
 HOMEPAGE="https://www.gnu.org/software/libc/"
 LICENSE="LGPL-2.1+ BSD HPND ISC inner-net rc PCRE"
-RESTRICT="strip" # Strip ourself #46186
 SLOT="2.2"
 
 EMULTILIB_PKG="true"
@@ -1356,23 +1355,6 @@ glibc_headers_install() {
        dosym usr/include $(alt_prefix)/sys-include
 }
 
-src_strip() {
-       # gdb is lame and requires some debugging information to remain in
-       # libpthread, so we need to strip it by hand.  libthread_db makes no
-       # sense stripped as it is only used when debugging.
-       local pthread=$(has splitdebug ${FEATURES} && echo "libthread_db" || echo "lib{pthread,thread_db}")
-       env \
-               -uRESTRICT \
-               CHOST=${CTARGET} \
-               STRIP_MASK="/*/{,tls/}${pthread}*" \
-               prepallstrip
-       # if user has stripping enabled and does not have split debug turned on,
-       # then leave the debugging sections in libpthread.
-       if ! has nostrip ${FEATURES} && ! has splitdebug ${FEATURES} ; then
-               ${STRIP:-${CTARGET}-strip} --strip-debug "${ED}"$(alt_prefix)/*/libpthread-*.so
-       fi
-}
-
 src_install() {
        if just_headers ; then
                export ABI=default
@@ -1381,7 +1363,6 @@ src_install() {
        fi
 
        foreach_abi glibc_do_src_install
-       src_strip
 }
 
 # Simple test to make sure our new glibc isn't completely broken.
index d02d0fcb97d643a03a0bdc04815c2adb3de38a36..1c3f4a15dde737d79698ce65586824bfaef48277 100644 (file)
@@ -11,7 +11,6 @@ inherit python-any-r1 prefix eutils eapi7-ver toolchain-funcs flag-o-matic gnuco
 DESCRIPTION="GNU libc C library"
 HOMEPAGE="https://www.gnu.org/software/libc/"
 LICENSE="LGPL-2.1+ BSD HPND ISC inner-net rc PCRE"
-RESTRICT="strip" # Strip ourself #46186
 SLOT="2.2"
 
 EMULTILIB_PKG="true"
@@ -1356,23 +1355,6 @@ glibc_headers_install() {
        dosym usr/include $(alt_prefix)/sys-include
 }
 
-src_strip() {
-       # gdb is lame and requires some debugging information to remain in
-       # libpthread, so we need to strip it by hand.  libthread_db makes no
-       # sense stripped as it is only used when debugging.
-       local pthread=$(has splitdebug ${FEATURES} && echo "libthread_db" || echo "lib{pthread,thread_db}")
-       env \
-               -uRESTRICT \
-               CHOST=${CTARGET} \
-               STRIP_MASK="/*/{,tls/}${pthread}*" \
-               prepallstrip
-       # if user has stripping enabled and does not have split debug turned on,
-       # then leave the debugging sections in libpthread.
-       if ! has nostrip ${FEATURES} && ! has splitdebug ${FEATURES} ; then
-               ${STRIP:-${CTARGET}-strip} --strip-debug "${ED}"$(alt_prefix)/*/libpthread-*.so
-       fi
-}
-
 src_install() {
        if just_headers ; then
                export ABI=default
@@ -1381,7 +1363,6 @@ src_install() {
        fi
 
        foreach_abi glibc_do_src_install
-       src_strip
 }
 
 # Simple test to make sure our new glibc isn't completely broken.
index 2846ee6a61c45fb5c056fac55610d0592e891149..b3da5c0345ed93c12bc549815f4931ec37896615 100644 (file)
@@ -11,7 +11,6 @@ inherit python-any-r1 prefix eutils eapi7-ver toolchain-funcs flag-o-matic gnuco
 DESCRIPTION="GNU libc C library"
 HOMEPAGE="https://www.gnu.org/software/libc/"
 LICENSE="LGPL-2.1+ BSD HPND ISC inner-net rc PCRE"
-RESTRICT="strip" # Strip ourself #46186
 SLOT="2.2"
 
 EMULTILIB_PKG="true"
@@ -1363,23 +1362,6 @@ glibc_headers_install() {
        dosym usr/include $(alt_prefix)/sys-include
 }
 
-src_strip() {
-       # gdb is lame and requires some debugging information to remain in
-       # libpthread, so we need to strip it by hand.  libthread_db makes no
-       # sense stripped as it is only used when debugging.
-       local pthread=$(has splitdebug ${FEATURES} && echo "libthread_db" || echo "lib{pthread,thread_db}")
-       env \
-               -uRESTRICT \
-               CHOST=${CTARGET} \
-               STRIP_MASK="/*/{,tls/}${pthread}*" \
-               prepallstrip
-       # if user has stripping enabled and does not have split debug turned on,
-       # then leave the debugging sections in libpthread.
-       if ! has nostrip ${FEATURES} && ! has splitdebug ${FEATURES} ; then
-               ${STRIP:-${CTARGET}-strip} --strip-debug "${ED}"$(alt_prefix)/*/libpthread-*.so
-       fi
-}
-
 src_install() {
        if just_headers ; then
                export ABI=default
@@ -1393,8 +1375,6 @@ src_install() {
                elog "Not installing static glibc libraries"
                find "${ED}" -name "*.a" -and -not -name "*_nonshared.a" -delete
        fi
-
-       src_strip
 }
 
 # Simple test to make sure our new glibc isn't completely broken.
index 743f14c253d428848bf03b4963e3a358356ff95c..5a8933d5d964c23b8a6f993640b6cb21498234b3 100644 (file)
@@ -11,7 +11,6 @@ inherit python-any-r1 prefix eutils eapi7-ver toolchain-funcs flag-o-matic gnuco
 DESCRIPTION="GNU libc C library"
 HOMEPAGE="https://www.gnu.org/software/libc/"
 LICENSE="LGPL-2.1+ BSD HPND ISC inner-net rc PCRE"
-RESTRICT="strip" # Strip ourself #46186
 SLOT="2.2"
 
 EMULTILIB_PKG="true"
@@ -1363,23 +1362,6 @@ glibc_headers_install() {
        dosym usr/include $(alt_prefix)/sys-include
 }
 
-src_strip() {
-       # gdb is lame and requires some debugging information to remain in
-       # libpthread, so we need to strip it by hand.  libthread_db makes no
-       # sense stripped as it is only used when debugging.
-       local pthread=$(has splitdebug ${FEATURES} && echo "libthread_db" || echo "lib{pthread,thread_db}")
-       env \
-               -uRESTRICT \
-               CHOST=${CTARGET} \
-               STRIP_MASK="/*/{,tls/}${pthread}*" \
-               prepallstrip
-       # if user has stripping enabled and does not have split debug turned on,
-       # then leave the debugging sections in libpthread.
-       if ! has nostrip ${FEATURES} && ! has splitdebug ${FEATURES} ; then
-               ${STRIP:-${CTARGET}-strip} --strip-debug "${ED}"$(alt_prefix)/*/libpthread-*.so
-       fi
-}
-
 src_install() {
        if just_headers ; then
                export ABI=default
@@ -1393,8 +1375,6 @@ src_install() {
                elog "Not installing static glibc libraries"
                find "${ED}" -name "*.a" -and -not -name "*_nonshared.a" -delete
        fi
-
-       src_strip
 }
 
 # Simple test to make sure our new glibc isn't completely broken.
index cd66539a9220dfa510cc45ee0f268b347f435f92..d529e346178ef245104d88f9f4f8aa4edd2cff57 100644 (file)
@@ -1181,11 +1181,6 @@ glibc_do_src_install() {
        # '#define VERSION "2.26.90"' -> '2.26.90'
        local upstream_pv=$(sed -n -r 's/#define VERSION "(.*)"/\1/p' "${S}"/version.h)
 
-       # gdb is lame and requires some debugging information to remain in
-       # libpthread.  libthread_db makes no sense stripped as it is only used when debugging.
-       dostrip -x $(alt_libdir)/libpthread-${upstream_pv}.so
-       dostrip -x $(alt_libdir)/libthread_db-1.0.so
-
        if [[ -e ${ED}/$(alt_usrlibdir)/libm-${upstream_pv}.a ]] ; then
                # Move versioned .a file out of libdir to evade portage QA checks
                # instead of using gen_usr_ldscript(). We fix ldscript as: