net-analyzer/nagios-core: use default homedir/shell for "nagios" user.
authorMichael Orlitzky <mjo@gentoo.org>
Sat, 31 Aug 2019 19:58:35 +0000 (15:58 -0400)
committerMichael Orlitzky <mjo@gentoo.org>
Sat, 31 Aug 2019 21:34:54 +0000 (17:34 -0400)
With GLEP81 approved, we're finally going to be able to (properly)
share the "nagios" user between the packages that require it. As part
of the migration process, I'd like to clean up its home directory and
shell usage: I'm fairly sure that the default (/dev/null and
/sbin/nologin) will work, at least for nagios-core. Whether or not
this will affect any other packages is harder to discern.

I'm using this new ~arch version of nagios-core to test things out. In
this and later versions, we'll use the default "enewuser" arguments.
If this causes a problem, it should appear only in new installs
(enewuser is a no-op on upgrades), and with any luck someone will file
a bug to say it doesn't work.

Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
net-analyzer/nagios-core/nagios-core-4.4.5-r1.ebuild [moved from net-analyzer/nagios-core/nagios-core-4.4.5.ebuild with 99% similarity]

similarity index 99%
rename from net-analyzer/nagios-core/nagios-core-4.4.5.ebuild
rename to net-analyzer/nagios-core/nagios-core-4.4.5-r1.ebuild
index 74ddb853c43eb791bf0e70e4fd495bdace5cf058..fdfccca6aabe37b78ce60ce045f8e619fbc0e550 100644 (file)
@@ -72,7 +72,7 @@ S="${WORKDIR}/${MY_P}"
 
 pkg_setup() {
        enewgroup nagios
-       enewuser nagios -1 /bin/bash /var/nagios/home nagios
+       enewuser nagios -1 -1 -1 nagios
 }
 
 src_configure() {