virtual/libc: prioritize uclibc-ng over uclibc
authorAnthony G. Basile <blueness@gentoo.org>
Tue, 27 Sep 2016 23:55:40 +0000 (19:55 -0400)
committerAnthony G. Basile <blueness@gentoo.org>
Tue, 27 Sep 2016 23:55:40 +0000 (19:55 -0400)
Package-Manager: portage-2.2.28

virtual/libc/libc-1.ebuild [new file with mode: 0644]

diff --git a/virtual/libc/libc-1.ebuild b/virtual/libc/libc-1.ebuild
new file mode 100644 (file)
index 0000000..23e8ad5
--- /dev/null
@@ -0,0 +1,18 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Virtual for the C library"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# explicitly depend on SLOT 2.2 of glibc, because it sets
+# a different SLOT for cross-compiling
+RDEPEND="!prefix-guest? (
+               elibc_glibc? ( sys-libs/glibc:2.2 )
+               elibc_musl? ( sys-libs/musl )
+               elibc_uclibc? ( || ( sys-libs/uclibc-ng sys-libs/uclibc ) )
+               elibc_FreeBSD? ( sys-freebsd/freebsd-lib )
+       )"