dev-python/pypy3: Clean old up
authorMichał Górny <mgorny@gentoo.org>
Fri, 5 Jan 2018 22:19:47 +0000 (23:19 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 5 Jan 2018 23:19:26 +0000 (00:19 +0100)
dev-python/pypy3/Manifest
dev-python/pypy3/files/2.5.0-shared-lib.patch [deleted file]
dev-python/pypy3/pypy3-5.8.0.ebuild [deleted file]

index 0cf5fe7f34104bd475bf4528c39c9989c986e024..4e6e322782336cfb2aa6c66708c4b0898f9a5af6 100644 (file)
@@ -1,3 +1,2 @@
 DIST pypy3-v5.10.0-src.tar.bz2 29075971 BLAKE2B 02fb64d514ab292e09ced57e1c206b04d0fb38353ad6ec0e836448344a6d126d0fccfb61cbd278ea3acaa227032640e82f9ffd7efe3b33ade1ca34a18831b3e4 SHA512 69a373c18dbad9dd617f994ad885c8d8975f0c484ba9dd547e6e892c9a3030a43e9e3ee668aee5f4969403883de1311cef97a0a5e5701921172ee6c2119b771b
-DIST pypy3-v5.8.0-src.tar.bz2 28986883 BLAKE2B dc6c906109269e8d1bd6b171cabf6475aa803e4326a9974ded86fbb0943798317761bc0ae0ab09829a48c073b3755c8a2bdcb03bed4b06b9a70cee061867edb6 SHA512 d78b4c899a5643028664365ed973a7b292a8e5b3989cc75203cd381ea3cda7dd73121c574726e23dca86e8364fcfcf42c372c9deee438c805f30d6e1c4ac115a
 DIST pypy3-v5.9.0-src.tar.bz2 29055111 BLAKE2B 181d87ebe4a83a3f03b28d891f248f718ad120ed54621f8054f19a65aebbe90b65c69e40ca656612356b2019aa9ac22d5e242e688a80190b046511a8ceb9c040 SHA512 3d5384d644fdd1bc8b95f5747dbd1771ae06eb2cfc7b57be359b8bf40177676afd097620d0cb9d9000c40d8cce075cfa6bfd92de987d3dd927c04d7d595dc5bd
diff --git a/dev-python/pypy3/files/2.5.0-shared-lib.patch b/dev-python/pypy3/files/2.5.0-shared-lib.patch
deleted file mode 100644 (file)
index b5c877b..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ur pypy-2.5.0-src.orig/rpython/translator/platform/posix.py pypy-2.5.0-src/rpython/translator/platform/posix.py
---- a/rpython/translator/platform/posix.py     2015-02-03 05:12:49.000000000 +0800
-+++ b/rpython/translator/platform/posix.py     2015-03-22 07:36:01.420116684 +0800
-@@ -183,7 +183,7 @@
-                    'int main(int argc, char* argv[]) '
-                    '{ return $(PYPY_MAIN_FUNCTION)(argc, argv); }" > $@')
-             m.rule('$(DEFAULT_TARGET)', ['$(TARGET)', 'main.o'],
--                   '$(CC_LINK) $(LDFLAGS_LINK) main.o -L. -l$(SHARED_IMPORT_LIB) -o $@ $(RPATH_FLAGS)')
-+                   '$(CC_LINK) $(LDFLAGS_LINK) main.o -L. -l$(SHARED_IMPORT_LIB) \'-Wl,-rpath,$$ORIGIN\' -o $@')
-         return m
diff --git a/dev-python/pypy3/pypy3-5.8.0.ebuild b/dev-python/pypy3/pypy3-5.8.0.ebuild
deleted file mode 100644 (file)
index b286c98..0000000
+++ /dev/null
@@ -1,238 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-# pypy3 needs to be built using python 2
-PYTHON_COMPAT=( python2_7 pypy )
-inherit check-reqs pax-utils python-any-r1 toolchain-funcs versionator
-
-MY_P=pypy3-v${PV}
-
-DESCRIPTION="A fast, compliant alternative implementation of the Python (3.3) language"
-HOMEPAGE="http://pypy.org/"
-SRC_URI="https://bitbucket.org/pypy/pypy/downloads/${MY_P}-src.tar.bz2"
-
-LICENSE="MIT"
-# pypy3 -c 'import sysconfig; print(sysconfig.get_config_var("SOABI"))'
-SLOT="0/58"
-KEYWORDS="~amd64 ~amd64-linux"
-IUSE="bzip2 gdbm +jit libressl low-memory ncurses sandbox sqlite tk"
-
-RDEPEND=">=sys-libs/zlib-1.1.3:0=
-       virtual/libffi:0=
-       virtual/libintl:0=
-       dev-libs/expat:0=
-       !libressl? ( dev-libs/openssl:0=[-bindist] )
-       libressl? ( dev-libs/libressl:0= )
-       bzip2? ( app-arch/bzip2:0= )
-       gdbm? ( sys-libs/gdbm:0= )
-       ncurses? ( sys-libs/ncurses:0= )
-       sqlite? ( dev-db/sqlite:3= )
-       tk? (
-               dev-lang/tk:0=
-               dev-tcltk/tix:0=
-       )
-       !dev-python/pypy3-bin:0"
-DEPEND="${RDEPEND}
-       low-memory? ( virtual/pypy:0 )
-       !low-memory? ( ${PYTHON_DEPS} )"
-#      doc? ( dev-python/sphinx )
-
-S="${WORKDIR}/${MY_P}-src"
-
-check_env() {
-       if use low-memory; then
-               CHECKREQS_MEMORY="1750M"
-               use amd64 && CHECKREQS_MEMORY="3500M"
-       else
-               CHECKREQS_MEMORY="3G"
-               use amd64 && CHECKREQS_MEMORY="6G"
-       fi
-
-       check-reqs_pkg_pretend
-}
-
-pkg_pretend() {
-       [[ ${MERGE_TYPE} != binary ]] && check_env
-}
-
-pkg_setup() {
-       if [[ ${MERGE_TYPE} != binary ]]; then
-               check_env
-
-               # unset to allow forcing pypy below :)
-               use low-memory && local EPYTHON=
-               if python_is_installed pypy && [[ ! ${EPYTHON} || ${EPYTHON} == pypy ]]; then
-                       einfo "Using PyPy to perform the translation."
-                       local EPYTHON=pypy
-               else
-                       einfo "Using ${EPYTHON:-python2} to perform the translation. Please note that upstream"
-                       einfo "recommends using PyPy for that. If you wish to do so, please install"
-                       einfo "virtual/pypy and ensure that EPYTHON variable is unset."
-               fi
-
-               python-any-r1_pkg_setup
-       fi
-}
-
-src_prepare() {
-       eapply "${FILESDIR}/4.0.0-gentoo-path.patch"
-       eapply "${FILESDIR}/1.9-distutils.unixccompiler.UnixCCompiler.runtime_library_dir_option.patch"
-       eapply "${FILESDIR}"/2.5.0-shared-lib.patch     # 517002
-
-       sed -e "s^@EPREFIX@^${EPREFIX}^" \
-               -e "s^@libdir@^$(get_libdir)^" \
-               -i lib-python/3/distutils/command/install.py || die
-
-       # apply CPython stdlib patches
-       pushd lib-python/3 > /dev/null || die
-       eapply "${FILESDIR}"/5.8.0_all_distutils_cxx.patch
-       eapply "${FILESDIR}"/python-3.5-distutils-OO-build.patch
-       popd > /dev/null || die
-
-       eapply_user
-}
-
-src_configure() {
-       tc-export CC
-
-       local args=(
-               --shared
-               $(usex jit -Ojit -O2)
-               $(usex sandbox --sandbox '')
-
-               --jit-backend=auto
-
-               pypy/goal/targetpypystandalone
-       )
-
-       # Avoid linking against libraries disabled by use flags
-       local opts=(
-               bzip2:bz2
-               ncurses:_minimal_curses
-       )
-
-       local opt
-       for opt in "${opts[@]}"; do
-               local flag=${opt%:*}
-               local mod=${opt#*:}
-
-               args+=(
-                       $(usex ${flag} --withmod --withoutmod)-${mod}
-               )
-       done
-
-       local interp=( "${PYTHON}" )
-       if use low-memory; then
-               interp=( env PYPY_GC_MAX_DELTA=200MB
-                       "${PYTHON}" --jit loop_longevity=300 )
-       fi
-
-       # translate into the C sources
-       # we're going to make them ourselves since otherwise pypy does not
-       # free up the unneeded memory before spawning the compiler
-       set -- "${interp[@]}" rpython/bin/rpython --batch --source "${args[@]}"
-       echo -e "\033[1m${@}\033[0m"
-       "${@}" || die "translation failed"
-}
-
-src_compile() {
-       emake -C "${T}"/usession*-0/testing_1
-
-       # copy back to make sys.prefix happy
-       cp -p "${T}"/usession*-0/testing_1/{pypy3-c,libpypy3-c.so} . || die
-       pax-mark m pypy3-c libpypy3-c.so
-
-       #use doc && emake -C pypy/doc html
-}
-
-src_test() {
-       # (unset)
-       local -x PYTHONDONTWRITEBYTECODE
-
-       # Test runner requires Python 2 too. However, it spawns PyPy3
-       # internally so that we end up testing the correct interpreter.
-       "${PYTHON}" ./pypy/test_all.py --pypy=./pypy3-c lib-python || die
-}
-
-src_install() {
-       local dest=/usr/$(get_libdir)/pypy3
-       einfo "Installing PyPy ..."
-       exeinto "${dest}"
-       doexe pypy3-c libpypy3-c.so
-       pax-mark m "${ED%/}${dest}/pypy3-c" "${ED%/}${dest}/libpypy3-c.so"
-       insinto "${dest}"
-       doins -r include lib_pypy lib-python
-       dosym ../$(get_libdir)/pypy3/pypy3-c /usr/bin/pypy3
-       dodoc README.rst
-
-       if ! use gdbm; then
-               rm -r "${ED%/}${dest}"/lib_pypy/_gdbm* || die
-       fi
-       if ! use sqlite; then
-               rm -r "${ED%/}${dest}"/lib-python/*3/sqlite3 \
-                       "${ED%/}${dest}"/lib_pypy/_sqlite3* \
-                       "${ED%/}${dest}"/lib-python/*3/test/test_sqlite.py || die
-       fi
-       if ! use tk; then
-               rm -r "${ED%/}${dest}"/lib-python/*3/{idlelib,tkinter} \
-                       "${ED%/}${dest}"/lib_pypy/_tkinter \
-                       "${ED%/}${dest}"/lib-python/*3/test/test_{tcl,tk,ttk*}.py || die
-       fi
-
-       # Install docs
-       #use doc && dohtml -r pypy/doc/_build/html/
-
-       einfo "Generating caches and byte-compiling ..."
-
-       local -x PYTHON=${ED%/}${dest}/pypy3-c
-       local -x LD_LIBRARY_PATH="${ED%/}${dest}"
-       # we can't use eclass function since PyPy is dumb and always gives
-       # paths relative to the interpreter
-       local PYTHON_SITEDIR=${EPREFIX}/usr/$(get_libdir)/pypy3/site-packages
-       python_export pypy3 EPYTHON
-
-       echo "EPYTHON='${EPYTHON}'" > epython.py || die
-       python_domodule epython.py
-
-       # Generate Grammar and PatternGrammar pickles.
-       "${PYTHON}" -c "import lib2to3.pygram, lib2to3.patcomp; lib2to3.patcomp.PatternCompiler()" \
-               || die "Generation of Grammar and PatternGrammar pickles failed"
-
-       # Generate cffi modules
-       # Please keep in sync with pypy/tool/build_cffi_imports.py!
-#cffi_build_scripts = {
-#    "sqlite3": "_sqlite3_build.py",
-#    "audioop": "_audioop_build.py",
-#    "tk": "_tkinter/tklib_build.py",
-#    "curses": "_curses_build.py" if sys.platform != "win32" else None,
-#    "syslog": "_syslog_build.py" if sys.platform != "win32" else None,
-#    "_gdbm": "_gdbm_build.py"  if sys.platform != "win32" else None,
-#    "pwdgrp": "_pwdgrp_build.py" if sys.platform != "win32" else None,
-#    "resource": "_resource_build.py" if sys.platform != "win32" else None,
-#    "lzma": "_lzma_build.py",
-#    "_decimal": "_decimal_build.py",
-#    "ssl": "_ssl_build.py",
-       cffi_targets=( audioop syslog pwdgrp resource lzma decimal ssl )
-       use gdbm && cffi_targets+=( gdbm )
-       use ncurses && cffi_targets+=( curses )
-       use sqlite && cffi_targets+=( sqlite3 )
-       use tk && cffi_targets+=( tkinter/tklib )
-
-       local t
-       # all modules except tkinter output to .
-       # tkinter outputs to the correct dir ...
-       cd "${ED%/}${dest}"/lib_pypy || die
-       for t in "${cffi_targets[@]}"; do
-               # tkinter doesn't work via -m
-               "${PYTHON}" "_${t}_build.py" || die "Failed to build CFFI bindings for ${t}"
-       done
-
-       # Cleanup temporary objects
-       find "${ED%/}${dest}" -name "_cffi_*.[co]" -delete || die
-       find "${ED%/}${dest}" -type d -empty -delete || die
-
-       # compile the installed modules
-       python_optimize "${ED%/}${dest}"
-}