Fix issue that was mentioned post-fix in bug #156422: don't use tset as it is an...
authorFabian Groffen <grobian@gentoo.org>
Tue, 5 Dec 2006 14:58:35 +0000 (14:58 +0000)
committerFabian Groffen <grobian@gentoo.org>
Tue, 5 Dec 2006 14:58:35 +0000 (14:58 +0000)
Package-Manager: portage-2.1.1-r2

app-shells/tcsh/ChangeLog
app-shells/tcsh/files/digest-tcsh-6.14-r5 [new file with mode: 0644]
app-shells/tcsh/files/tcsh-6.14-r4.patch
app-shells/tcsh/tcsh-6.14-r5.ebuild [new file with mode: 0644]

index e297d668a53051510cdbe998f0dc4d611ed533cc..1c70bf6b35552e4d04b3aaa29469275564bf2f11 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for app-shells/tcsh
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/ChangeLog,v 1.64 2006/12/02 14:03:37 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/ChangeLog,v 1.65 2006/12/05 14:58:35 grobian Exp $
+
+*tcsh-6.14-r5 (05 Dec 2006)
+
+  05 Dec 2006; Fabian Groffen <grobian@gentoo.org> files/tcsh-6.14-r4.patch,
+  -tcsh-6.14-r4.ebuild, +tcsh-6.14-r5.ebuild:
+  Fix issue that was mentioned post-fix in bug #156422: don't use tset as it
+  is an interactive tool, which is evil.
 
 *tcsh-6.14-r4 (02 Dec 2006)
 
diff --git a/app-shells/tcsh/files/digest-tcsh-6.14-r5 b/app-shells/tcsh/files/digest-tcsh-6.14-r5
new file mode 100644 (file)
index 0000000..c15c253
--- /dev/null
@@ -0,0 +1,6 @@
+MD5 06d9a00fa7e034394bf1152f0fc3e950 tcsh-6.14-conffiles.tar.bz2 20200
+RMD160 96e5e43985fe1b6e53b4a2a53f1b7bed3c2ae103 tcsh-6.14-conffiles.tar.bz2 20200
+SHA256 1bae5000c84593187974580c48b0edcec88e2f6363e3c1ec1e43da45c9a63049 tcsh-6.14-conffiles.tar.bz2 20200
+MD5 353d1bb7d2741bf8de602c7b6f0efd79 tcsh-6.14.00.tar.gz 859780
+RMD160 fa7635225ceb0225aedcfad5dd9d8e17d8d70849 tcsh-6.14.00.tar.gz 859780
+SHA256 fd738ac0c003d283a214d15d46c1bc3fb80afad697110994dccb8d101f0d6f0e tcsh-6.14.00.tar.gz 859780
index 4fd24f0654c68b7063c22843766c147340dd235c..a9628b78df0cb748d3cc3e634dd615f6d3742c2f 100644 (file)
  ##     Resolved reported bug on MOTD (disabled it)
  ## 2003-01-13  --  Alain Penders (alain@gentoo.org)
  ##     Initial version.  Inspired by the Suse version.
-@@ -16,7 +19,7 @@
+@@ -14,9 +17,7 @@
+     # Console
+     if ( ! ${?TERM} )           setenv TERM linux
      if ( "$TERM" == "unknown" ) setenv TERM linux
-     # No tset available on SlackWare
+-    # No tset available on SlackWare
      if ( -x "`which stty`" ) stty sane cr0 pass8 dec
 -    if ( -x "`which tset`" ) tset -I -Q
-+    if ( -x "`which tset`" ) eval `tset -Q -I -s`
      unsetenv TERMCAP
      settc km yes
  endif
diff --git a/app-shells/tcsh/tcsh-6.14-r5.ebuild b/app-shells/tcsh/tcsh-6.14-r5.ebuild
new file mode 100644 (file)
index 0000000..416c2db
--- /dev/null
@@ -0,0 +1,74 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.14-r5.ebuild,v 1.1 2006/12/05 14:58:35 grobian Exp $
+
+inherit eutils
+
+MY_P="${P}.00"
+DESCRIPTION="Enhanced version of the Berkeley C shell (csh)"
+HOMEPAGE="http://www.tcsh.org/"
+SRC_URI="ftp://ftp.astron.com/pub/tcsh/${MY_P}.tar.gz
+       mirror://gentoo/${P}-conffiles.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="perl catalogs"
+
+DEPEND=">=sys-libs/ncurses-5.1
+       perl? ( dev-lang/perl )
+       !app-shells/csh" # bug #119703
+
+S=${WORKDIR}/${MY_P}
+
+
+src_unpack() {
+       unpack ${A}
+       epatch "${FILESDIR}/${MY_P}"-debian-dircolors.patch # bug #120792
+       epatch "${FILESDIR}/${P}"-r2.patch
+       epatch "${FILESDIR}/${P}"-makefile.patch # bug #151951
+       epatch "${FILESDIR}/${P}"-r4.patch
+
+       if use catalogs ; then
+               einfo "enabling NLS catalogs support..."
+               sed -i -e "s/#undef NLS_CATALOGS/#define NLS_CATALOGS/" \
+                       ${WORKDIR}/${MY_P}/config_f.h || die
+               eend $?
+       fi
+}
+
+src_compile() {
+       econf --prefix=/ || die "econf failed"
+       emake || die "compile problem"
+}
+
+src_install() {
+       emake DESTDIR="${D}" install install.man || die
+
+       if use perl ; then
+               perl tcsh.man2html || die
+               dohtml tcsh.html/*.html
+       fi
+
+       insinto /etc
+       doins \
+               "${WORKDIR}"/gentoo/csh.cshrc \
+               "${WORKDIR}"/gentoo/csh.login
+
+       insinto /etc/profile.d
+       doins \
+               "${WORKDIR}"/gentoo/tcsh-bindkey.csh \
+               "${WORKDIR}"/gentoo/tcsh-settings.csh
+
+       dodoc FAQ Fixes NewThings Ported README WishList Y2K
+
+       docinto examples
+       dodoc \
+               "${WORKDIR}"/gentoo/tcsh-aliases \
+               "${WORKDIR}"/gentoo/tcsh-complete \
+               "${WORKDIR}"/gentoo/tcsh-gentoo_legacy \
+               "${WORKDIR}"/gentoo/tcsh.config
+
+       # bug #119703: add csh -> tcsh symlink
+       dosym /bin/tcsh /bin/csh
+}