app-portage/pram: Bump to v6
authorMichał Górny <mgorny@gentoo.org>
Fri, 24 May 2019 21:22:48 +0000 (23:22 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 24 May 2019 21:43:01 +0000 (23:43 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-portage/pram/Manifest
app-portage/pram/pram-6.ebuild [new file with mode: 0644]

index 09557f68a403ee9c9de7ef8762846a29ef6d6d09..b69385ffd65b7fffe2f818866a29fb9d7eda0d02 100644 (file)
@@ -1,2 +1,3 @@
 DIST pram-3.tar.gz 4334 BLAKE2B f06f9cfe938f83702baaa8f8bee06937e8790e533e14ab419251934d0f4300ee75d5377a4f4e0e47a774bd3c25ef31236d7e451b929cfbfe8343d226a311ca2d SHA512 526149523b748b57095ecb3eb23f6808ab57ee1d8dc60e27067931d269ce3465ad8a0e54e8edaa3a1f74fd0a8dd135fe4a92779382ba6e367112016bc254fc98
 DIST pram-5.tar.gz 4443 BLAKE2B 0c5d1ddfa44944e8480cffd0b4f49d6143fff36ed690c9e7c0acbdd54ae6ea50b6c1610c65914c2626a260c9de1084b42e101ca38952a3e8fb9264663c3ad00c SHA512 7634bcaac11c999e2ef01d5e12305d96032396ce624cc6085b4954583aebf6d54f0a1155604863d1aeda1c2bdf17ddcfd81b833decddfbe11eb8689297c70b23
+DIST pram-6.tar.gz 7455 BLAKE2B d897038ef841e389f46c0467b71630a1447abe508556f952632db5a4d68b31a98f32e3d8633a215c8484ae69b850dddb16aad584d9a95dafb5d876439a61a56b SHA512 3dc2ef116d1433508d48fa93d7515e50bb8b7daefd64874c4f78c114bb2ac96d23f519360915776156bdfa8b5634efb8d5fadd6c30629c2022aefd99fc3ba053
diff --git a/app-portage/pram/pram-6.ebuild b/app-portage/pram/pram-6.ebuild
new file mode 100644 (file)
index 0000000..61c091c
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Tool to ease merging Pull Requests and git patches"
+HOMEPAGE="https://github.com/mgorny/pram"
+SRC_URI="https://github.com/mgorny/pram/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-vcs/git
+       net-misc/wget[ssl]
+       virtual/editor
+       !dev-perl/Gentoo-App-Pram"
+DEPEND="
+       test? (
+               ${RDEPEND}
+               app-crypt/gnupg
+               sys-apps/diffutils
+       )"