dev-python/django-cacheops: cache with automatic event-driven invalidation
authorWilliam Hubbs <william.hubbs@sony.com>
Mon, 15 Jul 2019 23:13:01 +0000 (18:13 -0500)
committerWilliam Hubbs <williamh@gentoo.org>
Mon, 15 Jul 2019 23:16:09 +0000 (18:16 -0500)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: William Hubbs <williamh@gentoo.org>
dev-python/django-cacheops/Manifest [new file with mode: 0644]
dev-python/django-cacheops/django-cacheops-4.1.ebuild [new file with mode: 0644]
dev-python/django-cacheops/metadata.xml [new file with mode: 0644]

diff --git a/dev-python/django-cacheops/Manifest b/dev-python/django-cacheops/Manifest
new file mode 100644 (file)
index 0000000..5154104
--- /dev/null
@@ -0,0 +1 @@
+DIST django-cacheops-4.1.tar.gz 53766 BLAKE2B f74fa8b93700fa930f31e8db83b161c48eb520894d3e2072bf50ca4e18b20a8563438ac95ef5920a1371b3215a0d3b7c2a216a9d1f040cc51f4d468da438a966 SHA512 ea66f0744d9b0e3b03e92ee7083c17150c050a992e25159c50f766898d7ab9e2bcb0432db135abcc2dac0358aaaa7d2e86a8216ddf9afcdbb6c7400c3844ac02
diff --git a/dev-python/django-cacheops/django-cacheops-4.1.ebuild b/dev-python/django-cacheops/django-cacheops-4.1.ebuild
new file mode 100644 (file)
index 0000000..af2b574
--- /dev/null
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="ORM cache with automatic granular event-driven invalidation for Django"
+HOMEPAGE="https://github.com/Suor/django-cacheops"
+SRC_URI="mirror://pypi/${PN:0:1}"/${PN}/${P}.tar.gz
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=">=dev-python/django-1.8[${PYTHON_USEDEP}]
+       >=dev-python/redis-py-2.9.1[${PYTHON_USEDEP}]
+       >=dev-python/funcy-1.8[${PYTHON_USEDEP}]
+       >=dev-python/six-1.4.0[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
diff --git a/dev-python/django-cacheops/metadata.xml b/dev-python/django-cacheops/metadata.xml
new file mode 100644 (file)
index 0000000..5d3d9dc
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>python@gentoo.org</email>
+       </maintainer>
+       <maintainer type="person">
+               <email>williamh@gentoo.org</email>
+               <name>William Hubbs</name>
+       </maintainer>
+</pkgmetadata>