media-libs/libvisio: Fix tests (bugs 563326, 556922); drop old
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>
Sat, 6 Feb 2016 23:13:43 +0000 (00:13 +0100)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Mon, 22 Feb 2016 17:06:15 +0000 (18:06 +0100)
All tests passed.

Package-Manager: portage-2.2.27

media-libs/libvisio/files/libvisio-0.1.3-fix-importtest.patch [new file with mode: 0644]
media-libs/libvisio/files/libvisio-0.1.3-tests-without-tools.patch [new file with mode: 0644]
media-libs/libvisio/libvisio-0.1.3-r1.ebuild
media-libs/libvisio/libvisio-0.1.3.ebuild [deleted file]

diff --git a/media-libs/libvisio/files/libvisio-0.1.3-fix-importtest.patch b/media-libs/libvisio/files/libvisio-0.1.3-fix-importtest.patch
new file mode 100644 (file)
index 0000000..f7e7035
--- /dev/null
@@ -0,0 +1,25 @@
+From a97d30ad693374deab404ec31fe00665882cc949 Mon Sep 17 00:00:00 2001
+From: David Tardon <dtardon@redhat.com>
+Date: Mon, 18 Jan 2016 13:53:19 +0100
+Subject: [PATCH] tdf#92396 test must be run in specific time zone
+
+Change-Id: Idc9d85ae8c5c1a6eccca7e830baa05a867ac4402
+---
+ src/test/Makefile.am |    3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/src/test/Makefile.am b/src/test/Makefile.am
+index 59d3419..23049b5 100644
+--- a/src/test/Makefile.am
++++ b/src/test/Makefile.am
+@@ -29,4 +29,7 @@ EXTRA_DIST = \
+            data/dwg.vsdx \
+            $(test_SOURCES)
++# ImportTest::testVsdMetadataTitleUtf8 checks formatted date string
++AM_TESTS_ENVIRONMENT = TZ=CET; export TZ;
++
+ TESTS = test
+-- 
+1.7.9.5
+
diff --git a/media-libs/libvisio/files/libvisio-0.1.3-tests-without-tools.patch b/media-libs/libvisio/files/libvisio-0.1.3-tests-without-tools.patch
new file mode 100644 (file)
index 0000000..78eb9fe
--- /dev/null
@@ -0,0 +1,12 @@
+--- a/configure.ac     2015-07-25 09:29:53.000000000 +0200
++++ b/configure.ac     2016-02-07 00:19:30.534383076 +0100
+@@ -317,6 +317,9 @@
+ )
+ AS_IF([test "x$enable_tests" = "xyes"], [
+     PKG_CHECK_MODULES([CPPUNIT], [cppunit])
++    PKG_CHECK_MODULES([REVENGE_STREAM],[
++        librevenge-stream-0.0
++    ])
+ ], [])
+ AC_SUBST([CPPUNIT_CFLAGS])
+ AC_SUBST([CPPUNIT_LIBS])
index 0770f0fd1d4a74660c0b1a383eddaac3e4f53448..8c2449a7e3c1ae1449e112d5459f558df229a6af 100644 (file)
@@ -1,12 +1,12 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
 EAPI=5
 
 EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libvisio/"
-inherit base eutils
-[[ ${PV} == 9999 ]] && inherit autotools git-r3
+inherit autotools eutils
+[[ ${PV} == 9999 ]] && inherit git-r3
 
 DESCRIPTION="Library parsing the visio documents"
 HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libvisio"
@@ -33,12 +33,18 @@ DEPEND="${RDEPEND}
        test? ( dev-util/cppunit )
 "
 
+PATCHES=(
+       "${FILESDIR}/${P}-fix-tests.patch"
+       "${FILESDIR}/${P}-fix-importtest.patch"
+       "${FILESDIR}/${P}-tests-without-tools.patch"
+       "${FILESDIR}/${P}-boost-1.59.patch"
+)
+
 src_prepare() {
-       epatch "${FILESDIR}/${P}-fix-tests.patch" \
-               "${FILESDIR}/${P}-boost-1.59.patch"
+       epatch "${PATCHES[@]}"
+       epatch_user
        [[ -d m4 ]] || mkdir "m4"
-       base_src_prepare
-       [[ ${PV} == 9999 ]] && eautoreconf
+       eautoreconf
 }
 
 src_configure() {
diff --git a/media-libs/libvisio/libvisio-0.1.3.ebuild b/media-libs/libvisio/libvisio-0.1.3.ebuild
deleted file mode 100644 (file)
index 591d1b3..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libvisio/"
-inherit base eutils
-[[ ${PV} == 9999 ]] && inherit autotools git-r3
-
-DESCRIPTION="Library parsing the visio documents"
-HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libvisio"
-[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
-
-LICENSE="|| ( GPL-2+ LGPL-2.1 MPL-1.1 )"
-SLOT="0"
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86"
-IUSE="doc static-libs test tools"
-
-RDEPEND="
-       dev-libs/icu:=
-       dev-libs/librevenge
-       dev-libs/libxml2
-       sys-libs/zlib
-"
-DEPEND="${RDEPEND}
-       >=dev-libs/boost-1.46
-       dev-util/gperf
-       sys-devel/libtool
-       virtual/pkgconfig
-       doc? ( app-doc/doxygen )
-       test? ( dev-util/cppunit )
-"
-
-src_prepare() {
-       [[ -d m4 ]] || mkdir "m4"
-       base_src_prepare
-       [[ ${PV} == 9999 ]] && eautoreconf
-}
-
-src_configure() {
-       econf \
-               --docdir="${EPREFIX}/usr/share/doc/${PF}" \
-               $(use_enable static-libs static) \
-               --disable-werror \
-               $(use_with doc docs) \
-               $(use_enable test tests) \
-               $(use_enable tools)
-}
-
-src_install() {
-       default
-       prune_libtool_files --all
-}