net-libs/libproxy: backport patch from upstream solving build failure with USE="mono"
authorMichael Palimaka <kensington@gentoo.org>
Thu, 23 Feb 2017 10:10:27 +0000 (21:10 +1100)
committerMichael Palimaka <kensington@gentoo.org>
Thu, 23 Feb 2017 10:10:37 +0000 (21:10 +1100)
Gentoo-bug: 600254

Package-Manager: Portage-2.3.3, Repoman-2.3.1

net-libs/libproxy/files/libproxy-0.4.13-cmake-37.patch [new file with mode: 0644]
net-libs/libproxy/libproxy-0.4.13-r2.ebuild

diff --git a/net-libs/libproxy/files/libproxy-0.4.13-cmake-37.patch b/net-libs/libproxy/files/libproxy-0.4.13-cmake-37.patch
new file mode 100644 (file)
index 0000000..d96879a
--- /dev/null
@@ -0,0 +1,27 @@
+From 72bda7188408bd3c2491ea664da294cc483220bc Mon Sep 17 00:00:00 2001
+From: Andrey Rakhmatullin <wrar@wrar.name>
+Date: Sun, 20 Nov 2016 18:40:49 +0500
+Subject: [PATCH] Set CMP0054 CMake policy to NEW.
+
+CMake 3.7 exports a "t" variable for all projects and because of that
+the elseif statement in cmake/CMakeCSharpInformation.cmake:311 works
+incorrectly if CMP0054 is not set to NEW (as "t" is expanded to the
+variable value).
+---
+ CMakeLists.txt | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 5313787..451e7a6 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -3,6 +3,9 @@ cmake_minimum_required(VERSION 2.6)
+ if(POLICY CMP0011)
+    cmake_policy(SET CMP0011 NEW)
+ endif(POLICY CMP0011)
++if(POLICY CMP0054)
++   cmake_policy(SET CMP0054 NEW)
++endif(POLICY CMP0054)
+ # Make sure we look in our cmake folder for additional definitions
+ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_SOURCE_DIR}/cmake )
index 725f7d5c0802f732d1aa2f3a7523ecc15d55f47b..a5f0d30071efcd79fe70d8e5278808d8a5ce5dee 100644 (file)
@@ -55,6 +55,9 @@ PATCHES=(
 
        # https://github.com/libproxy/libproxy/issues/27
        "${FILESDIR}/${PN}-0.4.12-macosx.patch"
+
+       # bug 600254
+       "${FILESDIR}/${P}-cmake-37.patch"
 )
 
 multilib_src_configure() {