media-video/mplay-sh: Bump to EAPI 7
authorMichał Górny <mgorny@gentoo.org>
Sun, 10 Nov 2019 08:38:09 +0000 (09:38 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 10 Nov 2019 08:53:01 +0000 (09:53 +0100)
Closes: https://bugs.gentoo.org/697258
Signed-off-by: Michał Górny <mgorny@gentoo.org>
media-video/mplay-sh/mplay-sh-0.5.3-r1.ebuild

index 0f6b9838c2c82bdce46dee7e4191293562a1c9e8..da819c2dd0db533ea69fcc3e9b7a8bd3941945bc 100644 (file)
@@ -1,34 +1,33 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
-
-inherit eutils
+EAPI=7
 
 MY_P="mplay-${PV}"
 
 DESCRIPTION="mplayer wrapper script as backend for vdr-mplayer"
-HOMEPAGE="http://www.vdr-portal.de/board/thread.php?threadid=62306"
+HOMEPAGE="https://www.vdr-portal.de/board/thread.php?threadid=62306"
 SRC_URI="mirror://gentoo/${MY_P}.tgz
        https://dev.gentoo.org/~zzam/distfiles/${MY_P}.tgz"
+S=${WORKDIR}/${MY_P}
 
 KEYWORDS="~amd64 x86"
 SLOT="0"
 LICENSE="GPL-2"
 IUSE=""
 
+# for vdr user?
 DEPEND="media-tv/gentoo-vdr-scripts"
-RDEPEND=">=media-video/mplayer-0.90_rc4"
+RDEPEND="${DEPEND}
+       >=media-video/mplayer-0.90_rc4"
 
-S=${WORKDIR}/${MY_P}
+src_prepare() {
+       default
 
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
        sed -i mplay.sh \
-               -e 's#$CONFDIR/silence.wav#/usr/share/vdr/mplay-sh/silence.wav#'
+               -e 's#$CONFDIR/silence.wav#/usr/share/vdr/mplay-sh/silence.wav#' || die
        sed -i conf.examples/mplayrc \
-               -e 's#^MPLAY_PLAY.*#MPLAY_PLAY="/var/vdr/tmp/mplay.play"#'
+               -e 's#^MPLAY_PLAY.*#MPLAY_PLAY="/var/vdr/tmp/mplay.play"#' || die
 }
 
 src_install() {
@@ -41,7 +40,8 @@ src_install() {
        insinto /usr/share/vdr/mplay-sh
        doins conf.examples/silence.wav
 
-       dodoc README* HISTORY
+       dodoc HISTORY README*
+
        keepdir /var/vdr/tmp
-       chown vdr:vdr -R "${D}/var/vdr"
+       fowners -R vdr:vdr /var/vdr
 }