dev-python/publicsuffix: bump
authorMatthew Thode <prometheanfire@gentoo.org>
Tue, 21 Apr 2020 18:20:30 +0000 (13:20 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Tue, 21 Apr 2020 18:20:57 +0000 (13:20 -0500)
Closes: https://bugs.gentoo.org/718770
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/publicsuffix/Manifest
dev-python/publicsuffix/publicsuffix-2.20191221.ebuild [new file with mode: 0644]

index 69154581c960a323361ccb155b9a92ea54adc2a0..ae5f876ba06a9fd93787524816ce54eba9026f17 100644 (file)
@@ -1 +1,2 @@
 DIST publicsuffix2-2.20190205.tar.gz 84498 BLAKE2B 978b788aee4c40d687aff8d140e426658779bc913c846e420147e48f2837582991ff2900c7a483814c5b908c9771e04e04f41bf35795c2d2d1299c5513840e35 SHA512 359052a2b41f63be3f87b23605b5229424f2dcf06b5bd9e9b5f1988cf9df5171188b94d54ed0be37099d94afd6efe6cfa75be27aef262e6c5af0ded61dfc6258
+DIST publicsuffix2-2.20191221.tar.gz 99592 BLAKE2B 3e96f2b1d23a70827758eb4440892719deabdb9a67a2144fefd2d4b23e26dec0d19f6d9fd4de504d5d52c0250719ef85e929b4a2b92b7ba8896ed4055480d0d8 SHA512 d863f0937b340958ef7c8bd07d62054aead993ba31b0c2753631f2e75e48f7cea412c6501d8a94d98bf6a97a13eb0716c24a89e336787d5570e9af0386c58320
diff --git a/dev-python/publicsuffix/publicsuffix-2.20191221.ebuild b/dev-python/publicsuffix/publicsuffix-2.20191221.ebuild
new file mode 100644 (file)
index 0000000..67cd947
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+inherit distutils-r1
+
+DESCRIPTION="Get a public suffix for a domain name using the Public Suffix List."
+HOMEPAGE="https://github.com/nexB/python-publicsuffix2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}2/${PN}2-${PV}.tar.gz"
+S="${WORKDIR}/${PN}2-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+       >=dev-python/requests-2.7.0[${PYTHON_USEDEP}]"
+BDEPEND=""