dev-python/neovim-python-client: Drop old versions
authorMatt Turner <mattst88@gentoo.org>
Wed, 5 Feb 2020 06:46:21 +0000 (22:46 -0800)
committerMatt Turner <mattst88@gentoo.org>
Wed, 5 Feb 2020 06:56:27 +0000 (22:56 -0800)
Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-python/neovim-python-client/Manifest
dev-python/neovim-python-client/neovim-python-client-0.3.1-r1.ebuild [deleted file]
dev-python/neovim-python-client/neovim-python-client-0.3.2-r1.ebuild [deleted file]

index bf5ade42e37c663058d1c2e1859314329eb4733f..6fd7565b13a57e55f32f34bd91b31c1c601d0fc5 100644 (file)
@@ -1,3 +1 @@
-DIST neovim-python-client-0.3.1.tar.gz 51626 BLAKE2B 80e68d02d41c7891fb88e9386866f87a1c78acc9e279de4ce4c7022333f8da3b68ffe7c598c84ff9c6386458639b6ffb4aecbfe72288866dc147ffc6197e94e2 SHA512 9c1599aabce9f0e1133364f8e91dd1b57cee107a11d400f530218ec7ad157c2f58134c1e7e8fc27649b4d8953e27c51bf6e4f0e7565d8c3dab94788759eea229
-DIST neovim-python-client-0.3.2.tar.gz 51954 BLAKE2B 8e0a5eb510797db260ab501b751921f5c98551a06cf874eecff270f5f92da5d24539b857b4cc08494be9dfed139fd3bcab1cdea75ee87d99cece8e1f48f7a1c5 SHA512 c6d7c1a2955c63ac2f59bc57e190886fe0ee0238951ac26205b537d394b2ce2fee3611e8651ae1da5e6e7b3a1bd3bea36912b918b26e01bbb3354ddc2fbd77fc
 DIST neovim-python-client-0.4.0.tar.gz 53443 BLAKE2B de37fde43e90e8277f3c69cedde9226e929f122cc2ff3030766fa716069114bffb27ea9489f2de87c69d3e7a8e0ecc22397a94168cee542d37dc827dc3ed3d13 SHA512 4b3b0e295181cf8886850477d01daba1cba8ac456aedadc5b3881b0b4910724450c4e7774282f6edf3e322792b697ae8e925f40b2a0b181a95eee48aef42a97a
diff --git a/dev-python/neovim-python-client/neovim-python-client-0.3.1-r1.ebuild b/dev-python/neovim-python-client/neovim-python-client-0.3.1-r1.ebuild
deleted file mode 100644 (file)
index 22c82fe..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_6} )
-inherit distutils-r1
-
-DESCRIPTION="Python client for Neovim"
-HOMEPAGE="https://github.com/neovim/pynvim"
-SRC_URI="https://github.com/neovim/pynvim/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="
-       dev-python/msgpack[${PYTHON_USEDEP}]
-       virtual/python-greenlet[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' python2_7)"
-
-RDEPEND="
-       ${DEPEND}
-       >=app-editors/neovim-0.2.1"
-
-S="${WORKDIR}/pynvim-${PV}"
-
-python_prepare_all() {
-       # allow useage of renamed msgpack
-       sed -i '/^msgpack/d' setup.py || die
-       distutils-r1_python_prepare_all
-}
diff --git a/dev-python/neovim-python-client/neovim-python-client-0.3.2-r1.ebuild b/dev-python/neovim-python-client/neovim-python-client-0.3.2-r1.ebuild
deleted file mode 100644 (file)
index f424f4b..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{2_7,3_{6,7}} )
-inherit distutils-r1
-
-DESCRIPTION="Python client for Neovim"
-HOMEPAGE="https://github.com/neovim/pynvim"
-SRC_URI="https://github.com/neovim/pynvim/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-
-DEPEND="
-       dev-python/msgpack[${PYTHON_USEDEP}]
-       virtual/python-greenlet[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' python2_7)"
-
-RDEPEND="
-       ${DEPEND}
-       app-editors/neovim"
-
-S="${WORKDIR}/pynvim-${PV}"
-
-python_prepare_all() {
-       # allow useage of renamed msgpack
-       sed -i '/^msgpack/d' setup.py || die
-       distutils-r1_python_prepare_all
-}